Last reply by 01-24-2022 Solved
Start a Discussion
2 Jasper
2 Jasper

XPS 17 9700, crashes when sleeping, fingerprint to blame?

I've had the new XPS 17 for just over a month and it has a significant problem - it crashes and restarts when in sleep mode both when plugged in or unplugged. It seems that the Goodix fingerprint reader driver is the culprit, but not really sure what to do about it. Below is what I did to identify the Goodix device.

I noticed that SupportAssistant lists each BSOD in its history tab (a lot more clearly than the Windows Event Viewer) and I could see crashes there that were at the times when the laptop was sleeping.


I called Dell support and let the support engineer remote onto my Laptop. He downloaded and ran BlueScreenView https://www.nirsoft.net/utils/blue_screen_view.html. This was new to me so watched with interest. BlueScreenView lists and inspects all the minidumps created when Windows crashes and all 5 in my case were DRIVER_POWER_STATE_FAILURE related.

Annotation 2020-08-01 081553.png

The engineer then decided to manually reinstall all my drivers which seemed like it was a bit sledge hammer as an approach and took him over an hour. Later the same day (yesterday) same thing: came back to the laptop after it was sleeping and it had crashed and restarted. You can see this in support assistant above.

This morning I've dug into it a bit. DRIVER_POWER_STATE_FAILURE results under lots of conditions but relates to a device driver not responding correctly to Windows power management. Power management has become more and more complex over time as hardware and software designers try to preserve battery thus this type of failure is quite common. You can install the preview version of WinDbg (Windows Debugger) from the Microsoft Store. I loaded each dump into this tool and learnt that once loaded you can run !analyze

10: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

A driver has failed to complete a power IRP within a specific time.
Arg1: 0000000000000006, The device did not complete its Directed Power Transition callback successfully.
Arg2: ffffdf82f90159a0, The POP_FX_DEVICE object
Arg3: 0000000000000000, If this was a Directed Power Down(1) or Power Up(0) completion
Arg4: 0000000000000000

and in the case of my particular failures you can run  

dt _POP_FX_DEVICE ffffdf82f90159a0

To list the details of the driver which was receiving the IO Request Packet (Windows command sent to drivers). In my case this is always:

  +0x4a0 FriendlyName     : _UNICODE_STRING "Goodix fingerprint (\_SB.PCI0.XHC.RHUB.HS01)"

 I don't have a resolution to this but perhaps someone can suggest something as the Dell engineer was a bit out of his depth with this. I guess at this point its one of two things. The fingerprint reader hardware is faulty or there is a bug in the driver.

Solutions (2)

Accepted Solutions
2 Jasper
2 Jasper

Since this I have had a further crash today (seems to be at a frequency of a couple a day). I have gone in to the Goodix fingerprint properties from the device manager and changed the Power Management settings. I have unticked "Allow the computer to turn off this device to save power"

Goodix fingerprint props.png

Will update if that stops it or not.

View solution in original post

2 Bronze
2 Bronze

Yes, there is 



View solution in original post

Replies (36)
2 Jasper
2 Jasper

Since this I have had a further crash today (seems to be at a frequency of a couple a day). I have gone in to the Goodix fingerprint properties from the device manager and changed the Power Management settings. I have unticked "Allow the computer to turn off this device to save power"

Goodix fingerprint props.png

Will update if that stops it or not.


So far so good. after several long sleep mode periods both while charging and while not no further crashes yet.

superficially it seems to me as though the two tick box settings are actually mutually exclusive. allowing the device to wake the laptop from sleep and have the operating system power it down to save on battery seem to contradict each other. Maybe someone can explain that better to me.


Pretty convinced now that this setting has fixed the issue for me. one thing to add is that I am on windows 10 2004 May 2020 update and the Goodix driver is the latest on the Dell support site Version, A00

3 Argentum

 Until the problem is solved, I have a workaround solution for you. Here it is:

When you log in, and you can click on your username and type your password, after it opens up, try this.


Right-click on the fingerprint near the clock, left-click check for updates. It should update for you unless you already updated this. Then right-click on it again, left-click fingerprint enrollment. Click on the fingers that are giving you trouble. Do a slow swipe. and press down. Do a middle swipe, tilt a little to the left, tilt a little to the right and just try to swipe the last one like you would normally press to log in. Make sure to swipe slowly, I think this is the key to registering your fingers. After you have them re-registered, logging in should be easy. Like I said, when I see the login screen, I wait about 5 seconds, swipe my finger and I'm in.


To swipe to log in, you don't have to go straight. You can swipe backward, sometimes even go to the one side a little and it will log in. If the first one fails, then wait about 5 seconds in between swipes.


Hope you get it working. I just don't use mine for anything else like passwords in my browser, as I already have my passwords backed up in a secure location.



Thanks for the suggestion @RuskinF 

Just to be clear, my issue wasn't that the fingerprint reader device wasn't working as a fingerprint reader. It does this without issue.

The issue was that when the laptop was in sleep mode it would blue screen while no body was using it. My investigation (detailed in my original post) pointed to the Goodix fingerprint reader causing the crashes due to failing to handle power management commands from Windows 10 while the laptop was sleeping.

Changing the power management settings as I detailed in my follow up post seems to have stopped the laptop from crashing while it sleeps.


@Steven Pavett Since it's been a few months since you posted, has this issue come back? Or did your fix work for you? I started having this same issue today and am going to try it out.


Am having exactly the same problem with a brand new XPS 13 2-in-1 9310. Observing an average of one BSOD per day over the last week.

Have confirmed by running WinDbg that Goodix fingerprint is to blame.

Following the solution proposed by @Steven Pavett , will see what happens.




I can now confirm that the proposed solution seems to have fixed my problem: on the 5th consecutive day without a BSOD now.



@ChristosEdinburgh @jwills292 Glad it worked out for someone else! It did seem to stop the issue for me also

In the end I did a full reinstall after Dell replaced the motherboard. After that I didn't have to change this setting anymore (both checkboxes are ticked) so perhaps the issue is related to the earlier motherboard.

Dell changed the board due to a recognized issue with early XPS 9700 models not being able to draw the full power from the power supply resulting in the battery discharging when doing something like playing a game even when the laptop was plugged in.

Latest Solutions
Top Contributor