vWorkspace

Last reply by 03-31-2021 Solved
Start a Discussion
3 Silver

How to unlock (cltr-alt-end) on Apple MAC

Some of our clients use the MAC connector to connect to our vWorkspace VDI environment.

We have setup a screensaver that locks the screen after some minutes.

On a windows PC, the user can press CTRL-ALT-END to unlock the screen.

However, on MAC's without the END button, users can't get out of this unlock screen.

We have tried different combinations, but nothing seems to work.

Any idea's?

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze

I ran into the same problem. I work with a MacBook Air. What worked for me was the combination fn-control-alt/option-delete. Hope this helps any of you!

View solution in original post

Community Accepted Solution
Replies (17)
3 Argentum

Hi René,
On a Windows PC the CTRL-ALT-END key combination can be used to send the CTRL-ALT-DEL sequence to the remote session. As you rightly point out this is not possible on a MAC keyboard. For a MAC the key sequence to use is actually CTRL-ALT-DEL.  If after trying this you still have problems please reply back with details of the remote system you are connecting to, Windows XP or 7 etc..
3 Silver

Hello David,

You are right, when the keyboard has a DEL button, CTRL-ALT-DEL works on a MAC.
However, on notebooks and some smaller MAC keyboards (like the wireless keyboard), there is no DEL key.

For example, I have a macbook air without the DEL key.

Apple says you should press FN-BACKSPACE is the same as DEL.

So the combination would be : CTRL-ALT-FN-BACKSPACE

But that doesn't work. I even tried FN-CTRL-ALT-CMD-BACKSPACE without luck.

The remote clients are Windows XP.

I managed to get the following key function to work Command-option-control-fn-Right arrow

 

tested it, and it works

3 Argentum

Hello René,

I now have a smaller MAC keyboard (the wireless keyboard) in US English format. Using this keyboard I was able to perform the keystoke CTRL-ALT-FN-DEL this worked. I believe that non-English keyboards may have this key mapped to a different function.

Can you try something for me to test this further, open a document and type some text then use the FN-BACKSPACE keys, this should perform a delete function.

Now open a standard terminal window, not iTerm, and do the same test. I believe that the FN-BACKSPACE does not have delete functionality in this case.

Can you let me know what you find?

3 Silver

We are getting closer.

FN-BACKSPACE works correctly in documents / terminal. Even on the virtual desktop FN-BACKSPACE works like DEL.

However, ALT doesn't seem to work. I started notepad in the virtual desktop and pressed ALT-F. This should bringup the file menu. Instead is shows the character '2' ?

ps: I also tried attaching a normal keyboard with DEL button, with the same result. CTRL-ALT-DEL is not working.

3 Argentum

Hi,

Can you tell me what is the keyboard layout and regional settings of the remote computer?

Also have you checked the Modifier Keys are correctly configured in the System Preferences, Keyboard option on the Mac.

3 Silver

Keyboard layout on the virtual desktop is "United States-International".

Regional settings "Dutch (Nederlands)"

I checked the modifier keys and they are correct.

3 Argentum

It would seem as though your MAC is a similar setup to mine where I am able to use the key combinations and get the desired result. Is there perhaps a way that I could connect to this remotely using my MAC, or perhaps look at this further with you? If you wish to log a support case we can follow up and try to get to the bottom of it.

2 Bronze
2 Bronze

One thing that you can try and have tested here in the Reston office is using the (cltr-shift-esc) combination.

Top Contributor
Latest Solutions