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Windows stop error 100000EA due to Videoprt.sys

Summary: This article provides information about a Windows STOP error (bluescreen) that may occur due to Videoprt.sys.

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Symptoms

A stop error 100000EA occurs on a Windows server referencing Videoprt.sys. Further analysis reveals stopcode 100000ea: THREAD_STUCK_IN_DEVICE_DRIVER_M.

Event ID 1001 is logged in the System event log.

Log Name: System
Source: Microsoft-Windows-WER-SystemErrorReporting
Date: 4/17/2014 1:45:45 PM
Event ID: 1001
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: ComputerName
Description:
The computer has rebooted from a bugcheck. The bugcheck was: 100000EA, {fffffa803f895640, fffffa807003b280, fffffa806e9d0180, 1}. A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 041714-70544-01.
 

Review of the memory dump files using Debugging Tools for Windows will result in output similar to the following.

BugCheck 100000EA, {fffffa803f895640, fffffa807003b280, fffffa806e9d0180, 1}
Probably caused by : VIDEOPRT.SYS ( VIDEOPRT!WdpKernelApc+2e8 )
Followup: MachineOwner
THREAD_STUCK_IN_DEVICE_DRIVER_M (100000ea)
The device driver is spinning in an infinite loop, most likely waiting for
hardware to become idle. This usually indicates problem with the hardware
itself or with the device driver programming the hardware incorrectly.
If the kernel debugger is connected and running when watchdog detects a
timeout condition then DbgBreakPoint() will be called instead of KeBugCheckEx()
and detailed message including bugcheck arguments will be printed to the
debugger. This way we can identify an offending thread, set breakpoints in it,
and hit go to return to the spinning code to debug it further. Because
KeBugCheckEx() is not called the .bugcheck directive will not return bugcheck
information in this case. The arguments are already printed out to the kernel
debugger. You can also retrieve them from a global variable via
"dd watchdog!g_WdBugCheckData l5" (use dq on NT64).
On MP machines it is possible to hit a timeout when the spinning thread is
interrupted by hardware interrupt and ISR or DPC routine is running at the time
of the bugcheck (this is because the timeout's work item can be delivered and
handled on the second CPU and the same time). If this is the case you will have
to look deeper at the offending thread's stack (e.g. using dds) to determine
spinning code which caused the timeout to occur.
Arguments:
Arg1: fffffa803f895640, Pointer to a stuck thread object.  Do .thread then kb on it to find
 the hung location.
Arg2: fffffa807003b280, Pointer to a DEFERRED_WATCHDOG object.
Arg3: fffffa806e9d0180, Pointer to offending driver name.
Arg4: 0000000000000001, Number of times "intercepted" bugcheck 0xEA was hit (see notes).
Debugging Details:
------------------
FAULTING_THREAD:  fffffa803f895640
DEFAULT_BUCKET_ID:  GRAPHICS_DRIVER_FAULT_SERVER_MINIDUMP
CUSTOMER_CRASH_COUNT:  1
BUGCHECK_STR:  0xEA
PROCESS_NAME:  perfmon.exe
CURRENT_IRQL:  1
LAST_CONTROL_TRANSFER:  from fffff88003475c54 to fffff8000208dbc0
STACK_TEXT: 
fffff880`097b4cf8 fffff880`03475c54 : 00000000`000000ea fffffa80`3f895640 fffffa80`7003b280 fffffa80`6e9d0180 : nt!KeBugCheckEx
fffff880`097b4d00 fffff800`020805f7 : fffffa80`3f895640 fffffa80`3f895690 fffff880`097b59b8 fffff900`c290e010 : VIDEOPRT!WdpKernelApc+0x2e8
fffff880`097b5230 fffff800`020808a7 : 00000000`59e5aa80 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiDeliverApc+0x1c7
fffff880`097b52b0 fffff960`002ad712 : fffff880`097b6110 fffff960`002ad826 fffff880`097b60f8 fffff880`097b61e0 : nt!KiApcInterrupt+0xd7
fffff880`097b5440 fffff960`002ad826 : fffff880`097b60f8 fffff880`097b61e0 fffff880`097b5510 fffff880`097b6118 : win32k!AddEdgeToGET+0x136
fffff880`097b5450 fffff960`002add9e : fffffa80`3f895640 fffff900`c290e010 00000000`00000001 fffff880`097b5940 : win32k!bConstructGET+0x92
fffff880`097b54b0 fffff960`0022b635 : fffff880`097b59a0 fffff880`097b5e10 00000000`ffffffff fffff880`097b5f40 : win32k!RGNMEMOBJ::vCreate+0x202
fffff880`097b5920 fffff960`0022e732 : fffff900`c01d7000 fffff880`097b5e10 fffff900`c28ed618 00000000`00000008 : win32k!RGNMEMOBJTMPIFNEEDED::RGNMEMOBJTMPIFNEEDED+0x69
fffff880`097b5960 fffff960`00229814 : fffff900`c01d7000 00000000`00000000 fffff880`097b5e10 fffff900`c28ed618 : win32k!EngFillPath+0x1d2
fffff880`097b5b60 fffff960`0022a06b : 00000000`00000000 00000000`00000f0f fffff880`097b5dc0 00001e84`00000000 : win32k!EPATHOBJ::bSimpleFill+0x34c
fffff880`097b5c40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : win32k!EPATHOBJ::bSimpleStrokeAndFill+0x45b
STACK_COMMAND:  .thread 0xfffffa803f895640 ; kb
FOLLOWUP_IP:
VIDEOPRT!WdpKernelApc+2e8
fffff880`03475c54 cc              int     3
SYMBOL_STACK_INDEX:  1
SYMBOL_NAME:  VIDEOPRT!WdpKernelApc+2e8
FOLLOWUP_NAME:  MachineOwner
MODULE_NAME: VIDEOPRT
IMAGE_NAME:  VIDEOPRT.SYS
DEBUG_FLR_IMAGE_TIMESTAMP:  4a5bc58b
FAILURE_BUCKET_ID:  X64_0xEA_IMAGE_VIDEOPRT.SYS
BUCKET_ID:  X64_0xEA_IMAGE_VIDEOPRT.SYS
Followup: MachineOwner

 

Cause

There are several possible causes:
  • Video drivers and/or firmware are outdated.
  • The operating system is not up to date.
  • The video adapter is malfunctioning.

Resolution

  • Download and install the latest video adapter firmware and drivers from the Dell support website.
  • Ensure the latest Windows updates have been applied to the operating system.
  • Perform hardware diagnostics on the video adapter and replace it if necessary.

Affected Products

Microsoft Windows Small Business Server 2011 Essentials, Microsoft Windows Small Business Server 2008, Microsoft Windows Essential Business Server 2008, Microsoft Windows 2008 Server R2, Microsoft Windows 2008 Server Service Pack 2 , Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2 ...