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Unisphere for PowerMax:SMASがエラー「Address already in use: bind 127.0.0.1:9999」でクラッシュし続ける

Summary: SMASが5秒でダウン

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Article Content


Symptoms

新しくインストールされたUnisphere for PowerMaxは5秒以内に
SMASを起動できません。一部のシナリオでは、インストール
後にSMASが正常に実行されないため、run.logが生成されます。一部のシナリオでは、smas.logも生成されます

すべてのログ

にエラー メッセージ(smas.log)が表示
されます。
 
[ホスト コントローラー] 21:43:20,514 ERROR [org.jboss.msc.service.fail]( MSCサービス スレッド1~2)MSC00001: サービスjboss.remoting.server.managementの開始に失敗しました: org.jboss.msc.service.StartException
in service jboss.remoting.server.management: JBAS017112: すでに使用されているアドレス:bind 127.0.0.1:9999

エラー メッセージ(run.log):
 
[ホスト コントローラー] 21:43:20,529 FATAL [org.jboss.as.host.controller]( コントローラー ブート スレッド) xxxx010933: ホスト コントローラーの起動が回復不能な方法で失敗しました。終了。詳細については、前のメッセージを参照してください。
[ホスト コントローラー] 21:43:20,576 INFO [org.jboss.as] (MSCサービス スレッド1~5) xxxx015950: JBoss AS 7.1.3aOCI-emc「xxxxx」が9ミリ秒
で停止 21:43:21,075 INFO [org.jboss.as.process.Host Controller.status]( ホスト コントローラーのリパー) xxxx012010: プロセス「ホスト コントローラー」が終了ステータス99
21:43:21,075 INFO [org.jboss.as.process] (Thread-8) xxxx012016: プロセス コントローラー21
:43:21,075 INFO [org.jboss.as.process] (Thread-8) xxxx012015: すべてのプロセスが完了しました。exiting

[Host Controller] ]) - 障害の説明: {"WFLYCTL0080: Failed services」 => {"jboss.remoting.server.management" => "WFLYRMT0004: すでに使用されているアドレス:bind 127.0.0.1:9999

 

Cause

上記のエラーは、Unisphereポートが他のアプリケーションと一緒に存在していることを意味します

Resolution

Unisphere for VMAX/PowerMaxは、以下のポートに排他的にアクセスしてインストールする必要があります。 
  • httpsの場合は8443
  • 3324(SMAS_DB用)
  • RCA用8088、8089、RT
  • Unisphere for VMAXサーバー用4447、9990、9999(編集不可)
    • ポート:9999は、サービス内通信として使用されます。これは一般的にMANAGEMENT_NATIVEと呼ばれます。
  • 5988/5989(ECOM向け)
  • 2707(クライアント/サーバー用)
  • 10123 for vWitness

この問題を解決するには、上記のいずれかのポートを使用しているアプリケーションを特定し、アンインストールします。次に、SMASを正常に開始します。
一部のシナリオでは、Unisphereの再インストールが必要になる場合があります。

このような低下が観察されたアプリケーションの一部を次に示します。
Splunk
CISCO
Dell EMC Data Protection Advisor(DPA)
AppSync

Article Properties


Affected Product

Unisphere for VMAX, Unisphere for PowerMax

Product

Unisphere for VMAX

Last Published Date

08 Sept 2023

Version

3

Article Type

Solution