Highlighted
2 Bronze

Alpha R2, freezes, lags, loud

Wondering if anyone else has had a horrible experience with the Alienware Alpha R2. Been to the repair depot 4 times since purchasing in May. Very very slow, takes a long time to start up, Lags and freezes, loud, Issues are unresolved. Now they say it needs an upgrade. They have refused to replace it. I bought extra warranty. means nothing. I am so frustrated, bought for my son who has a disability and he has not been able to enjoy it. Just keep getting run around from Alienware technical support. What to do?

Labels (1)
0 Kudos
3 Replies
Highlighted
5 Iridium

Re: Alienware alpha r2

I assume when "they" say it needs an upgrade we are talking about Dell tech support. First off to be sure you do not have a hardware problem. Restart the system and at the Alienware logo start tapping F12. Run full system diagnostics. Next I believe that your system has a 5400 RPM HDD and 4 GB of RAM. For gaming you should have at least 8GB of RAM, and with one memory slot that means buying an 8 GB RAM module. Also that hard drive is rather sluggish. Replace it with an SSD. You have an M.2 SATA slot or you can just pull the HDD and put in a 2.5" SSD. The operation would be much faster. If you replace the drive you can either clone the existing HDD to the SSD or clean install the OS. If you clone, then a software program such as Macrium Reflect Free would work fine. You can clone using an external hard drive enclosure, which are very inexpensive. Also if your son is doing a lot of online gaming, uninstall Smartbyte if it is on the system. A clean install would get rid of any bloatware on the system but I am not sure how tech savvy you may be.

These links may help..

https://www.alienwarearena.com/ucf/show/226441

Clone Windows 10

This is with a laptop but procedure is the same.

https://www.youtube.com/watch?v=q2LySc8gZ3I

also.

https://www.youtube.com/watch?v=FvTIAxVvd_0&t=35s

Clean install Windows 10

https://www.youtube.com/watch?v=-eDX7f6EcLA




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B450-A Pro Max with Ryzen 7 2700X
Real work on an Inspiron 15 5575 and Latitude E5430
0 Kudos
Highlighted
2 Bronze

Re: Alienware alpha r2

The diagnostics have been run numerous times before we actually sent it off to the repair depot. They have replaced many components, send it back saying it’s fixed and it’s not. This machine has been mailed to them 4 times now. I am waiting for a reply on a further escalation of the file, and will see what there response is. Haven’t wanted to get in there swapping  things out as I didn’t want to void the extra warranty. 

0 Kudos
Highlighted
1 Copper

Re: Alpha R2, freezes, lags, loud

I notice after a year my gpu fan was making a loud noise and my gpu temp was running high. While my gpu was overheating  the cpu temp was also high because of the heat the gpu was making. To fix this I would open the alpha r2 and oil up the gpu fan (temp. fix) Both the Gpu and Cpu would be 80°c. Ever since i purchase the Alienware Graphic Amplifier with Rtx 2060 it runs so much smoother and the temps are around 50°c & 60°c           i7-6700t   16gb ram  Rtx 2060

 

0 Kudos