AmericanMadman
1 Copper

M11x R2 - No 5.1 Audio via HDMI Out?

Hey All,

First time poster. I've owned my M11x R2 for about a month now and have been extremely pleased. It's a great rig and I am really enjoying it.

I have run into an issue that I'm hoping someone on these forums can assist with. 

I've hooked up my M11x to my Sony home theater (STR-DH810) via HDMI. For some reason the M11x will only transmit 2 channel LPCM to the receiver.

This Home Theater supports up to 7.1 surround sound and all of the latest audio codecs.

When in the control panel, under Manage Audio Devices, I see the Sony listed as "SONY AV". Under properties it shows the Sony as only supporting 2 Channel audio even though it is HDCP compliant. It is using the Intel HD Graphics driver to operate the Sony Amp.

I called tech support and spoke to Jim. He spent about 40 minutes of my time placing me on hold while remotely accessing my system. He told me that this issue doesn't fall under the umbrella of the 1 year warranty, and offered to transfer me to someone who could fix this issue for a $25 fee. Seeing how the M11x is advertised as supporting 5.1 I disagreed that I shouldn't be charged for this service - to no avail.

So - seeing as I dont wish to pay $25 for an answer, I'm hoping the community here may be able to help me.

Sorry for the wall of text, but thanks in advance for your assistance.

0 Kudos
4 Replies
Moderator
Moderator

Re: M11x R2 - No 5.1 Audio via HDMI Out?

0 Kudos
AmericanMadman
1 Copper

Re: M11x R2 - No 5.1 Audio via HDMI Out?

Hey Chris,

Thanks for the reply.  I checked the thread you reccomended.

I tried making adjustments in the control panel via manage audio devices. I can choose between 5.1 and stereo for the "Speakers" but that only effects the onboard speakers in the M11X. When connected to the Sony, manage audio devices doesnt give me the option to choose 5.1, only stereo. I also changed the speaker pattern in the Realtek HD Audio Manager to 5.1, but that only effects the onboard speakers as well.

I know my Home Theater supports up to 7.1 and all the latest codecs and PCM, but the M11x doesn't recognize this.

It also shows that the Sony is being controlled by the "Intel Display Audio" driver. Should that be the case, or should the Realtek driver be controlling my home theater? If so, how can I enable the realtek software to do this?

Thanks again for your help. I really appreciate it.

 

0 Kudos
Tesla1856
6 Gallium

Re: M11x R2 - No 5.1 Audio via HDMI Out?

AmericanMadman,

 

Read this thread.

 

Interesting, but that's not what the OP needs. That link is about Analog Audio.

AM needs to use Digital Audio. Sounds like he wants to get the Digital Audio BitStream (like from a DVD) , un-changed, and sent to the Sony AVR for decoding there.

AM ... try testing with a real DVD (or VIDEO_TS folder ... must be sure your source material is truely DolbyDigital5.1 or better). Be sure the DVD player software is set to SPDIF or HDMI. Also, in Control Panel ... both Sound section and any sound driver config tool to SPDIF or HDMI. Try a different "Default" sound device so the Windows Mixer is using the right one.

After all that is set properly, THEN connect the HDMI cable (or dis-connect/re-connect) so the HDMI can re-negotiate the link and capabilities of the two devices.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos
AmericanMadman
1 Copper

Re: M11x R2 - No 5.1 Audio via HDMI Out?

I figured out why I was unable to get a 5.1 signal via HDMI from the R2. It was a setting on the Sony receiver that was causing the issue.

In the HDMI menu on the Sony, the input was configured as TV+AMP. Because of this setting, the R2 was detecting settings from my TV. Since the TV doesn't support 5.1, it limited my choices to 2 channel stereo.

By changing the setting on the receiver's HDMI menu  to AMP only, it detected all 7.1 channels and all the codecs it supports.

Thanks to those who tried to help!

0 Kudos