N2Z2
1 Copper

AX4-5 rebuild hot spare disk stuck

Jump to solution

Hi all,

I've an old AX with one raid group (raid5) with two lun that own disk #9. Hot spare disk is #11

Last night disk #9 has faulted, so disk #11 has taken his place.

After replacing with a new disk, one of two luns has been rebuilded, the other one is stuck at 93% since 18 hours

The real disk that is rebuilding is the hot spare..

Is there any way to see if rebuilding is doing something or is really stucked?


Those are screenshot from Navisphere

1.jpg


2.pngunnamed.png

unnamed.png

Thanks!



Labels (1)
Tags (3)
0 Kudos
1 Solution

Accepted Solutions
N2Z2
1 Copper

Re: AX4-5 rebuild hot spare disk stuck

Jump to solution

Hi all,

It seems that in firmware version previous to .11 there's a bug (or a feature?) that occurs if you change the faulted disk before rebuild has completed on hot spare disk. In that case rebuild on hot spare will stuck. I've removed disk in position 9 and rebuild has been restarted on hot spare from 93%. After a couple of hours rebuild goes to 100%. I've inserted disk 9 again and rebuild has restarted on this disk. Now it's all ok.

0 Kudos
2 Replies
N2Z2
1 Copper

Re: AX4-5 rebuild hot spare disk stuck

Jump to solution

Hi all,

It seems that in firmware version previous to .11 there's a bug (or a feature?) that occurs if you change the faulted disk before rebuild has completed on hot spare disk. In that case rebuild on hot spare will stuck. I've removed disk in position 9 and rebuild has been restarted on hot spare from 93%. After a couple of hours rebuild goes to 100%. I've inserted disk 9 again and rebuild has restarted on this disk. Now it's all ok.

0 Kudos
8 Krypton

Re: AX4-5 rebuild hot spare disk stuck

Jump to solution

That's good news - I'd recommend that you upgrade to the latest release - 712.

Would you also mark this question Answered - that will help others that might have the same issue that you did.

glen