Highlighted
PebbleMatt
1 Nickel

CIFS servers have lost network connectivity

Hi,

Hopefully someone will be able to provide some assistance ... We have a Celerra NS4-480 which is sitll running a few file (CIFS) services for us.  Yesterday, users lost access to the CIFS servers set up on the Celerra.  From what I can see looking at logs (using server_log), the data mover started to report errors connecting to various network resources, the DNS client reporting it cannot connect to the DNS servers, entries from SMB service reporting errors connecting or getting the DCs, with the SMB errors occuring for multiple VDMs.  The issue is also happening on the CIFS servers on the data mover itself (i.e. those created on server_2 and not within a VDM on server_2).

I tried failing over to the stanby datamover, server_3, but that exhibited the same issue, while failed over I performed a cold reboot of server_2 (at that point server_2.faulted.server_3), then failing back and restarting the standby as well; but still the problem persisted.

I've tried pinging from the interfaces (server_ping server_2 -interface <interface_name> <hostname>), but I keep getting "Error 5: server_2 : Input/output errorRPC: Timed out", if I try entering an IP instead I get "Error 6: server_2 : No such device or address

no answer from x.x.x.x", I imagine the Error 5/errorRPC is due to not being able to resolve the network name as it cannot connect to the DNS servers.

As an additional test, as we have the 1Gb ports set up for replication, I set up some interfaces on those and assigned them to the CIFS servers, but they do not appear to work.

At present it seems that only one CIFS server can even be pinged from a client (but still cannot connect to any shares on it), and that CIFS server is on the root data mover (i.e. not in a VDM).

We have an NFS Export, and the server using that appears to have access (can read and write to it), but it also happens to be mounted using the IP that is used by the one CIFS server that is at least repsonding to pings (although cannot ping from the Celerra on that interface).

Have to say I'm confused by what is occuring.

Thank you in advance for any help.

Matt

0 Kudos
1 Reply
umichklewis
3 Zinc

Re: CIFS servers have lost network connectivity

Hard to say, but it certainly appears that you have a network issue of some kind or an issue with the CIFS service on your VDMs.  Have you tried using server_setup to stop/start cifs on each VDM?  Something to the effect of:

server_setup VDM_1 -Protocol cifs -option stop

server_setup VDM_1 -Protocol cifs -option start


Then, check status with


server_cifs VDM_1


Let us know if that helps!


Karl

0 Kudos