kjstech
3 Argentium

redundancy for celerra connection to network

Jump to solution

Currently our Celerra is connected to one Cisco 3750G 24 port switch.  Our VMWare (3) servers are also connected to this.  There's 3 VLANs,

1 LAN

10 SAN

20 DMZ

This switch is trunked to the core.

Now we added a second switch.  Any best practices how to make it redundant, so if one switch goes down?

on both sides in the back of the celerra there's

cge0, cge1, cge2, cge3        -        cge0, cge1, cge2, cge3

Any link to documents would be helpful.

Storage traffic is on its on vlan.  The VMWare ESX hosts have interfaces on the storage vlan to talk to the celerra via NFS.

0 Kudos
22 Replies
dynamox
6 Thallium

Re: redundancy for celerra connection to network

Jump to solution

from Celerra configuraiton perspective, have you seen this document ?

https://support.emc.com/docu10545_Configuring-and-Managing-Celerra-Network-High-Availability.pdf?lan...

0 Kudos
etaljic81
4 Tellurium

Re: redundancy for celerra connection to network

Jump to solution

If you want to protect yourself against a switch failure then you need to create an FSN (fail safe network). You can create an FSN across two cge ports or you can create two LACP trunks and create an FSN on top of those two.

Example 1: no trunking

Step1: cge0 - connect to switch1

Step2: cge1 - connect to switch 2

Step3: create FSN using cge0 and cge1. You'll be able to choose which link the traffic should go through. If that link dies FSN will use the other link

Example 2: trunking

Step1: cge0 and cge1 - connect to switch1

Step2: create LACP/etherchannel trunk using cge0 and cge1 ports (let's call this LACP0)

Step3: cge2 and cge3 - connect to switch2

Step4: create LACP/etherchannel trunk using cge2 and cge3 ports (let's call this LACP1)

Step5: create FSN using LACP0 and LACP1

You don't need to do anything special on the switches to make an FSN work.

The standby datamover is not being used unless there's a datamover failure. You have to connect the cge ports on the standby datamover the same way that you connected the ports on the active datamover. For example, if cge0 and cge1 are connected to switch1 on the active datamover and those two switch ports on switch1 are configured in VLAN10, you have to connect cge0 and cge1 on the standby datamover to switch1 and configure those to be in VLAN10 as well.

Hope this helps.

0 Kudos
kjstech
3 Argentium

Re: redundancy for celerra connection to network

Jump to solution

That document does help, thanks!

Ernes, that is helpful, thank you.

I did not configure this the first time around.  All I have to go by is looking at the current active switch config.  I have no idea why ports 10 and 14 are explicitly shut down and no port channel defined.

interface Port-channel2

interface Port-channel3

switchport access vlan 10

interface Port-channel4

switchport access vlan 10

interface GigabitEthernet1/0/1

description server_2-cge3

channel-group 2 mode active

spanning-tree portfast

interface GigabitEthernet1/0/3

description server_2-cge1

channel-group 2 mode active

spanning-tree portfast

interface GigabitEthernet1/0/5

description server_3-cge2

switchport access vlan 10

channel-group 3 mode active

spanning-tree portfast

interface GigabitEthernet1/0/7

description server_2-cge0

switchport access vlan 10

channel-group 4 mode active

spanning-tree portfast

interface GigabitEthernet1/0/8

description server_3-cge0

switchport access vlan 10

channel-group 3 mode active

spanning-tree portfast

interface GigabitEthernet1/0/10

description server_3-cge3

shutdown

spanning-tree portfast

interface GigabitEthernet1/0/12

description server_2-cge2

switchport access vlan 10

channel-group 4 mode active

spanning-tree portfast

interface GigabitEthernet1/0/14

description server_3-cge1

shutdown

spanning-tree portfast

Now when I log into Unisphere on this

lan ip - cifs - server_2 - cifs_trk

lan ip - replication-int - server_2 - cifs_trk

san ip - iscsi - server_2 - iscsi_trk

128.221.252.2 - el30 - server_2 - mge0

128.221.252.3 - el30 - server_3 - mge0

128.221.253.2 - el31 - server_2 - mge1

128.221.253.3 - el31 - server_3 - mge1

0 Kudos
etaljic81
4 Tellurium

Re: redundancy for celerra connection to network

Jump to solution

Click on the devices tab in Unisphere. You listed the interfaces created (cifs_trk) but we need to know how that cifs_trk is configured. Go to the devices tab on the same screen where you obtain the interfaces info and post the output here

0 Kudos
kjstech
3 Argentium

Re: redundancy for celerra connection to network

Jump to solution

Should probobobly identify each defined device on celerra

Device Name: cifs_trk

data mover: server_2

Type: lacp

Devices: cge1, cge3

Owned by virtual: none

Interfaces: (2 different LAN ip's)

1000FD

Device Name: isci_trk

data mover: server_2

Type: lacp

Devices: cge0, cge2

Owned by virtual: none

Interfaces: SAN IP

1000FD

0 Kudos
etaljic81
4 Tellurium

Re: redundancy for celerra connection to network

Jump to solution

One more thing. In your switch config, can you clarify what is on switch1 and what is on switch2?

0 Kudos
kjstech
3 Argentium

Re: redundancy for celerra connection to network

Jump to solution

Nothing is on switch 2 yet, I want to implement it.

The only thing switch 2 has is 2 links trunked to the core switch stack.  It works great and has full connectivity to the core network.  I tried with a laptop on various vlans between switch 2 and different vlans on the core switch.

I have some spare network interfaces on each ESX host and I can figure that myself.  Its the celerra that I want to make sure I don't make a mistake. 

Switch 1 Cisco 3750G- everything- Celerra, 3 x ESX hosts, ports 23/24 trunked to core

Switch 2 Cisco 3560X - nothing yet.  ports 23/24 trunked to core.

0 Kudos
Highlighted
etaljic81
4 Tellurium

Re: redundancy for celerra connection to network

Jump to solution

If you really want to implement FSN to protect yourself against a switch failure you'll have to delete cifs_trk and iscsi_trk and re-create those.

Since you only have four ports you'll have to do delete cifs_trk, connect cge3 to the second switch and then create an FSN using cge1 and cge3. When you create the FSN you'll specify which port (cge1 or cge3) the traffic should go through.

You have to do the same thing for iscsi_trk; conenct cge2 to switch2 and create an FSN.

Yes, downtime is required since you will be deleting the trunks and reconfiguring the environment.

What is your other option? If a switch fails you will have to manually failover the datamover. This is a manual step but doesn't require reconfiguration and you can leave everything as is.

kjstech
3 Argentium

Re: redundancy for celerra connection to network

Jump to solution

Would bandwidth be reduced since cge1 and cge3 would be on two separate switches?

I'm almost thinking we could just put all of the interfaces from server_3 on the second switch and like you said fail over the datamover if there was a switch failure.

I will have to discuss with the I.T. team.  downtime would surely need to be scheduled and off hours.

You have been really great and thanks for looking over my config so far.

0 Kudos