RE: Provider installation

Presently only Dell Client Enterprise systems (  OptiPlex, Latitude, Venue etc.) are supported.

Thanks

Vibha

0 Kudos
jack.frianeza
1 Copper

RE: Provider installation

Hello All,

Any workaround on this issue? "WARNING: Couldn't get ACPI Buffer Size!!"

Thank you.

Jack

0 Kudos

RE: Provider installation

Hello Jack,

Dell Command PowerShell Provider runs only on supported platforms having supported BIOS version. There is no work around for this.

Can you please check and let us know whether the platform which you are using is present in the supported platform list? If your platform is present then please verify BIOS version also. 

http://en.community.dell.com/techcenter/enterprise-client/w/wiki/11653.supported-platformsbios-refer...

Let us know if you have any other query.

Thanks

-Tarun

0 Kudos
jack.frianeza
1 Copper

RE: Provider installation

Hello Tarun,

I am running this on a Dell 3020 with BIOS version A08.

Thank you.

Jack

0 Kudos
Schneefalke
1 Copper

RE: Provider installation

Hello,

I'm running a Dell OptiPlex 9020 with latest BIOS (A15) and Windows 7 64bit.
VC++2010 x86 and VC++2012 x86 are both installed (also VC++2010 x64) and also .NET 4.6.
I installed nuget and the DellBIOSProvider and tried to import the module, but it always runs into

VERBOSE: Starting PS provider DellSmbiosProv
VERBOSE: .NET Version: 4.0.30319.42000
VERBOSE: Performing InitializeDefaultDrives operation on the 'DellSmbiosProv'provider.
Import-Module : Could not load file or assembly 'DSMBLibWrapper.dll' or one of its dependencies. Das angegebene Modul
wurde nicht gefunden.
At line:1 char:1
+ Import-Module DellBIOSProvider -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (Smiley Happy [Import-Module], FileNotFoundException
    + FullyQualifiedErrorId : NewDriveProviderException,Microsoft.PowerShell.Commands.ImportModuleCommand

On another machine (Dell OptiPlex 7010) with the same configuraton, I can import the module without problems.

Any ideas, what I can do?!?

Thanks a lot and kind regards,
Sebastian

0 Kudos
Highlighted

RE: Provider installation

Hi Sebastian, 

You must have VC++2010 x64 and VC++2012 x64 redistributables installed in your machine to run Dell Command | PowerShell Provider successfully. After installation please restart the machine before loading the module.

Note - x86 redistributables are not required if operating system is 64 bit. 

Please let me know in case you face same issue again.

Thanks

-Tarun

Schneefalke
1 Copper

RE: Provider installation

Hi Tarun,

thanks for your feedback, that solved it! :-)

Meanwhile, it took so long until my question had been reviewed, I found this solution, too. ;-)

But nevertheless, thank you for your help, and the 'validation' of this solution.

Best regards,
Sebastian

0 Kudos
Edyxx
1 Nickel

RE: Provider installation

Hi,

I have a similar problem with import-module command. I receive an error about PS-Drive not installed. The install continues though.

It's a Dell Latitude E7450 with Windows 7 64bit installed. VC++ 2010, 2012 and 2013 runtime modules are installed.

On another machine which is a OptiPlex 9020 with Windows 7 64bit and VC++ 2010 and 2013 installed I was able to run the import-module command with no problem PS-Drive is there, although VC2012 is not installed

So I have a few questions:

- Is VC++ 2012 required when VC++ 2013 is installed?

- Why cannot the module load PS-Drive? Is it caused from the VC++ runtimes?

Thanks,

Edy

0 Kudos