c0ba1t
1 Copper

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

Not all cards have this switch.  I decided to give it another try and purchased a new card.  It did not have the switch the previous poster talked about, but I'm happy to report that it is working fine out of the box.  Easy and problem free install and it's been running stable for the past week or so.

This is the card that finally worked for me:

SAPPHIRE R9-270XOC 2GB D5 DDHDP

www.microcenter.com/.../Radeon_R9_270X_Overclocked_2048MB_DDR5_PCIe_30x16_Video_Card

0 Kudos
RobDuggan
1 Copper

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

I had a similar issue with another machine of mine.

I bought a new video card that only supported PCIE 3.0 and was not backward compatible.

Just check the motherboard specs and make sure that the video card supports that PCIE version.


Cheers.

0 Kudos
Mogle222
1 Nickel

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

The new cards gtx 970 or 980, the AMD Radeon r9 series, do not work with the xps 8300 motherboard.

0 Kudos
savage1159
1 Copper

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

I have a Saphire R9 270 Dual X video card that replaced my original HD5870 and it was plug and play right out of the box in my 2011 model XPS 8300.  Not sure why others are having this problem and not me.

0 Kudos
Highlighted
Mogle222
1 Nickel

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

Same issue here, I wish Dell would make a statement to all xps 8300 users, so we can move on if we truly cant do anything about this.

0 Kudos
Mogle222
1 Nickel

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

Did you run yours in legacy?

0 Kudos
RobDuggan
1 Copper

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

Looking online PCIE 3.0 is supposed to be backward compatible.


My problem could have been that the video card was demanding more power from the bus than my stock power supply could have provided

0 Kudos
Jhwx
1 Copper

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

Just got around to replying now.

I had a Dual fan Sapphire Radeon, and my GPU did not have that switch.

Thanks for posting this for other users though, much appreciated.

Happy Holidays.

0 Kudos
jvahabzadeh
2 Bronze

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

Captainv - can you elaborate a little bit?

Which particular video card did you use (MSI, Gigabyte, or whoever, and what model number?), and what's this switch you're talking about?  Does the switch say anything, or does it have a particular name?

I'm looking to go with an R9 285 myself, so any information you can give would greatly help.

0 Kudos
wolfwinter
1 Copper

RE: Dell XPS 8300 & AMD Radeon R9 270x

Jump to solution

Hi, I just finished installing a msi r9 270x 2g video card on my 2011 xps 8300 and I ran into the same issue as everyone did.

Ther is several ways you can go around this issue without changing anything on your computer.

The first one is to remove all video cards from your mother board and plug in your monitor into the onboard vga or hdmi plug located to the back of your computer( probably hidden by a plastic cover)

Download and install all drivers....then without unpluging your monitor install your new hardware and now restart your computer.it will go to your onboard display, at this point 2 things can happen either your window start normaly and you are able to see your system looking for new hardware and if so let it do its thing or you will get a message asking you to unplug the present onboard display adaptor and plug into the new hardware....

Then do just that and your new card as been detected...

The weird part is that some video cards will respond to that some others wont, in the case of mine it was as simple as pushing a switch on the card located to the left of the two six pins connector and restard.

I tryed several gpu using this method and was able to get a picture everytime...

Please feel free to contact me for questions...