8 Krypton

Devices and Printers not loading

When I try to load Devices and Printers nothing loads – the green bar goes all the way along and just sits there looking at me!! 

 

I have tried the following steps: -

 

looking in Services and checking that the Bluetooth Support Service and the Printer Spooler Services are on and set to automatic.

I have performed a Clean Boot using MSCONFIG , disabling Microsoft Services.     

  I have run repair for Windows    I have tried to run Sfc /scannow both in Safe Mode and from Normal Windows but I get the message – Windows Resource Protection could not perform the requested Operation.  I tried running it in Administrator Mode

System Restore 

Setting up a new account

The printers and scanner all work perfectly for both my computer and laptop they just don’t show they are there.

I have a DELL XPS 420 running WIndows 7      

Any help would be welcome with this annoying problem

0 Kudos
6 Replies
8 Krypton

Re: Devices and Printers not loading

Hi Estelled,

This is really a softare problem, but let me make a suggestion. Unplug all devices except your monitor, mouse and keyboard. Then try loading devices and printers. Next, plug in each item until you determine which one is causing the problem.

0 Kudos
8 Krypton

Re: Devices and Printers not loading

Thanks for your interest - I did as you suggested but it still doesn't work with no peripherals attached.  The stange thing is that I share a Homegroup with my laptop and that works perfectly -  the Devices and Printers works perfectly and I can print to either of my printers no problem.

EstelleD

 

0 Kudos
8 Krypton

Re: Devices and Printers not loading

You said you disabled MS Services...that's not a good thing, unless you know exactly what you're doing! If you disable the wrong service...:emotion-60:

You may need to do a System Restore back to latest date available before your very first attempt to install these devices. Then start over. And never connect a USB device to the PC until the installation software tells you to connect it. If you connect it before the software requests it, Windows may install the wrong drivers and it just won't ever work.

Ron

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
8 Krypton

Re: Devices and Printers not loading

I followed instructions from the Microsoft Knowledge base for the Clean Boot so I am sure I did nothing wrong there.  I think you misunderstood my problem - All my printers are installed and working fine and have been for two years since I got the computer - it is just that all of a sudden I cannot get the Devices and Printers in Control Panel to show them - they still work both on my main computer and on my Homegroup. 

 

Estelled

0 Kudos
8 Krypton

Re: Devices and Printers not loading

See if the solution here fixes your problem.  Seems to be an issue with Bluetooth.

Ron

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
ES1012
1 Copper

Re: Devices and Printers not loading

yes Thankyou

0 Kudos