Funkydad
1 Copper

Upgraded Precision 370 to Vista ... Oops!

Call me different but I am one of those who actually likes Vista.  I inherited a quad processor Precision 370 with 4Gb memory after a hard drive failure so I installed 2 new GB HDs, a second DVD and a newer video adapter,  I reloaded the XP and then upgraded to Vista Business so I could use the machine for my business.  Great machine ...   Worked great...   for a while.

Now my problem.  Both DVD drives use the Vista built-in drivers.  After SP2 neither drive shows up on my drive list and both are marked with an exclamation mark in the Device Manger.  I can't even use the back-up DVDs to go back to a prior checkpoint because the DVD drives aren't there.

Device Info:
        _NEC DVD+-RW ND-3530A ATA Device
        SONY DVD-ROM DVU1615 ATA Device

Driver info (Same for both)
        Driver Provider:   Microsoft
        Driver Date:         6/21/2006
        Driver Version:    6.0.6002. 18005
        Manufacturer:      Microsoft
        File Version         6.0.2002. 18005 (lh_sp2rtm.090410-1830)

The message:

        Windows cannot load the device driver for this hardware.  The driver may be corrupted or missing.  (Code 39).

There is also a button for check for solutions from Microsoft ... but that hasn't panned out either.  I have also re-downloaded and installed the Intel 82801 chipset drivers from Microsoft.

As of this posting, I cannot find any Dell approved Vista drivers for the Precision 370.

Any ideas?

0 Kudos
5 Replies
8 Platinum

Re: Upgraded Precision 370 to Vista ... Oops!

Funkydad

See if the FAQ refering to Code 39 errors HERE can help.

You may find more information about this problem, if you post this in the Disk Drives (HDD, CD/DVD, Blu-ray) forum, HERE

Dell appears not to have any Vista support for the Precision 370, see HERE

Bev.

 


If my answer was helpful, please click: Kudos
Forum Member since 2001
I am not employed by Dell

0 Kudos
Highlighted
CALLMENUJAK
2 Iron

Re: Upgraded Precision 370 to Vista ... Oops!

A Precision 370 with a quad processor, are you sure?

0 Kudos
Funkydad
1 Copper

Re: Upgraded Precision 370 to Vista ... Oops!

I was suprised too!

0 Kudos
Dev Mgr
6 Gallium

Re: Upgraded Precision 370 to Vista ... Oops!

You may want to check, as the 370 uses the Intel 925X chipset, which didn't support dual processor or dual core, let alone quad core/processor (and I don't think there were any dual core processors with hyper-threading either (to make it look like 4 cores)). Possibly the badge on your system says 370, but it's a different motherboard inside the system.

Member since 2003

0 Kudos
rdunnill
5 Iridium

Re: Upgraded Precision 370 to Vista ... Oops!

I had a similar problem : my Blu-ray drive was disabled after an upgrade from a Socket 939 to a Core2 Duo.

The problem stemmed from a filter driver that iTunes had installed. Uninstalling iTunes removed the filter driver and the Blu-ray drive worked once more.

I never worry about Dell-approved drivers for my Dell desktops. My Vostro 220S is purring with Windows 7 64-bit, despite Dell support being limited to 32-bit XP and Vista.

 

0 Kudos