TrevJo
1 Copper

XPS 400 - USB ports do not work

I have a Dell XPS 400.  My USB (wireless) keyboard and mouse stopped working.  They did not work either in the bootloader or in the OS (Vista).  When I boot up, the screen says "Keyboard Failure" for usually about a second before loading the OS.  I tried using a wired USB keyboard and mouse, but those did not work either.  I was able to borrow a PS/2 Serial card to use a PS/2 keyboard and mouse (the card plugs into the SER2 port on the motherboard).  This was successful and I was able to log in to the OS and verify that mouse and keyboard functioned properly.  Unfortunately, the PS/2 Serial Card is not mine to keep and they are not easy to find.  Worse, NONE of my USB ports work.

 

I have observed that of the 7 USB ports (2 in front, 5 in back), 6 of them will supply power to a device, even though the computer will not recognize the device.  For example, if I plug in a USB mouse the mouse light will come on.  However, with the 7th USB port, when I plug in a USB device it gets no power from the port.  This makes me wonder if there was a failure with this particular USB port that is also causing the other 6 USB ports to fail.

 

The only other thing I noticed is that when I ran an application from DVD, it ran very slow, especially when refreshing the display for that app.  Otherwise the OS and programs looked fine.  Makes me wonder if maybe there is a general power issue that affects both the USB ports as well as the CD/DVD drive?

 

I saw some posts on this forum that suggest doing a power drain (unplugging the computer and holding the power button for 30 seconds).  I tried this with great hope, but unfortunately it was not successful.

 

Has anyone else had this problem?  Any other ideas?  Thanks in advance.

0 Kudos
3 Replies
8 Krypton

Re: XPS 400 - USB ports do not work

Since you have a PS/2 mouse working, try the 'generic' USB fix.

 

Disconnect all USB devices 

Open Device Manager

Expand list under USB 

Right-click and uninstall all USB entries

Exit Device Manager and reboot

XP will reinstall the USB ports.

 

You also may have to consider a hardware failure. 😞

 

Ron 

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
8 Krypton

Re: XPS 400 - USB ports do not work

another option that appears to work also

 

Power off the computer

Unplug all USB Devices...Not the Location of the Mouse and keyboard...

Unplug the power cord from the wall outlet

Press and hold the Power button for 5-10 SECs

Replug in the power cord.

Replug in Only the mouse and keyboard.

Power up the system

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

0 Kudos
WRECKED67
1 Copper

Re: XPS 400 - USB ports do not work

I been Having the same problem, except that all my USB port are giving power. Mine occurred when I plugged my ipod into the front USB ports. I have tried every solution I can find on this board including the cmos reset, so now computer wont get past boot screen since I need to strike f1 or f2  now. This seems to be the fly in the ointment on this system, it kind of upsets me that this has been an on going problem withn this system for years and DELL neither has the integrity or character to fix recall replace or warn its customers about this serous glitch. I should have seen the warning sign when they offered it for no interest for 18 months. So are there any other options I have missed or am I forced to by a new motherboard in the hopes that this will fix it.

 

I feel like a captive now I have 2 other dell machines and am now afraid to plug my camera and mp3 player into them for fear of the same thing happening.

0 Kudos