Highlighted
chucko6166
2 Bronze

XPS 8700 Windows 8.1 Dell BT/WIFI issues

XPS 8700, Windows 8.1 Pro.  Problem developed where system was taking a long time to shutdown or reboot.  Troubleshooting led me to this thread:

http://answers.microsoft.com/en-us/windows/forum/windows8_1-performance/windows-81-pro-x64-uefi-very...

and based on what I read I tried uninstalling the BT and WiFi devices from device manager and then uninstalling the BT/WiFi driver suite from Programs and Features in Control Panel.

This corrected the long shutdown and reboot problem on my system.  The Dell Qualcomm Atheros BT/WiFi Driver Suite was the issue.  On reboot the BT & WiFi devices were reinstalled by Win 8.1 using generic drivers but the long shutdown and reboot problem has NOT reappeared.

This lead me to problem #2.  I visited the Dell Drivers and Downloads site for the XPS 8700 and looked for an updated driver for Win 8.1 for the BT/ WiFi device.  There is no driver listed for Windows 8.1 for this device.  For Windows 8 the download that was suggested was this file:  

Hard-Drive-DW1703_Win84_A00_Setup-M8R50_ZPE.exe

but this file does not install under windows 8.1.  The error message effectively says 'wrong operating system".

So it looks like as of this moment the Dell combo BT/WiFi device is broken under Win 8.1.  When will Dell offer a correct driver for this OS?

Edit 12/26 - looks like Dell has changed the links as now there is an older file listed under Win 8.1 for this device.  I also edited some of the above for gramer and speling erors.

Note - If you try to uninstall the software from Programs and Features, the uninstall may hang.  If so, kill off the uninstall process using Task Manager and reboot.   When restarted, uninstall the BT and Dell WiFi devices from Device Manager and then try the uninstall of the software again from Programs and Features.  It should work properly this time. 

After reboot, you may see the BT and Wi-Fi devices have reappeared in Device Manager as Win 8.1 will reinstall them using more generic or older drivers.  On my system this seemed to be OK as the slow shutdown/reboot problem has not reappeared.

Hopefully Dell and Qualcomm will get this sorted out quickly and give us a driver that works properly under Win 8.1

0 Kudos
31 Replies
gartaud
2 Bronze

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

Just wanted to say thank for your post in the "XPS 8700 suddenly slow rebooting and starting" thread. I had the same issue and your post help me solved it.

0 Kudos
Prius2004
2 Iron

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

Is this the one that is supposedly broken?:

http://www.dell.com/support/drivers/us/en/19/DriverDetails/Product/xps-8700?driverId=P84MY&osCode=WB...

What I find really strange is the Windows 8 driver appears to be more recent than the Windows 8.1 driver. How is that even possible?

0 Kudos
chucko6166
2 Bronze

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

Your link pointed to the Intel driver, the one that does not work for me is this one:

Hard-Drive-DW1703_Win8.1_A00_Setup-P84MY_ZPE.exe

and the link is:

http://www.dell.com/support/drivers/us/en/19/DriverDetails/Product/xps-8700?driverId=P84MY&osCode=WB...

However, this is not the same file that I pointed to earlier.  Apparently Dell has changed the file link(s) sometime over the last 48 hours or so.

 

 

0 Kudos
Prius2004
2 Iron

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

Yeah, I don't know what happened with the links. I only know that the most recent (Dell-Atheros) driver available for download on Dell's web page for Win 8.1 has an earlier date than the driver for Win 8 (8.1 driver is listed as October 17th while the Win 8 driver shows November 20th). 

Anyway, my issue does not appear to be as debilitating as was your issue; my boot times are somewhat reasonable. I'm not sure why that would be other than, perhaps, you're running 8.1 Pro and I'm not.

Regardless, what I would REALLY like to know is exactly what advantage the Dell Qualcomm Atheros BT/WiFi Driver has over the Windows 8.1 generic driver. Is there a difference in functionality that you have noticed? If there is little or no difference, then why not just use the generic Windows driver?

0 Kudos
hanssolo12
1 Copper

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

XPS 8700 Win 8.1

Same issue with long reboot times and removed this software suite, with all the issues of uninstalling as described in the posts.  Allowed windows to set up the automatic drivers and this resolved the long boot time issue.  This software suite also has other issues with blue tooth add-ins for outlook.  Upon installing outlook 2010 the qualcom add-in generated errors as well.  Will wait and see if an update comes out but both devices check out fine with the windows installed drivers.

 

Thanks,  

0 Kudos
august_month
1 Copper

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

I have the same issue, but I cannot uninstall Dell WLAN and Bluetooth Client installation from Control Panel. I assume this is the program all post above talk about. I get error message: "The installer cannot run on this platform. Please select package for your operating system"

Dell needs to do something about it!!!!

0 Kudos
gartaud
2 Bronze

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

How are you trying to uninstall the Dell WLAN and Bluetooth Client? Directly from the Control Panel by selecting it and clicking uninstall? Do you also have a XPS8700 that originally came with Windows 8 x64 (as uninstalling from the Control Panel worked for me)?

0 Kudos
august_month
1 Copper

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

Correct, I am simply selecting uninstall from Control Panel. 

When I bought by XPS 8700, I installed SSD and put fresh Win 8 Pro (64 bit) on it.

0 Kudos
suchok
1 Copper

RE: XPS 8700 Windows 8.1 Dell BT/WIFI issues

The XPS-8700_Network_Driver_P84MY_WN_10.0.0.260_A00.EXE download from Dell installs a Qualcomm Atheros Communications driver for Dell Wireless 1703 Bluetooth card (WLAN WiFi 802.11 b/g/n + Bluetooth Half-Height Mini-PCI Express Card - FXP0D) with the following details:

Driver Date: 25/07/2013 Driver Version: 8.0.1.232

This driver doesn't seem to cause a 2 min delay on shutdown described here.

However, the latest version 8.0.1.241 (dated approx. 5 days later, i.e. 30/07/2013) was causing the delay on my XPS8700. I'm not sure, but most likely it was installed via Windows (or Dell) Update.

The bottom line is : install version 8.0.1.232 from XPS-8700_Network_Driver_P84MY_WN_10.0.0.260_A00.EXE and make sure it's not automatically updated to 8.0.1.241.

 

0 Kudos