Desktops General - Read Only

Last reply by 12-15-2015 Solved
Start a Discussion
788460

XPS 8900 BSOD's out of box. Exchanged XPS 8900 does the same thing.

RESOLVED! ------------------------------------------------------------------------------------------------------------------

Main fix: Disable this driver: bcmwl664.sys (Broadcom 802.11 Network Adapter wireless driver, Broadcom Corporation)

This can be done by finding and disabling the wi fi card in the Device Manager - find the WIRELESS driver - not the regular network driver, under Network Adapters, right click, and select "Disable".

If you've already begun to reinstall Windows out of frustration, or in a last ditch effort to save yourself the trouble of another return (like I did), make sure to NOT install the Broadcom Wireless driver from Dell's site. Otherwise, you'll be back where you started.

User dbark has also found another issue, slightly OT but it might help some of you - on his 8900 file explorer won't open when left-clicking from the task bar. Screen flashes, icons reload and wallpaper changes (slideshow mode is on). Right-clicking and selecting a folder works. Right-clicking on a file or desktop icon crashes.

He read that a shell extension was the likely culprit and using ShellExView he was able to ID NVIDIA's "OpenGLShExt Class" (file nv3dappshext.dll) to be the cause by process of elimination. We're still working through the fix there, details on page 7.

Original post below. --------------------------------------------------------------------------------------------------------

Posting my story here so that I'm using all available channels. Also, the three reps I'd been working with over email have gone dark since I mentioned the word "refund". So I thought maybe I could find some help here. I'm spending my last shreds of hope here, before all becomes darkness.

I ordered an XPS 8900 system on 10/15, and received it on 10/27. Within a couple hours of powering on the system, I got a BSOD that said "UNCORRECTABLE HARDWARE ERROR". I'm somewhat computer saavy but I had never seen this BSOD before. After using my other older computer (also a Dell - still works great) to research the issue, I determined that I did not have the skills to diagnose or fix whatever this might be (most resources said power supply issues, bad RAM). I did see that a RAM clamp was not fastened tightly, so I clamped it in. But no dice.

I called Dell and started the age old customer service tradition of, did I try restarting, yes I did. Yes, I tried restarting. Overall my experience was OK. Mostly I feel like there's one guy in any group of phone reps who actually knows stuff about these machines, and everyone asks him what to do. That's my theory, because after each answer I gave, I was placed on hold for several minutes. In the end, the decision was made to try a new motherboard. The conversation moved to email and a Dell authorized tech was scheduled to come out and install the board. 

On 11/2 the new board was installed, but the computer would not boot at all now. Before, it went to Windows but BSOD'd after anywhere from 30 min to 2 hrs. Never more than 2 hrs. The Dell tech spoke with customer care from my home and more parts were ordered - a cable and hard drive. A 2nd visit was scheduled for 11/5, after which the computer was still not functional. That same day I heard from a sales rep who asked if I wanted an exchange, to which I replied, yes, I would like an exchange.

The new computer arrived 11/17 and I sent back the broken one. I ran through Windows first time set up. As I prepared dinner, I started installing my programs and getting other stuff set up. Holding a pan of simmering taco meat (I use ground turkey, try it - it's great), something caught my eye in the periphery. I set down the pan and saw that the screen had changed to the BSOD. It said: UNCORRECTABLE HARDWARE ERROR. Yes, the new computer gave me exactly the same error.

Quick aside -  last night, 11/18 I received an email from the original rep asking if I ever got that hard drive and cable.

So here's the sequence of events that took place:

1. Original BSOD - UNRECOVERABLE HARDWARE ERROR on 10/27
2. First visit from Dell technician to install new motherboard (did not resolve issue) - 11/2
3. Second visit by Dell tech to install cable and new hard drive (did not resolve issue) - 11/5
4. Same day, heard from Sales rep regarding exchange 11/5. I replied I wanted to go ahead and exchange
5. Sales rep initiates exchange and new computer goes into production - 11/6
6. Receive new computer and pack up/send back nonfunctional one - 11/17
7. New computer is unpacked - 11/17 6:00pm
8. New computer gives same BSOD UNCORRECTABLE HARDWARE ERROR, 11/17 6:27pm while software is installing

And here are the steps to repro the BSOD on my system. Remember - this is right out of the shipping box.

1. Hook up my monitors, keyboard/mouse, network cable and the power cable provided
2. Windows 7 Pro first time setup
3. Install Google Chrome
4. Log into Autodesk account, download Maya installer
5. Begin Maya installation - never finished, BSOD

I have written back to the sales rep and the original rep requesting that we start the refund procedure. Normally the original rep would get back to me pretty quick, but not this time. And I asked the sales rep about a refund about two days ago now with no response. What are my other options at this point? My situation is this: I have spent a lot of money on something which does not work. What can I do about this?

Replies (96)
3 Argentum
1277

The drive that disappeared probably just lost it's mount point assignment (Drive letter). 

  • Open the WinX menu by right clicking over Start and select Disk Management
  • Find the HDD, right click on the affected partition, and select Change Drive Letter and Paths
  • select a Change, pick a drive letter, and hit ok twice

For graphics drivers especially, it's always best to utilize the ones directly from the manufacturer [Nvidia] vs Dell.  Tech Support will tell you different many times, however Dell is usually a year or more behind manufacturers in releasing "dell approved" drivers.  (Think cell service providers and how they treat android updates)

If you do start getting BSODs again, I would encourage you to email Executive Resolutions, provide a link to this, and any other threads on other sites, and request a 10% discount if you decide you want to stick with Dell.  You have far more patience than I, as your experience has to be quite frustrating.

  • If another BSOD does occur, it should create a memory dump file in the Windows directory that will probably be around 1.5GB in size.  Prior to returning the PC, copy the dump file to external storage and inform dell you have the memory dump if they'd like to debug it.

SilverStone DS380 AsRock C2750D4I | AW 18 In Win Chopin SuperMicro A1SRi-2758F
2.4gHz 8C Avoton C2750 | OC 3.5gHz 4C 4710MQ 2.4gHz 8C Avoton C2758
32GB Crucial ECC ; Vantec UGT-PCE430-4C | 32GB Crucial ; 8GB M290x 16GB Kingston ECC
Seagate: ST4000VN000 (8) Z1 ; ST750LX003 (3) Z1 ; Samsung 850 EVO 120GB | Samsung 850 Evo: 1TB ; 500GB mSATA Samsung 850 Pro 128GB
FreeNAS 9.3 | Win 10 Pro Sophos UTM 9.3

1277

Will do, thanks. I finished with the drivers, I'm creating a restore point now and starting windows updates.

During all the driver searching/downloading, no BSOD's. So far. Of course I was also manually restarting constantly.

I still can't see the 2TB drive though in WinX. I think what might have happened is this morning, when running your Command Prompt steps the first time, I ran the diskpart steps so literally that I set disk 0 to GPT, and it turns out disk 0 is actually the 2TB drive. This latest time I correctly GPT'd drive 1, which was the OS drive. Can I get disk 0 back from GPT by reformatting somewhere? 

3 Argentum
1277

DO NOT write anything to the HDD,

DO NOT attempt to access it outside of the program below

As long as you don't, it's a fairly simple process to get your partition back

Just so I understand correctly, 2TB disk was mbr and you accidentally converted it to gpt? Or was it already gpt and you simply ran the clean command?

Download TestDisk 

Prior to running it, please read the following:

  • If you do not have a thorough understanding, please search on Google for what you may not have a grasp of yet.  Once you feel you have a thorough understanding, open up TestDisk, create a log, and proceed recovering the lost partition(s)

SilverStone DS380 AsRock C2750D4I | AW 18 In Win Chopin SuperMicro A1SRi-2758F
2.4gHz 8C Avoton C2750 | OC 3.5gHz 4C 4710MQ 2.4gHz 8C Avoton C2758
32GB Crucial ECC ; Vantec UGT-PCE430-4C | 32GB Crucial ; 8GB M290x 16GB Kingston ECC
Seagate: ST4000VN000 (8) Z1 ; ST750LX003 (3) Z1 ; Samsung 850 EVO 120GB | Samsung 850 Evo: 1TB ; 500GB mSATA Samsung 850 Pro 128GB
FreeNAS 9.3 | Win 10 Pro Sophos UTM 9.3

1277

Ah never mind, found the missing drive. It was hidden in the bottom pane, I had to scroll around and format it.

2 Bronze
2 Bronze
1277

Edited post since it took all day for it to clear moderation it's irrelevant. I defer to my later post below

2 Bronze
2 Bronze
2714

I want to chime in... I have the exact same hardware as you and have been experiencing pretty much the same problems you have. At least I've had our company IT guy helping along the way.

Like you I wanted to keep the Win7 installed because I'm waiting on software to catch up. My issues started when trying to update the Win7. Quite a few updates did install but had issues with 17 of them. I tried repeatedly with no success, even selecting them individually. BSODs were a regular occurence while we fought for those 17 updates. After a LENGTHY and frustrating call to support we were told the hardware was not meant to be used with Win7 and we HAD to upgrade to Win10.

We resigned to the idea that I had to use Windows 10 and hope the software would work. We tried to use the DVD that came with the system but it installed the new OS on the D drive. It turns out that when you boot from the computer it assigns the "c" volume to the SSD, but when you boot from the DVD it assigns the "c" volume to the 2TB drive, and there's no way to select (that I knew of) the SSD drive. Because of this I chose to update OS via the MS website. This failed a couple times until I uninstalled all the updates that Win7 did take.

So then I had 10 pro on my machine and things were looking up but it turned out I just swapped my BSOD for a LBSOD (Light Blue Screen of Death) with the same WHEA_UNCORRECTABLE_ERROR error. I loaded my Office and Adobe software that came with the computer and thought I'd just work my way though it since the crashes were less frequent and I was confident it was a video driver issue.

I went into the office on Saturday evening and thought I'd mess with it some more using Premiere video editing as a method of stressing the machine into another failure (doing a lot of work saves). After a couple of LBSOD failures within a few minutes of each other requiring a reboot each time I decided to get rid of an annoying message that kept popping up about my wifi card doing something wrong. I had not paid any attention to it since I was plugged in but went in and disabled the driver to stop getting the messages. I did that just before 5pm on Saturday. I then went on to do a lot of video work until I got tired and went home at 9pm with no LBSODs. Before leaving I thought I'd give the machine a better test and have it render the 2 hours of video. It shows it finished at 10:25pm.

I had installed logmein so I could check in on it throughout the rest of the weekend and it was just happy sitting there. I wasn't 100% sure I was in the clear so I kept reading through the weekend (and found your thread) and also came across the WhoCrashed app. I downloaded and installed WhoCrashed and got reports and a notice pointing to the wireless driver. See below.

On Sat 11/21/2015 9:53:04 PM GMT your computer crashed
crash dump file: C:\WINDOWS\Minidump\112115-15781-01.dmp
This was probably caused by the following module: hal.dll (hal!HalBugCheckSystem+0xCF)
Bugcheck code: 0x124 (0x4, 0xFFFFE00140ED3038, 0x0, 0x0)
Error: WHEA_UNCORRECTABLE_ERROR
file path: C:\WINDOWS\system32\hal.dll
product: Microsoft® Windows® Operating System
company: Microsoft Corporation
description: Hardware Abstraction Layer DLL
Bug check description: This bug check indicates that a fatal hardware error has occurred. This bug check uses the error data that is provided by the Windows Hardware Error Architecture (WHEA).
This is likely to be caused by a hardware problem problem. This problem might be caused by a thermal issue.
The crash took place in a standard Microsoft module. Your system configuration may be incorrect. Possibly this problem is caused by another driver on your system that cannot be identified at this time.

***(9 more identical reports with different times)***

15 crash dumps have been found and analyzed. Only 10 are included in this report. A third party driver has been identified to be causing system crashes on your computer. It is strongly suggested that you check for updates for these drivers on their company websites. Click on the links below to search with Google for updates for these drivers:

bcmwl664.sys (Broadcom 802.11 Network Adapter wireless driver, Broadcom Corporation)

If no updates for these drivers are available, try searching with Google on the names of these drivers in combination with the errors that have been reported for these drivers. Include the brand and model name of your computer as well in the query. This often yields interesting results from discussions on the web by users who have been experiencing similar problems.

So, I will follow your progress in this thread and see how things turn out for you in case I need to head down that path, but so far...

 

3 Argentum
1277

Thurston,

It is nice that all your troubleshooting efforts seem to have paid off, but the computer is not what you wanted or ordered.  You ordered a Windows 7 pro machine and now have a Windows 10 machine.  You may want to check out if Maya works on that as Adobe does not state compatibility with Windows 10 for any version of Maya.

Good luck.

1277

Thanks Cathaleen, it's true that I did order a win7 machine specifically because I was concerned about compatibility. But I've got my apps working so far. Last night when I finished the clean install, I then installed only the essential drivers, like the ones JW had in red, Intel RST, and then for audio/video I'm using NVIDIA's drivers from their site, instead of the Dell ones. I left Networking as the generics. I then set a restore point and started installing my apps. No BSOD's. In fact, overnight I set up a 1000 frame Maya render and downloaded the Unreal Editor, woke up this morning, rendering was done and Unreal was ready to go.

Closest I can figure out is that one of the drivers available for download on my Dell product page is corrupt/incompatible. It's either the Dell version of the Nvidia drivers or maybe one of the networking drivers as JW mentioned previously. But I think I might be in OK shape here. I'm going to keep letting it soak and check it again around lunch, make sure Photoshop installs.

3 Argentum
1277

How you ran into this problem with two machine in a row us quite remarkable.

You said it happened right out if the box which means it was preloaded with corrupt software and that seems highly unlikely.   Very odd.   You paid up to get a Windows 7 pro and you are not even using it.  Worse you had to spend hours and hours trying to sort it all out by troubleshooting yourself calling Dell, and installing 10.  This has got to be one of the most costly new pcs ever.  If I was not recently exposed to the new complete lack of interest by Dell's management in understanding and learning from events like this I would suggest that you write a letter to Mr. Dell.  But alas that will just waste more of your time and it will fall on deaf ears.

1277

Oh I'm definitely writing them something. Since they likely pre-install all the Dell drivers in the manner JW described, using some ghost image or something, that's probably why the previous system failed as well. I likely could've got up and running by doing the same steps on that one. Instead, tech support recommended a motherboard replacement, and we couldn't get back to windows after that was done.

If I had more time I'd install those Dell drivers one by one and try to soak each until I found the bad one. But I think I've spent enough time troubleshooting at this point. I'll suggest they try that so hopefully no one else has to deal with this. I haven't seen a lot of posts like mine about the 8900 failing people, I must have an unusual hardware combo or something. Or I have hardware that happens to need that broken driver.

Regarding cost - Fortunately this is my personal/home computer and I had a lazy weekend where I could work on the other machine while attempting these various fixes. Would've been nice if it, you know - just worked - without all the extra effort. Thankfully I had you guys to help guide me through. BTW Just got Photoshop installed, everything still seems good. 

Latest Solutions
Top Contributor