1 Nickel

TPM Firmware Update in SCCM WinPE

I've tried to run the TPM firmware update here: http://www.dell.com/support/home/au/en/aubsd1/drivers/driversdetails?driverId=RF87D&fileId=367755199... on one of my Dell Latitudes through a SCCM Run Command Line task and I keep getting the same error.

The command I'm running is:

DellTpm2.0_Fw1.3.2.8_V1_64.exe /f /s /p=****** /l="*****\DellTpm2.0_Fw1.3.2.8_V1_64.log"

The Log output is follows:

***TPM flash started on 7/24/2017 at 16:38:55***
Command: D:\_SMSTaskSequence\Packages\HVP00132\DellTpm2.0_Fw1.3.2.8_V1_64.exe /f /s /p= /l="L:\TPMUPDATE2\DellTpm2.0_Fw1.3.2.8_V1_64.log"
INSTALLED TPM : 2.0, Firmware Version :
    UPDATE TPM : 2.0, Firmware Version :
Error: Unable to prepare the TPM update payload.
Exit Code = 10 (Unspecified Error)
***TPM flash finished at 7/24/2017 at 16:38:55***

Now I've done a /? on the exe and refers to a /b= option to specify the payload file but the payload file is in the main executable isn't it?

I've seen with some bios update you can use a command line option to extract the payload hdr file out, but I can't do this with the tpm firmware file.

Any help would be really greatly appreciated Smiley Happy

0 Kudos
4 Replies
1 Nickel

RE: TPM Firmware Update in SCCM WinPE

any news to this problem?

0 Kudos
1 Nickel

RE: TPM Firmware Update in SCCM WinPE

yes, I did get this working. the tpm firmware update needs to be done after a cleartpm and restart using cctk 3.3. see below sequence.

the following log output should be as follows:

1 Nickel

RE: TPM Firmware Update in SCCM WinPE

Great. Can you give the Commandline for the Clear TPM?

I get the following error:

The task sequence execution engine failed executing the action (Clear TPM CCTK 3.3.0) in the group (Prepare for BitLocker) with the error code 66
Action output: ...         --powerwarn                    --valsetuppwd
    --embsdcard                    --primarybatterycfg            --valsyspwd
    --enclavememorysize            --propowntag                   --version*
    --energystarlogo               --pwdlock                      --virtualization
    --extendposttime               --sata2                        --vtfordirectio
    --externalhotkey               --sdcardboot                   --wakeondock
    --fanctrlovrd                  --sdcardreadonly               --wakeonlan
    --fastboot                     --secureboot                   --warningsanderrors
    --firstpowerondate*            --secureguardext               --watchdogtimer
    --fnlock                       --setuppwd--wirelesslan
Process completed with exit code 66
    --fnlockmode                   --sfuenabled                   --wirelesswitchbluetoothctrl
    --forcepxeonnextboot           --sleepmode                    --wirelesswitchcellularctrl. The operating system reported error 66: The network resource type is not correct.

0 Kudos
1 Nickel

RE: TPM Firmware Update in SCCM WinPE

What method are you using to clear the TPM. Care to share please.


I am having issues using the CCTK version 4.1 and clearing the TPM on older DELL's.

Im curently looking in to updating the TPM to version 2.0

0 Kudos