Latitude E6510 A09 BIOS Update Issues

NOTE: This is not a support request.  My system now appears to be running fine on the A09 BIOS.  If anyone can explain my experiences, that would be great.  If not, I hope that this information helps others that might have experienced the same problems that I did.

About two weeks ago, I decided to update my E6510's BIOS to the A09 version.  The system came from the factory with version A05, in which I updated to version A06 shortly after receiving the computer (December, 2010). 

Some possibly relevant system specs:

OSes: Windows 7 x64, Linux (x64, kernel 3.0.1, X.org with proprietary Nvidia driver).
CPU: Core i7 740QM
Video: Nvidia Quadro NVS 3100M
Intel vPro disabled

Prior to the A06 -> A09 update attempt, the system was fully functional and stable.

I updated the BIOS from A06 directly to A09.  The update executable was run in FreeDOS booted from a USB flash drive.  There were no errors or any other unusual events during the update process (from the time of execution through the second reboot after the actual flashing process had completed).  At this time, the system started exhibiting some very unusual problems.  The system would not always appear to complete or even initiate a power on self test.  Specifically, when powering up the system, the system would not display anything but a black screen, sometimes not even turning on the LCD backlight (as in, no Dell logo, bios version display, etc.).  Other times, the system would not actually progress to the point of actually booting from the system disk.  In this case, all of the normal displays from the power on self test phase appeared as normal, but then the screen would transition to the normal blank black screen prior to the normal boot sequence and not continue any farther.  Another case that happened is where the system would boot the OS, but once booted, the system would eventually freeze, requiring a power cycle.  This happened in Windows 7, Linux, FreeDOS, and sometimes even in the Dell Diagnostics pre-boot assessment tool.  Based on events that happened later on in the struggle, the freeze (at least in Windows 7) appeared to be a deadlock or other problem causing the display driver to stop responding.  Now, to get to one case to the next, I had to forcefully power cycle the system multiple times before I could at least boot an operating system.  The problem appeared to be the worst when the system had been powered down for a significant period of time or if the system had just frozen.

At this point, I was unsure what the cause of the issue was (as in, a BIOS issue vs. a coincidental hardware failure).  Before I did this, I opened the case to check the heatsink connection to the GPU, CPU, and perhaps the northbridge (if that is in fact what the other chip is).  There were no obvious problems in this respect, so I applied some new grease and put the system back together.  I started the system again, only to find that the issues were still present. 

I then took the somewhat risky move and flashed the BIOS with the A06 version.  Just like the A09 BIOS update, I ran the updater from the USB FreeDOS installation.  At first, I thought that the problem was solved after doing this, but the only difference is that the issues occurred less frequently (or they appeared to occur less so). 

My next action was to update the Nvidia video drivers in Windows 7 x64 from 267.xx to 280.26.  The only difference here was that with the new driver, I was at least getting some BSOD's and some MiniDumps.  The error was a bug check 0x116 (video driver response timeout).  While every crash/freeze from this point on was not a BSOD, 90% of the events resulted in a bug check 0x116 being reported upon the next startup of Windows.  The issues were sporadic, with no issues occurring for up to 4 hours in some cases.

I decided to try to reinstall the A09 update in the same manner as before.  The issues were still present at that point.  I then re-downgraded back to A06.  Again, the issues were still present, though seemingly less frequent.

When I was able to boot the system into Windows, I ran a program called FurMark in order to see if somewhat GPU intensive programs might trigger the problem.  I ran the program until the GPU reached about 80 C with no ill effects.  I did this several more times with the same results.

I removed the CMOS battery with the power supply disconnected and battery removed.  I received the expected configuration checksum error, but this had no effect on the issues.

I ran the Dell Diagnostics from the Boot menu.  If it ran through the tests without freezing, it passed all tests (though I didn't do the hard drive tests).  I ran memtest86+ with USB legacy mode turned off, of which ran fine for the half pass that I let it run through.

A couple more issues appeared during POST.  Occasionally, the system would emit a beep error code.  I don't know the count on the first set of beeps, but the second set of beeps was definitely a 5.  Also, the system once displayed an error via. the lock indicators (caps lock + scroll lock).  At one point, I power cycled the system about 12 times without a successful POST (black screen with backlight turned off but power indicator was on (blue)). 

I finally decided to try downgrading the BIOS even further.  I installed the A04 BIOS via the FreeDOS USB drive like the previous updates I installed.  This was the point at which the issues had disappeared completely.  I ran the system for four days without a single problem, BSOD, or system freeze.  Note that this version is older than the one installed upon receipt.  I didn't try going back to A05 instead, but this might have solved the problem as well (unlike going to A06). 0

I then progressively updated the BIOS to A09 by applying all of the updates (A05, A06, A07, A09) in chronological order.  In between each update, I went into BIOS setup and loaded the default settings.  I am no longer having issues with the A09 BIOS.  The BIOS update files were run from FreeDOS on the same USB flash drive as discussed before.  I did not recopy the A06 or A09 update executables to the drive.  The executables were the same as when I first did the A09 update.  Granted, I've only been running this version for a day, but in the past with the A09 update, the problem usually shows up within 15 minutes of power on. 

I don't know if going from A06 -> A07 -> A09 is what prevented the problem.  But in summary, I flashed all updates A04 - A09 sequentially which resulted in a usable system.  There was a boot menu item issue in A05 (if I tried to boot to the USB flash drive, it booted the hard drive instead), but beyond that, everything appears to be running fine.




0 Kudos
3 Replies

Re: Latitude E6510 A09 BIOS Update Issues

Facing the exact same problem with bios A11, up to the part when furmark runs perfectly but random freezes still occur during bios post / os load.

Sometimes this is followed by power-on black screen and a sequence of 4 beeps followed by 5 beeps (with the second one being slightly longer than the rest)

Going to try upgrating bios one version at a time or rolling back to A04.

Either way, I have a feeling that you saved me a lot of trouble.

I can't truly express how grateful I am for such elaborate post!

0 Kudos

Re: Latitude E6510 A09 BIOS Update Issues

Hopefully you are able to solve your issue.  My system is still in proper operation since I started this thread.  I'm surprised that this issue hasn't come up before.  I'm afraid to update the BIOS on this system anymore.

0 Kudos

RE: Latitude E6510 A09 BIOS Update Issues

Guys, I have the same issue with no possbility to downgrade or upgrade BIOS, have tried both from Windows and USB free dos, system reboots and black screen, flashing Caps and Scroll/Num are solid, after few blinks all 3x are solid and blackscreen. When press Power button system restarts after 5 second. Is there are any possbility to force bios update without reboot ?.

Thanks for your help.

0 Kudos