Last reply by 06-21-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Inspiron 7586 Intel AC 9560 not working / Can not install latest driver

Hello everyone,

i have a Problem with my Inspiron 7586 since two days. Out of a sudden, my WiFi and mit Bluetooth istn't working anymore. In the device Manager, the Intel WiFi ac 9560 and the Intel Bluetooth Adapter are marked with the yellow exclamation mark! Bevor the issue I only used a vpn Client... maybe this helps.

I have tried following steps to fix this issue:

- restart

- install newest Driver with dell, with Windows device Manager, manually ( can't install the newest Driver !!!)

- uninstall device in the device Manager and restart

- update all drivers via dell update center

- update windows

-  reset windows

- recovery windows

- set bios to factory settings

- deactivate Wifi and Bluetooth in bios and restart

In the device Manager, Intel ac 9560 Shows the error : "The device could not be started (Code 10)". The intel bluetooth device shows the error: "The device could not be started (Code 10) STATUS_DEVICE_POWER_FAILURE".

The Problem is, that i can't install the newest Driver on the devices. Sometimes I got the message, that i

They don't show the newest Driver version in the device manager and when i try to install it, the Installation process get stuck ( the dell updater as well as the Intel installer) without any message.

Version Show in the device Manager: Newest version on the Intel page: 21.40.2.

Has anyone an idea to fix that Problem? I would be very grateful for any help.


Greetings, Ivo



Replies (29)

I read the's why I posted what I did...having said that, I went back to the Dell update site for the upteenth time and when I ran their diagnostic (once I clicked away from automatically being routed to services they were selling ...sigh...) it said in all green letters - all drivers are up date...then below had a list of critical updates (!?). I noticed a Bios update that had already been done but thought if it's showing up as a critical update the former may not be being read (?)...reverted idea (obviously.). Regardless, downloaded the driver/bios chipset update once more, installed and halehf'nluya Ac 9560 works! yelow triangle of fkery gone....for now. Keep in mind, this is the 3rd round in almost 2yrs...good times Dell...good times!


Nope - worked for a grand total of 20mins then ...boom, right back to large pile of crap...will try the very last solution of cmnd prompt entries (although complete wipe and fresh install of Dell factory settings and Windows 10 should have solved just about anything/everything...wish somehow Dell could be held accountable...but it's an amazing business model when you're one of perhaps 1000s with same issue and yet has 0 impact...I started out at a PC guy decades ago, just a happened to come into a MacPro 17ich and it lasted seamlessly for ....wait for it, ...almost a decade before hard drive finally crashed and integrated graphics slowly gave up...but never, ever where there any issues whatsoever with the basics of wifi connections/drivers/bios/...I enjoy learning for sure but there's limit to how much one pays for a product and then forced to spend further time and $$ to get to do what Dell sold it as....a functioning laptop at minimum. Life is short, buy a Mac. 

2 Bronze
2 Bronze


I hope you have fixed this issue by now. If not, I have something to say.

I asked for help in this very community, but the support from Dell said my warranty was expired, and they wouldn´t help me.

So, I went to Intel Support, and the guy helped me over remote access (I have an anker usb-c hub with ethernet). He spent over an hour on my laptop, but HE FIXED THE ISSUE.

As it turns out, that is a driver issue with the latest updates.

The guy even gave me the link with the steps followed to fix it, so I can pass foward to you guys.

I hope it works for you as well.

However, if you can´t fix it yourself, I recommend you contact the Intel Support, because they are way better than Dell on that matter.


Thank you for this information as it helped me to resolve this very annoying issue.  I knew about uninstalling the drivers from the device manager, but did not realize it was necessary to uninstall multiple times to peel back the layers of updates.  After uninstalling multiple times, the correct drivers were found and the device started working perfectly.  BTW, I uninstalled both the Wireless driver AND the Bluetooth driver.  Perhaps it is a combination of the two that caused the cards to fail.


I tried everything I could with the drivers - removing lots of old ones, installing latest, etc - but no joy.  It would sometimes work for a short period then fail again.

I too then ordered a new card off Amazon - - and it worked fine after I replaced it

2 Bronze
2 Bronze

After trying everything mentioned here, I finally discovered I was missing a firmware update that resolved the issue.

  1. Navigate to the Dell Update page, enter your machine details into the 'Identify your product' section and click 'Search'.
  2. Click 'Check for Updates', install all recommended updates and re-start as directed.tracys_0-1629404252560.png
  3. REPEAT STEPS 1-2, until you get the message 'No driver updates found. Your system has the most recent updates'.

This is important, because the BIOS firmware update was not in the 1st batch of updates, and nothing got fixed. But it appeared in the 2nd batch of updates, which fixed the wireless adaptor issues. 


Thanks, I tried all the fixes I could find and replacing the card was the only fix that worked for me.


You state "I suggest your Remove your Wi-Fi Card and Reset it."  I've replaced my wife's network card 3 times now on her Insperion 15 7000. How do you Reset the network card? 


Just pull it from the socket and reinstall it. that is what I meant by resetting it.

- Please kudos posts you like!
- Please "Accept as Solution" posts that are a solution.

Inspiron 13 7386
Samsung 970 Evo 1TB SSD 2nd SSD 512 GB Hynix

Precision 3440 SFF CTO BASE, Intel Xeon W-1250 (6 Core, 12M cache, base 3.3GHz, up to 4.7GHz) 16GB 2X8GB DDR4 2666MHz or 2933MHz (2933MHz requires Intel Core i7 or above) UDIMM Non-ECC Memory Windows 10 Pro for Workstations

2 Bronze
2 Bronze

Eu resolvi formatando tbm, mas o problema voltou depois de um tempo, resolvi desinstalando o driver, reinicio o notebook, vou na bios e desabilito o adaptador de wifi e bluetooth. Deixo o windows inicializar e reinicio novamente para habilitar somente o wifi dessa vez e deixo o bluetooth desabilitado (não fiz o teste de habilitar o bluetooth) deixando apenas o wifi habilitado deixo o windows iniciar e pronto o wifi volta normalmente

Latest Solutions
Top Contributor