S4MBH4V
1 Nickel

Intel Virtualization

Jump to solution

Hello there !

i have dell 7577  ( Windows 10 home ,Intel i7 7700HQ , 16 GB ram configuration ). I want to run android emulators but it always shows an error message that virtualization is not enabled though in task manager it shows it is enabled. 

I checked by disabling the intel virtualization form the bios and re enabling it. Still the problem is not solved. There is no Hyper V installed and i cannot install intel HAXM ( i.e it shows error that i have hyper v installed but it is not).

Labels (2)
0 Kudos
1 Solution

Accepted Solutions
S4MBH4V
1 Nickel

Re: Intel Virtualization

Jump to solution

i fixed it by re installing windows.

0 Kudos
6 Replies
jphughan
5 Rhenium

Re: Intel Virtualization

Jump to solution

Do you have an additional BIOS options for something like VT-d, or VIrtualization Technology for Direct I/O? Are you sure you don’t have even a few components of Hyper-V installed, i.e. have you checked the “Add/remove Windows features” list? Are you running any third-party anti-virus that may be preventing that emulator from accessing virtualization features, since virtualization can be used for rather sophisticated malware these days? If none of that helps, if you haven't already, you might want to post in forums dedicated to your Android emulator to find out the exact technical firmware, configuration, and software requirements to satisfy that emulator’s virtualization needs.

0 Kudos
S4MBH4V
1 Nickel

Re: Intel Virtualization

Jump to solution

There is a feature in the BIOS called VT for Direct IO. Yes i have checked there is no option called Hyper-V in the programs and features option. And no i don't have any third party antivirus program installed. Not only for a particular emulator , every emulator or Virtual Machine i install shows an error. Virtualization not enabled.. And I do have checked the requirements for all of those emulators or VMs

0 Kudos
jphughan
5 Rhenium

Re: Intel Virtualization

Jump to solution

Just for clarification, Hyper-V doesn’t show up in the main area of Programs and Features. From that area, you have to click “Turn Windows features on or off”. But I also just noticed that you said you’re running Windows 10 Home, which means you definitely don’t have Hyper-V since that’s only included with Windows 10 Pro and above. If you’ve already got both regular VT and VT for Direct I/O enabled in the BIOS, then my only last resort suggestion would be to update your BIOS/firmware and things like your chipset drivers in case this is some strange bug that exists in whatever version of some component you’re running right now.

0 Kudos
S4MBH4V
1 Nickel

Re: Intel Virtualization

Jump to solution

Yes i have to set that from Add or remove windows features. I updated the bios to the latest version and still i cannot use it.

0 Kudos
S4MBH4V
1 Nickel

Re: Intel Virtualization

Jump to solution

There is no device guard option in the gpedit.msc

 

Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard 

0 Kudos
S4MBH4V
1 Nickel

Re: Intel Virtualization

Jump to solution

i fixed it by re installing windows.

0 Kudos