Last reply by 05-21-2019 Unsolved
Start a Discussion
2 Bronze
2 Bronze

IsilonSD Edge free license not transferred to cluster

Hi all,

I have the following issue - when deploying IsilonSD with the Free license included this is not reflected in the cluster. During deployment I select using free license from the IsilonSD Management server, then cluster is successfully deployed, but when listing licenses it shows for all modules "Unlicensed". I am aware that CloudPools and SmartLock are not available with free license, but all other functionalities also appear as unlicensed.

Isilon Management server v 1.1.0
OneFS image v

CLI output about licenses:

isilon-sd-1# isi license list
OneFS License ID: -
Valid Signature: Yes

Module Licensed node count Actual node count Status Expiration date
SMARTQUOTAS 0 Nodes 0 Nodes Unlicensed -
SNAPSHOTIQ 0 Nodes 0 Nodes Unlicensed -
SMARTCONNECT_ADVANCED 0 Nodes 0 Nodes Unlicensed -
SYNCIQ 0 Nodes 0 Nodes Unlicensed -
SMARTPOOLS 0 Nodes 0 Nodes Unlicensed -
SMARTLOCK 0 Nodes 0 Nodes Unlicensed -
HDFS 0 Nodes 0 Nodes Unlicensed -
SMARTDEDUPE 0 Nodes 0 Nodes Unlicensed -
CLOUDPOOLS 0 Nodes 0 Nodes Unlicensed -
SWIFT 0 Nodes 0 Nodes Unlicensed -
HARDENING 0 Nodes 0 Nodes Unlicensed -
ONEFS 0 Nodes 3 Nodes Unlicensed -
Total: 12

I tried to delete the first cluster and then redeploy again as it is described in troubleshooting guide, but the situation is the same - all modules appeared as unlicensed. On the first cluster that I deployed I had to test something very urgent so I didn't bother troubleshooting missing licenses and enabled trial licenses. Of course they expired after 90 days. So I deleted the cluster and redeployed a new one, again using the Free license. And the most confusing thing is that although Isilon cluster shows modules as unlicensed the Management server counts licenses for the deployed cluster:

Licenses seen by Management serverLicenses seen by Management server

I found the following topic about same issue, but it is still not answered:

If somebody has some suggestions or ideas how to overcome this strange issue I will appreciate to share the solution.

Thank you guys,

Reply (1)

Hello Cyril,

When you uninstalled your cluster did you follow the unregister an Isilon SD edge license steps or no?  When you registered your host again did you get any error’s, or did it complete without any errors? Not sure if you are using the IsilonSD Edge With IsilonSD Management Server Installation guide, here is a link to the guide just in case you need it.

Please let us know if you have any other questions.

Social Media Support Enterprise

Top Contributor
Latest Solutions