matlap21
1 Copper

Dell Inspiron 15R SE 7520, blurred display after upgrading to windows 10

Jump to solution

Dear Dell Forum,
Recently, I have upgraded from my windows 8.1 to windows 10. After I upgraded, I found blurred displays issue.
I have done the following things to resolve my issue.

1. Updated all the latest drivers.
2. Changed screen resolution to and fro
3. Updated AMD Radeon HD 7700M series and Intel® HD Graphics 4000

For web browsers and File Explorers, I can see very clear display without any issue.
But for installed software’s (for example Skype and some other installed applications), I have the blurred display problems.
If I open “Device Manager”, I have the same issue. If I try to install any software, the pop-up box also blurry display.
I think because of this issue, system start up takes longer time.
I am researching this issue since more than a month. Please, can someone help me how to resolve this issue?

thanks in advance..!

5 Replies
matlap21
1 Copper

RE: Dell Inspiron 15R SE 7520, blurred display after upgrading to windows 10

Jump to solution

Can someone help me to fix this issue?

thanks

0 Kudos
Ltlombardi
1 Copper

RE: Dell Inspiron 15R SE 7520, blurred display after upgrading to windows 10

Jump to solution

I have this problem too.

Already update the video drivers and problem remains.

It's really annoying. See the attached file

0 Kudos
Jim Coates
6 Gallium

RE: Dell Inspiron 15R SE 7520, blurred display after upgrading to windows 10

Jump to solution

Hello all. You have posted on the Laptop Audio discussion board. You might get better results by re-posting on the Laptop Video board.

Jim Coates -- 14 years on the Dell Laptop Audio boards -- since 2/6/04 

0 Kudos
soni77
1 Copper

RE: Dell Inspiron 15R SE 7520, blurred display after upgrading to windows 10

Jump to solution

Did you resolve this issue? I am having the same. Please let me know how if you resolved it.

0 Kudos
Ltlombardi
1 Copper

RE: Dell Inspiron 15R SE 7520, blurred display after upgrading to windows 10

Jump to solution

Yes. It's quite easy: Right click the desktop -> Display Settings -> Scale and layout -> Change the size of text, apps, and other items -> change to 100% or 125% or something like that.

Another place to look at is control panel, resolution, "make text and other items larger or smaller" then make sure the box for "let me choose one scaling level for all my displays is checked"