Highlighted

Dell Studio 1555 not booting, but USB ports working.

My 6 years old Dell Studio 1555 is not booting right from a morning. No Dell logo, nothing. It worked fine till the last night.

The PC heats (slightly) as usual when i leave it ON for some time. USB ports are giving out power as usual. But when i switch it OFF using the power button, i hear a small click sound (may be the hard disk). Even the power indicator blinks fine (battery is dead).

I have also checked if the display backlight is OFF but it isn't. Have reinserted the RAMs, CMOS battery, HDD and tried, But it is not at all booting up.

0 Kudos
1 Reply
Moderator
Moderator

RE: Dell Studio 1555 not booting, but USB ports working.

Hi,

I would recommend you check out this Dell KB article about troubleshooting No Post / No BOOT issues with systems.  It may be able to help you figure out what is causing the issue. You may also want to pull up the Support pages for your system by going to the Dell Support Pages and inputting your service tag. You'll find other articles, and manuals, specific to your system that may help you out.

As for the USB, if the system has power running through it, then it may have the power running to the USB ports, which you are seeing.  

Please check out that No BOOT article I linked above.  See if there is anything there that would help you find out what is causing the issue, and if the power, caps lock, and scroll locks are either on or flashing, in a particular order, you can find out what that represents by looking at the manuals.

Let me know what you find out and I'll see if there are any other suggestions I can think of to help you.

Todd

0 Kudos