xephyre
1 Copper

Dell XPS 13 (2015) wont turn on. LED lights working

I was using my laptop normally and decided to put it to sleep by putting the screen down. I took it with me to my car and drove around a bit for about 15 minutes. When I decided to use the laptop again, I saw a wisp of smoke wafting out from where the heat sink should be--from my point of view I am looking at the screen and smoke is coming out from the keyboard. I could smell something burning. However, it's 10 degrees celsius around me so I'm not sure why any part of the laptop would be burning.

I then tried to turn the laptop on. The power button's LED flashes on and off slowly everytime I try to turn it on. Nothing comes up. I have tried removing the battery and holding the power button to remove static energy and then turning the laptop on with the battery. Nothing comes up again. However, I did hold onto D and white, green, red, and black shows up, but no beep sounds (if there are supposed to be any). I believe my laptop is in active warranty, but I'll be on vacation in a week and I need my laptop. So if possible I'd like to fix this problem myself first.

0 Kudos