Highlighted
Cameron98
1 Nickel

Dell XPS 15 trackpad lag

Jump to solution

I've been experiencing an issue where when my mouse is on the desktop, it delays a lot to my actions on the track-pad. I could draw a figure of 8 and it would take 3 seconds to complete the pattern after I drew it for example. I've cleaned my disk startup and i've updated drivers. The specs are:
GPU: GTX 960M
i7 6700Q @ 2.6GHz
16GB RAM
4k Display
500GB SSD

If anyone could help me out, that would be great. Thanks!

5 Replies
Community Manager
Community Manager

RE: Dell XPS 15 trackpad lag

Jump to solution

Hi cameron98,

Thanks for posting.

Your post doesn't say what OS you are using, so here are some general guidelines for troubleshooting and fixing trackpad issues.  If you're needing additional assistance, post back so the experts here can assist.  Thanks.

Regards,
Robert


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
shijie.toh
1 Copper

RE: Dell XPS 15 trackpad lag

Jump to solution

Hi Robert,

I've got the same issue here. The trackpad works fine on all occasions except when the mouse is on the desktop. I have tried to troubleshoot according to your link but it hasn't fix this issue.

My specs are the following:

GPU: GTX 960M

i7 6700Q @ 2.6GHz

16GB RAM

4k Display

500GB SSD

Windows 10

Regards,

Shijie

0 Kudos
Ndragonawa
1 Copper

RE: Dell XPS 15 trackpad lag

Jump to solution

I have the same issue:  The track pad will be sluggish, with no noticeable bottlenecks in Task Manager.

Same specs as everyone so far w/ Windows 10 x64.

0 Kudos
Cameron98
1 Nickel

RE: Dell XPS 15 trackpad lag

Jump to solution

Hi guys, if you have GeForce Experience, that is the cause of the lag. Just uninstall that and BAM! Bob's your uncle

lingxizhong
1 Copper

RE: Dell XPS 15 trackpad lag

Jump to solution

Good god I was busting my head over this issue uninstalling trackpad drivers and reinstalling other ones to no avail. Thanks for the tip, I had the same issue and its all fixed up now.

0 Kudos