georgeziozas
1 Copper

Main Graphic Card not detected


Hello there,

I have a dell 1558 laptop 1 year now, some days ago i accidentaly understood that my graphic card is not detected anymore by my system, i searched it and it appears error code 45 which means that my card is not in the right place. My graphic card is nvidia 920M 4GB.
Here is 2 pics from speccy and device manager.
speccy
device manager

I tried to check for updates on my graphic card but everytime i try to install it tells me that i dont have compatible component or something like that..

I have also run dell diagnostics on the gpu but it only check the default intel hf graphics 5500 , it doesnt recognise nvidia. 

thanks in advance.
Tags (1)
0 Kudos
5 Replies
8 Krypton

RE: Main Graphic Card not detected

If this is a Studio 1558, it has either Intel or ATI/AMD video - not both.

If it's a different model, please verify the exact model number of the system - it's not the one you've indicated.

If it's a 7558, it has either Intel-only or Intel-nVidia hybrid graphics - the latter was an option on some models -- it was not standard on all of them.

0 Kudos
georgeziozas
1 Copper

RE: Main Graphic Card not detected

sorry my bad, my laptop model is 5558, it comes with inte HD 5500 i think and nvidia 920M 4 gb, invidia its the card it cant identify

0 Kudos
8 Krypton

RE: Main Graphic Card not detected

Uninstall the nVidia driver if it's present.  Then do the same for the Intel driver.

Reboot the system.

Install the Intel GPU driver (from Dell's website - NOT Intel's).

Restart.

Install the nVidia GPU driver (again, from Dell's website - NOT nVidia's).

0 Kudos
georgeziozas
1 Copper

RE: Main Graphic Card not detected

i did it , but it only works for the Intel HD graphics , when i try to install again the nvidia gpu driver again the nvidia geforce experience opens and tells me that there is no suitable hardware etc... the same as before

0 Kudos
8 Krypton

RE: Main Graphic Card not detected

Is this

<<www.dell.com/.../DriversDetails;fileId=3499067508&osCode=WT64A&productCode=inspiron-15-5558-laptop&languageCode=en&categoryId=VI>>

the driver you tried to install?

0 Kudos