denisj1
1 Copper

Plugging laptop into external monitor results in low resolution

Hi,

I have an Inspiron 17R SE 7720 and ti works great however when I plug it into an external monitor LG W300H the resolution displayed is quite low. I try to choose a higher one but there are no options for higher resolutions. It's actually quite a bit lower than the resolution displayed on the laptops own screen.

Thanks for your help

0 Kudos
8 Replies
Moderator
Moderator

Re: Plugging laptop into external monitor results in low resolution

Hi denisj1,

Welcome to the community.

Please check the link below to update the video card drivers for your system:

Intel

http://dell.to/15xwOmR

Nvdia

http://dell.to/YbTe9Q

Please install the same and check again.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
denisj1
1 Copper

Re: Plugging laptop into external monitor results in low resolution

I just installed both of these drivers and the problem is still there. The mobile PC display resolution is at 1920x1080 but the external monitors only goes up to  1280x800. On my old computer I used the monitor at 2560 x 1600 so i know the problem isn't with the monitor.

0 Kudos
Moderator
Moderator

Re: Plugging laptop into external monitor results in low resolution

Hi denisj1,

I would like to inform you that this might be happening because external monitor might be using Intel display adapter only and not the Nvidia one.

Please check in Nvdia control panel and select Nvidia card for the external display and check again.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
denisj1
1 Copper

Re: Plugging laptop into external monitor results in low resolution

How do I do that? I open Nvidia control panel but I don't know where this option is.

0 Kudos
Moderator
Moderator

Re: Plugging laptop into external monitor results in low resolution

Hi denisj1,

Under Nvidia control panel make sure Use Nvidia settings is check marked. Under Display tab at the left choose the option setup multiple displays to setup the external Monitor. Please check the image attached:

Also, try and disable the Intel graphic card from device manager and then try to connect the external display.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
denisj1
1 Copper

Re: Plugging laptop into external monitor results in low resolution

Hi I think my Nvidia Control panel is buggy as it doesn't have the options to change the resolution in it. Here is what I see in it:

As for disabling the intel card I tried that and it made the resolution worse on both my laptop and external monitor

0 Kudos
Moderator
Moderator

Re: Plugging laptop into external monitor results in low resolution

Hi denisj1,

I appreciate the time and effort that you took to troubleshoot the issue.

Please contact me through a private message by clicking on my name highlighted in blue. On the next page, click the envelope icon and provide your service tag and contact information so I may access your system records.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
quant1
1 Copper

RE: Plugging laptop into external monitor results in low resolution

Hi, what was the solution to the problem ? I have the same problem.

0 Kudos