1 Copper

Precision M4600 - can't boot; can't access BIOS

I have a Dell Precision M4600 (Service Tag: <ADMIN NOTE: Service tag removed per privacy policy>) that I bought refurbished from newegg.ca. The machine is no longer under Dell Warranty, but is still under warranty with the refurbishment company, but if the fix is easy, I would rather do it myself and not send it off.

My issue is as follows:
I recently bought an mSATA SSD to add to my system as the boot disk. I had originally installed Windows 10 to the SSD with an MBR partition and was experiencing no issues. I decided to then reinstall Windows to the same drive as a GPT partition and setting the BIOS to use both Legacy/UEFI boot options. The install was successful and was working fine when I would use the system boot menu and select the new GPT drive to boot from.

However, when I set the boot settings to use UEFI as the main boot option, so that the system would boot automatically from the SSD without any intervention from me, the system now ceases to complete the boot sequence. The Dell Logo loading screen appears and the load bar reaches to the end, but then the system becomes un-responsive and never resolves, even after leaving it for an hour or so. The hardware does not appear to be under any strain one the system has locked-up.

Before the system becomes unresponsive I can press F2(Boot Menu) and F12(BIOS Menu) and the text appears saying that the system is loading those menus, but still locks once the loading bar is full. During this time I am also able to toggle NumLock on and off.

Additionally, I have used some other startup options I have found. Holding D while holding the power button to boot results in a series of display tests, but then once the system tries to perform the normal boot sequence, the previous issue is still encountered. I have also tried holding the Fn key while holding the power button to boot, and the text appears on screen saying the Diagnostics are loading, but once again it freezes at the same spot as the others do.

When I first purchased the machine in September, I updated the BIOS to the newest version for this model (A16) and experienced no issues. However, in reading online about similar models released around the same time, I found that some of them had a flaw where SecureBoot would be inappropriately applied when setting up a UEFI boot and that some of the hardware may not be SecureBoot compatible.

As such, I have attempted to remove nearly every component and attempt to boot the system. If memory and/or processor are removed, the post lights display the relevant errors.

When only a single stick of memory and the processor are present, the same boot issue occurs. I have also tried using different memory modules and different slots (this unit has 4 RAM slots). This included removing the main battery, AC, and the motherboard's coin battery; pressing and holding the power button for up to a minute to release any remaining static or residual power; and powering the unit back on simply by plugging in AC. The computer would do a prelimary boot sequence, power down, and then start the main boot sequence, but still resulting in the original issue.

Additionally, in reading online it would appear that these laptops do not include any sort of DIP switches to reset the BIOS either. Unfortunately, I cannot find a datasheet or schematic for this motherboard (8YFGW). The most I found was another user asking about the position of the EEPROM for this board, which included a response stating that there were 2 located at positions U52 and U53 on the board, which I then verified to be correct.

The chips are as follows:
U52: MXIC MX25L1606E M2I-12G (200mil 8-SOP)
U53: MXIC MX25L6406E M2I-12G (200mil 8-SOP)

In checking the datasheets for these from Macronix, the 1606E is explictly label as "CMOS SERIAL FLASH MEMORY", while the 6406E is described more genericly. Since I don't have access to any datasheets for the board, I cannot verify if one is the main and the other the backup, and if so which is which.

Since the issue only seemed to arise after making the change in the BIOS menu, I believe that there isn't anything wrong with the hardware components of the system, the motherboard, or the chips themselves, but rather that the BIOS is simply in an invalid state and unable to finish the boot sequence and also unable to recognize that the state is invalid and force it into backup recovery mode.

Is there any way to force the BIOS to reset or to load the backup image? Is there anywhere I can find a datasheet for the 8YFGW motherboard?


0 Kudos
1 Reply
1 Copper

RE: Precision M4600 - can't boot; can't access BIOS

Hello. I have exactly same problem... after I changed SATA to AHCI e boot to UEFI it hangs on Dell logo exactly as you described. Did you find solution??

0 Kudos