Highlighted

Unresponsive Touchpad in Dell Inspiron 3551

Jump to solution

Just bought this laptop from a friend and installed Ubuntu 16.04 LTS.

The installation went well until it booted up and I saw that my touchpad is not working. It used to work fine in my friend's Windows as well!

Here's my xinput:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]  
⎜   ↳ Virtual core XTEST pointer                    id=4    [slave  pointer  (2)]  
⎜   ↳ 2.4GHz RF  KEYBOARD  AND  MOUSE               id=11   [slave  pointer  (2)]  
⎜   ↳ DLL06AB:00 06CB:78F1                          id=13   [slave  pointer  (2)]  
⎜   ↳ SynPS/2 Synaptics TouchPad                    id=15   [slave  pointer  (2)]  
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]  
    ↳ Virtual core XTEST keyboard                   id=5    [slave  keyboard (3)]  
    ↳ Power Button                                  id=6    [slave  keyboard (3)]  
    ↳ Video Bus                                     id=7    [slave  keyboard (3)]  
    ↳ Power Button                                  id=8    [slave  keyboard (3)]  
    ↳ Sleep Button                                  id=9    [slave  keyboard (3)]  
    ↳ 2.4GHz RF  KEYBOARD  AND  MOUSE               id=10   [slave  keyboard (3)]  
    ↳ Integrated_Webcam_HD                          id=12   [slave  keyboard (3)]  
    ↳ AT Translated Set 2 keyboard                  id=14   [slave  keyboard (3)]  
    ↳ Dell WMI hotkeys                              id=16   [slave  keyboard (3)]  

I really want this to start working as my work at JustDoc is totally dependent on this and my productivity has gone down without a working trackpad.

P.S. I'm totally new to Ubuntu. TIA.

1 Reply

RE: Unresponsive Touchpad in Dell Inspiron 3551

Jump to solution

I faced the similar issue. You can fix it by switching off i2c_hid and setting nopnp in boot parameters this way

1. Run

sudo -H gedit /etc/default/grub

In the open window edit line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

it should look this way

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp"

Save file and run

sudo update-grub

2. Run

echo "blacklist i2c_hid" | sudo tee /etc/modprobe.d/i2c-hid.conf

sudo depmod -a

sudo update-initramfs -u

echo "synaptics_i2c" | sudo tee -a /etc/modules

3. Reboot.

Enjoy !! and let me know if that worked for you.

0 Kudos