OrinVukelic
Not applicable

Waves MaxxAudio Pro turns "Speaker Enhancement" on automatically

Jump to solution

Hi, I have Dell Inspiron 5558 and today I noticed that when I turn "Speaker Enhancement" off, it turns back on automatically after "Dell Audio" is closed. It doesn't happen for "Microphone Enhancement", just for "Speaker Enhancement". I think it occured first when I updated Realtek HD Audio Driver. If that is so, is there any known fix for that, since I don't remember which version of driver I had before?

0 Kudos
1 Solution

Accepted Solutions
Jim Coates
7 Gold

RE: Waves MaxxAudio Pro turns "Speaker Enhancement" on automatically

Jump to solution

Hello. Sorry for the slow reply.

If checking the disable all enhancements box is not working correctly, you could revert to the previous driver.

Return to the previous version of the driver by using "rollback driver". Open Device Manager, Sound Controllers, right click on Realtek audio driver, properties, driver tab. This is a screen shot from a laptop with IDT audio, but otherwise it shows the dialog.

If that doesn't work, you can install any version of the driver you want. Select "uninstall", then in the next dialog check the box to delete the files.

Restart the laptop and the driver will be removed. Check the Device Manager after restarting. If you still see Reatek High Definition Audio there, that means there was an older version that had been downloaded at some point in the past, and Windows installed it after removing the current driver. Repeat the uninstall process until Realtek is no longer in Device Manager Sound Controllers, and "High Definition Audio Device" appears in its place. That is the Windows native audio driver.

At that point you can install any version of Realtek audio driver from the Inspiron 5558 html driver page. If you install an old driver, you can then install a newer one right over it without going through the uninstall process again, then when you get to a version that doesn't work right, just use the rollback feature to return to a working version. Make sure to only select versions that are meant for whatever operating system you have. Look in the right hand column for supported OS. WT = Win10, and WB = Win8.1.

Jim Coates -- 16 years on the Dell Laptop Audio boards -- since 2/6/04 

View solution in original post

0 Kudos
1 Reply
Jim Coates
7 Gold

RE: Waves MaxxAudio Pro turns "Speaker Enhancement" on automatically

Jump to solution

Hello. Sorry for the slow reply.

If checking the disable all enhancements box is not working correctly, you could revert to the previous driver.

Return to the previous version of the driver by using "rollback driver". Open Device Manager, Sound Controllers, right click on Realtek audio driver, properties, driver tab. This is a screen shot from a laptop with IDT audio, but otherwise it shows the dialog.

If that doesn't work, you can install any version of the driver you want. Select "uninstall", then in the next dialog check the box to delete the files.

Restart the laptop and the driver will be removed. Check the Device Manager after restarting. If you still see Reatek High Definition Audio there, that means there was an older version that had been downloaded at some point in the past, and Windows installed it after removing the current driver. Repeat the uninstall process until Realtek is no longer in Device Manager Sound Controllers, and "High Definition Audio Device" appears in its place. That is the Windows native audio driver.

At that point you can install any version of Realtek audio driver from the Inspiron 5558 html driver page. If you install an old driver, you can then install a newer one right over it without going through the uninstall process again, then when you get to a version that doesn't work right, just use the rollback feature to return to a working version. Make sure to only select versions that are meant for whatever operating system you have. Look in the right hand column for supported OS. WT = Win10, and WB = Win8.1.

Jim Coates -- 16 years on the Dell Laptop Audio boards -- since 2/6/04 

View solution in original post

0 Kudos