Highlighted
Opus104
1 Copper

XPS 9360 BIOS 1.3.7 created USB dropout/lag in WD15 dock

Much like has been reported three days ago with the TB16 dock (see here), once I updated the Bios on my XPS 13 to 1.3.7, I started experiencing unexpected cutouts of USB powered devices. In this case, it was my Logitech universal receiver. This cause stuttering/dropouts of the mouse.

When I switch to the on-board USB slot on my laptop - no issue. Whether the USB 2 or USB 3 slots on the dock - the problem returns.

I have no issues with my HD monitor or with the Ethernet connection on the dock - just the USB. Every driver is up to date and, as I said, the ports in the laptop work great.

2 Replies
Saltgrass
4 Germanium

RE: XPS 9360 BIOS 1.3.7 created USB dropout/lag in WD15 dock

I suppose the obvious question would be have you tried a wired mouse?

I remember comments about a Logitech wireless mouse causing problems for some systems after a prior Win 10 build update.

Does the WD 15 use the ASMedia USB drivers and have they been updated since the Bios update?

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Opus104
1 Copper

RE: XPS 9360 BIOS 1.3.7 created USB dropout/lag in WD15 dock

Wired or wireless, the USB seems to be the issue. My only solution is to plug into the laptop or, as I did, shell out extra money for a Bluetooth keyboard and mouse. (Which works great)

The audio/mic jack works fine for my headset, and the Ethernet and HDMI have no issue. I am just happy I do not rely on a USB mic or webcam.

0 Kudos