battery plugged in, not charging

I apologize in advance if this has already been addressed here, I do not see a way to search this forum.

I have an Inspiron 15, 5000 series laptop running Windows 10.  It worked using AC power, but not battery.  The toolbar battery icon message says "0% available (plugged in, not charging).  I have tried several variations of online recommendations to remove the battery and either disable, reinstall, or uninstall drivers.  All were unsuccessful.  

I did notice that if I remove the battery, the battery icon says "no battery detected".  When I plug it back in, the text changes for about 1 minute to "0% (plugged in, charging), and the icon shows charging, but then it reverts to the 'normal' "not charging" status.

Based on this info, how do i determine if this is a hardware problem requiring a new battery, if it is a software problem other then the driver problem that tried earlier, or some other charger problem?



0 Kudos
3 Replies

RE: battery plugged in, not charging


Thank you for writing to Dell Community Forum.

Please boot into BIOS <F2> and check if the battery is detected.

What is the latest BIOS version installed on the system?

Please private message us the service tag of the system along with your email id.

(Note: please don't mention the service tag or email id on the public forum as it contains your personal information).

DELL-Akshatha M
Social Media and Community Professional

DELL-Akshatha M
Social Media Support
Dell Support Videos 
Drivers and Downloads

0 Kudos

RE: battery plugged in, not charging

Thanks for helping with the problem.  

The BIOS (in Settings/General/Battery Information) says that the primary battery is 0% charged, Idle, Health: Excellent, and AC Adapter = Unknown.  

I noticed that the BOIS Events log shows several events showing "Alert! Unknown AC power adapter, may affect performance".  The most recent event like this was on June 04.  The only AC adapter used is the one that came with the laptop.

The BIOS Version (shown in Settings/General/System Information) is A03.

I will private email the service tag and email info.



0 Kudos
8 Krypton

RE: battery plugged in, not charging

This is a hardware problem with the adapter, power jack or the mainboard.  If the adapter is unknown, the battery will not charge.

If you're in warranty, call Dell for repair.  If not, in order:

Replace the adapter with a new OEM Dell unit, and if that doesn't solve the problem,

Replace the DC jack inside the system-- if that fails to get the adapter recognized,

Replace the mainboard.

0 Kudos