Start a Discussion
2 Bronze
2 Bronze


So, I typed in mbr2gpt /convert in Windows Recovery Environment and of course i got an error:

MBR2GPT: Attempting to convert disk 0
MBR2GPT: Retrieving layout of disk
MBR2GPT: Validating layout, disk sector size is: 512 bytes
MBR2GPT: Trying to shrink the system partition
MBR2GPT: Trying to shrink the OS partition
MBR2GPT: Creating the EFI system partition
MBR2GPT: Installing the new boot files
MBR2GPT: Performing the layout conversion
MBR2GPT: Migrating default boot entry
MBR2GPT: Adding recovery boot entry
MBR2GPT: Fixing drive letter mapping
MBR2GPT: Conversion completed successfullyCall WinReReapir to repair WinRE
MBR2GPT: Failed to update ReAgent.xml, please try to manually disable and enable WinRE.
MBR2GPT: Before the new system can boot properly you need to switch the firmware to boot to UEFI mode!

Do i need to reinstall Windows 10?(Don't worry i have a backup and a installation USB) 

Also if there is a fix that does not involve reinstalling can i let my laptop sleep in the WinRe Command Prompt?

Replies (6)
2 Bronze
2 Bronze

Also i don't know the disk sector size, i just got this from another forum, and it was the same error so yeah.

7 Thorium

@adelluser565  Looks like the conversion completed despite the error about the Windows Recovery environment. In terms of the recommended action of manually disabling and enabling WinRE, that can be done from within Windows in an elevated Command Prompt by entering “reagentc /disable” and then “reagentc /enable”.

I'm sorry about the system32 part ,  I completely forgot system32 was inside Windows. I'll run reagentc and update you with the results. I shutdown the laptop but I am going to try to run cmd out of Windows Setup.(Also the disk is now GPT , and so is my bootable flash drive)

@adelluser565  Not sure what the first sentence means, but good to hear your internal disk is now GPT.  Your flash drive does not need to be in GPT in order to be booted in UEFI mode though.  If you keep it MBR it will be able to support both Legacy BIOS and UEFI booting.

Sorry for my replies but when i try to boot of my WINDOWS 10 flash drive weird lines appear when i select it. 

Edit: I tried it with another flash drive but still some weird horizontal white straight lines? Is it a BIOS issue?

I'm having the exact same issue with the usb and the horizontal lines. let me know if you've found anything out.

Top Contributor
Latest Solutions