PPPeter
1 Copper

P2418HT, USB 3 cable disconnected, flickers when touched

Hi, 

In my office there is an P2418HT touch monitor that is mounted on a Ergotron arm, shared by a few people.

Whenever we adjust the monitor (push, pull the Ergotron arm) or physically touch it, it would flicker/ goes black for 1 second then comes back on. It is quite irritating. 

I discover this is due to the USB 3.0 upstream cable being disconnected. The reason is probably: without the USB 3.0 cable, the  P2418HT touch monitor registers every touch and movement as an touch input, but the signal has "nowhere to go to be processed", causing the monitor flicker/ black out.

The flicker does not happen when I plug the USB 3.0 cable to the laptop I'm using. If you don't plan to use touch feature you can disable it at "device manager". Once disabled, the flicker appears to be gone.

However the problem will return when the USB 3.0 cable is unplugged and/ or you reboot the monitor (power off, then power on). Does anyone has a solution that does not required the USB 3.0 cable to be plugged in?

Labels (1)
Tags (2)
0 Kudos
2 Replies
Moderator
Moderator

Re: P2418HT with USB 3 cable disconnected, flickers when tou

 

If the USB 3.0 cable is NOT connected to the P2418HT USB 3.0 upstream port, then all P2418HT "touch" functionality should be disabled?

When you, "adjust the monitor (push, pull the Ergotron arm) or physically touch it", are you sure that the power cable or video in cable (HDMI, DP, or VGA) are not being slightly pulled away from the P2418HT ports, registering a disconnect/reconnect?

0 Kudos
Highlighted
jdixon4
1 Copper

Re: P2418HT with USB 3 cable disconnected, flickers when tou

 I am having the same issue. I have 2 of these monitors but I only want one connected for touch, so the second one is not connected. When I touch the disconnected monitor it flickers about a second or so later, which is undesirable. When I look in the device manager under Human Interface Devices I only see one HID-compliant touchscreen. How do I disable the second one since it doesn't show in the list? Is there some other setting somewhere to completely turn off the touch?

0 Kudos