Highlighted
sarkis f
1 Copper

U3818DW, USB Type-C, stopped functioning

Don't know if anyone has the answer on how to fix this, and it may just need to be RMA'ed. Recently purchased a Dell U3818DW Curved Monitor and it worked just fine out of the box. 5-6 hours later it stopped working. DisplayPort works fine but not the USB Type-C output. The monitor charges my MacBook Pro Touch bar but doesn't send data.

Tried:
-New USB-C cable
-Installed new firmware
-Tried Mac and PC 

Any other tricks that might work?

Tags (2)
0 Kudos
1 Reply
Moderator
Moderator

Re: U3818DW, USB Type-C, stopped functioning

 

* Was this U3818DW purchased directly from Dell?
* What specific PC model are you testing on the U3818DW?
* Turn the PC off
* Turn the U3818DW off
* Disconnect every cable and device from the rear and side of the U3818DW. Including the power cable
* Press and hold in the U3818DW power button for 10 seconds
* Reconnect the U3818DW USB Type-C cable to the PC and the U3818DW
* Reconnect the power cable to the U3818DW
* Turn the U3818DW on
* Turn the PC on
* Press the middle U3818DW Menu button
* Go to Input Source
* Check USB Type-C

What happens?

0 Kudos