mnefferdorf
1 Nickel

Exchange NMM pseudo_saveset fails

Hello all,

any thoughts on this?

Exchange backup in a DAG with 2 servers. Every week the Exchange backup with NMM failes on a certain day. All mailbox backup succeed, but only the backup of the pseudo_saveset fails. Then the whole workflow keeps running and needs to be stopped manually. All other days the backups succeed without any problem. But there is no any other problem on Exchange or operating system site obvious and distinguishable in eventlogs. No restart or reboot. Also Networker logs are not helpful. I already changed the start time from 1:50 am to 11pm. But the problem then occured on Friday instead of Tuesday. Backup level is always full. Why is pseudo savest failing once a week?  Thanks a lot in advance.

NWS: W2k8R2 with NW 9.1.1.5

NWC: W2k8R2 with NW and NMM 9.1.1.4

here the details of the failed pseudo_saveset from NMC log:

Unable to render the following message: 107092:nsrnmmsv: Version information for C:\WIN64APP\nsr\bin\nsrnmmsv.exe: Original file name: nsrnmmsv.exe Version: 9.1.1 (ntx64) Comments: Supporting Microsoft Volume Shadow Copy Service Unable to render the following message: 127159:nsrnmmsv: Created temp path C:\WIN64APP\nsr\tmp\nmm\2017-12-15_23-00-10_15656-14000\. Unable to render the following message: nsrnmmsv: multithreaded save set parallelism==4 Unable to render the following message: 145369:nsrnmmsv: Initialization success -- Exchange shell successfully initialized. Required for Exchange. 15.12.2017 23:00:40  Exch01  Starting backup operation. 15.12.2017 23:00:40  Exch01  Initialization success -- Exchange shell successfully initialized. Required for Exchange. 15.12.2017 23:00:40  Exch01  DAG IP: 10.45.22.93. 15.12.2017 23:00:40  Exch01  The Exchange DAG name "DAG02 " was provided by the user.  The actual DAG name is "DAG02 ".  15.12.2017 23:00:40  Exch01  The federated Exchange backup state is set to PREFERRED, which selects passive, if available, on any node.  If a passive copy of a database is unavailable, the active copy is selected.  This method includes all mounted databases in the backup. 15.12.2017 23:00:40  Exch01  Exchange federated .. A preferred server order list has been provided. 15.12.2017 23:00:40  Exch01  Exchange federated .. Server order checked for databases: 15.12.2017 23:00:40  Exch01      Exch01  15.12.2017 23:00:40  Exch01      Exch02  15.12.2017 23:00:43  Exch01  Exchange federated ..  Databases in DAG have been evaluated for backup..continuing. 15.12.2017 23:00:44  Exch01  Skipping user specified component from backup PFDB02. 15.12.2017 23:00:44  Exch01  Starting 'secondary' backup job on host : Exch01 . 15.12.2017 23:00:44  Exch01  jobhandler(306): Created Job ID: 37684\n Save command: nsrnmmsv.exe -s NWServer -g Exchange/Exchange_10/backup/Exchange_10 -m DAG02  -b ExchangeDD -l full -y "Fri Dec 29 23:59:59 GMT+0100 2017" -Z DAG02  -A *NSR_BACKUP_GENERATIONID=1513375210 -A NSR_APP_TYPE= -A NSR_EXCH_CHECK=no -A NSR_EXCH_DAG=DAG02  -A NSR_EXCH_INCL_SA=TRUE -A NSR_EXCLUDE_COMPONENTS=PFDB02 -A NSR_FEDERATED_BACKUP=yes -A NSR_FED_SECONDARY=yes -A NSR_SINGLE_SNAPSHOT=No -a "*POLICY ACTION JOBID=37654" -a "*POLICY ACTION NAME=backup 15.12.2017 23:01:31  Exch01  Signal message received from Exch01 . 15.12.2017 23:01:31  Exch01  Starting 'secondary' backup job on host : Exch02. 15.12.2017 23:01:31  Exch01  jobhandler(306): Created Job ID: 37699\n Save command: nsrnmmsv.exe -s NWServer -g Exchange/Exchange_10/backup/Exchange_10 -m DAG02  -b ExchangeDD -l full -y "Fri Dec 29 23:59:59 GMT+0100 2017" -Z DAG02  -A *NSR_BACKUP_GENERATIONID=1513375210 -A NSR_APP_TYPE= -A NSR_EXCH_CHECK=no -A NSR_EXCH_DAG=DAG02  -A NSR_EXCH_INCL_SA=TRUE -A NSR_EXCLUDE_COMPONENTS=PFDB02 -A NSR_FEDERATED_BACKUP=yes -A NSR_FED_SECONDARY=yes -A NSR_SINGLE_SNAPSHOT=No -a "*POLICY ACTION JOBID=37654" -a "*POLICY ACTION NAME=backup 15.12.2017 23:03:11  Exch01  Signal message received from Exch02. 15.12.2017 23:56:37  Exch01  Secondary backup with job id (37684) is successful on host 'Exch01 '

0 Kudos
4 Replies
bingo.1
4 Tellurium

Re: Exchange NMM pseudo_saveset fails

With respect to pseudo-save set errors:

Before you do anything else, max I suggest that you set the 'Inactivity Timeout' for the action to 0 and avoid potential problems which could be caused by this setting.

increase the

0 Kudos
mnefferdorf
1 Nickel

Re: Exchange NMM pseudo_saveset fails

Inactivity timeout is already set to 0. I always use this setting as this is a good choice. 😉

I will try to reregister the Exchange user. Perhaps this helps. But I'm wondering, because all other days in the week are successfully.

0 Kudos
ble1
5 Iridium

Re: Exchange NMM pseudo_saveset fails

I have seen pseudo savesets fail with regular backups too in some cases when backing up disk with encryption vault (if encryption was used).  Strange thing there was that we would change VSS snapshot to be mounted under different disk, make backup (it worked) and then revert settings back and it would work again.  Never figured out why does this happen. I'm not  sure what pseudo saveset is under NMM, but I suspect it is also VSS related.

0 Kudos
mnefferdorf
1 Nickel

Re: Exchange NMM pseudo_saveset fails

Thanks Hrvoje, today we do have the same issue on another system with normal file backup. The backup job ran with all save sets, but the workflow does not end. It keeps running. It only stops when stopping it manually. a manual attempt to backup the same clients succeeds and finishes correctly.

Sorry for aksing. Am I right? You configured a different drive letter under "Located on this volume" and made a manual VSS snap. Then you moved back the drive letter location and then it worked?

Thanks a lot.

0 Kudos