AngeLinux1
1 Nickel

I can't Login to NMC 7.5 SP1

Hi everybody

I hava a problem to get login in NetworkerManagmentConsole, because from some workstation after I put my user and password I can not enter to the console and I never receive any error message (I wait around 4minutes) but from others workstation I get login.

I have reinstalled the NMC and Java from my laptop, but I still have this problem. Other information is that with this laptop go to other NetworkerServer in other site and I get login without problems.

What can I do, for solve this??

Thanks for your assistance.

--
Angel

0 Kudos
10 Replies
Highlighted
coganb
3 Cadmium

Re: I can't Login to NMC 7.5 SP1

It could be that there are communication problems between the two machines due to name-resolution issues or because of firewall problems.  Check that the name resolution is ok for both hosts and check that the correct ports are open.  For an explanation on the ports, I paste here the relevant section from Configuring TCP Networks and Network Firewalls for EMC NetWorker

"

The Console server component of NMC uses 3 ports:

- One port (9000 by default) is used for the web server, which provides a way to download the java application code that acts as the Console front end. This port is selected during the installation process.

- The second port (9001 by default) is used for RPC calls from the Console Java client to the Console server. This port is selected during the installation process.

- The last port (2638 by default) is used for database queries.
The NMC ports are not taken from the range configured by using nsrports and are only for communication between client workstations (systems running the Java GUI) and the NMC server.
The Console server communicates to the NetWorker server using service ports from the standard NetWorker range (as defined by nsrports).

"

You can find this document on support.emc.com:

-Bobby

AngeLinux1
1 Nickel

Re: I can't Login to NMC 7.5 SP1

Thanks Bobby for that information.

I will review those ports in my network.

0 Kudos

Re: I can't Login to NMC 7.5 SP1

Don't install the Java manually

it will be installed auto when you start the networker execution file

Akkoub

0 Kudos
ble1
6 Indium

Re: I can't Login to NMC 7.5 SP1

I have something like that, but it is not related to NMC, but rather network.  I sniffed the traffic between and found network will cause TCP Reset-I when I initiate connection.  Our network ppl are looking into it, but since I use another stepping server to access NMC I really do not mind the error.  For now it seems as NAT translation in the firewal is cauing this issue, but we are not 100% sure.

0 Kudos
AngeLinux1
1 Nickel

Re: I can't Login to NMC 7.5 SP1

Hi thanks for your information

This is strange, because I configure my laptop with the IP that can connect correctly to the NMC, however I can not access to the NMC.

For that reason Thought that is a java problem. Other info is that when I put an incorrect login I receive quickly a error messasge but when I put the correct login I dont receive any message

Thanks

--

Angel

0 Kudos
ble1
6 Indium

Re: I can't Login to NMC 7.5 SP1

Other info is that when I put an incorrect login I receive quickly a error messasge but when I put the correct login I dont receive any message

Same here.

0 Kudos
axavier1
2 Iron

Re: I can't Login to NMC 7.5 SP1

What is your JRE version?, I have got the same error with java 1.6, to NMC work I had downgrade to JRE 1.5

0 Kudos
ble1
6 Indium

Re: I can't Login to NMC 7.5 SP1

I'm using from workstation 1.5 (1.5.0_04-b05).  From different network, where I bypass some NAT and firewalls, I have 2 stepping stone servers; one with 1.5 and one with 1.6 and there it works.  Since we get an error in fw log on switch, and using same affected workstation to access NMC in another DC works we know in our case this is caused by network (just not sure why yet).

0 Kudos
chadney_greene
1 Copper

Re: I can't Login to NMC 7.5 SP1

<<For now it seems as NAT translation in the firewal is cauing this issue, but we are not 100% sure.>>

I am having a similar issue. My NMC user is behind a NATed firewall. The NMC see's the incoming connection as if it was from the firewall and the connection never finishes and the app hangs. Did you ever find a solution to your NAT problem?

0 Kudos