ALEX_SERYOGIN
3 Silver

backup with snapshot error

Jump to solution

Hi All!

This my error:

--- Unsuccessful Save Sets ---

Feb 03 12:53:10 networker: * srv01.intranet.s-k.kz C:\: Backup of failed

Feb 03 12:53:10 networker: * srv01.intranet.s-k.kz SYSTEM COMPONENTS:\: Backup of [SYSTEM COMPONENTS:\] failed

Feb 03 12:53:10 networker: ibpsvssclnt: Save Operations value is ignored on this OS platform.

Feb 03 12:53:10 networker: C:\ProgramData\EMC\NetWorker\LG_VSS_CLIENT3113317597.xml

Feb 03 12:53:10 networker: libpsvssclnt: C:\ProgramData\EMC\NetWorker\LG_VSS_CLIENT3113317597.xml level=full, 23 MB 00:01:36      1 file

Feb 03 12:53:10 networker: 7167:libpsvssclnt: libpsvssclnt completion time: 03.02.2012 12:50:03

Feb 03 12:53:10 networker: NMM .. Request the PS backup service backup the GUI presentation objects to the NetWorker saveset 'VSS:/'.

Feb 03 12:53:10 networker: NMM .. Delete the temporary snapshot as part of deport

Feb 03 12:53:10 networker: 48568:nsrsnap_vss_save:PS: (CPSImportService::DeportCopy) ERR: Error calling deportCopy, status=15:'Error deleting replica'

Feb 03 12:53:10 networker: 64041:nsrsnap_vss_save:NMM .. Error during deport of snapshot: PS .. Error starting snapshot deport: 'Error deleting replica'

Feb 03 12:53:10 networker: .

Feb 03 12:53:10 networker: 63372:nsrsnap_vss_save:NMM .. Registration of snapshot set failed -- PS .. Error starting snapshot deport: 'Error deleting replica'

Feb 03 12:53:10 networker: 

Feb 03 12:53:10 networker: NMM .. Delete the temporary snapshot as part of deport

Feb 03 12:53:10 networker: 48574:nsrsnap_vss_save:PS: (CPSImportService::GetOperationStatus) ERR: Error for operation 2

Feb 03 12:53:10 networker: 76960:nsrsnap_vss_save:NMM .. error caught calling RM to commit the replica.

Feb 03 12:53:10 networker: 83394:nsrsnap_vss_save:NMM .. cluster failover or application role change after a replica created may have caused snapshot creation failure, try to restart the backup.

Feb 03 12:53:10 networker: 63335:nsrsnap_vss_save:NMM backup failed to complete successfully.

Feb 03 12:53:10 networker: Internal error.

Feb 03 12:53:10 networker: 68151 1328251880 2 0 0 7028 3992 0 srv01.intranet.s-k.kz nsrsnap_vss_save 39 nsrsnap_vss_save: Exiting with failure. 0

Feb 03 12:53:10 networker: --- Successful Save Sets ---

0 Kudos
1 Solution

Accepted Solutions
CarlosRojas
4 Germanium

Re: backup with snapshot error

Jump to solution

Hi Alex,

I've seen this before, however I would need once again the nmm.raw rendered (looks like you didn't manage to render the logs in any of the previous threats).

My suggestion would be at first to follow these steps in the client:

1.- Stop NetWorker services, including Replication Manager Exchange interface and Replication manager AgentPS

2.- Delete /nsr/tmp folder

3.- Run vssadmin list shadows to display any old snapshot

4.- Use Diskshadow tool to delete old shadows

5.- Start NetWorker services

6.- Start Replication Manager Exchange Interface, and leave Replication Manager AgentPs stopped, as that service is Manual and will be started when required.

Then run a new backup and let us know the results.

What are you backing up by the way?

Thank you.

Carlos

View solution in original post

6 Replies
CarlosRojas
4 Germanium

Re: backup with snapshot error

Jump to solution

Hi Alex,

I've seen this before, however I would need once again the nmm.raw rendered (looks like you didn't manage to render the logs in any of the previous threats).

My suggestion would be at first to follow these steps in the client:

1.- Stop NetWorker services, including Replication Manager Exchange interface and Replication manager AgentPS

2.- Delete /nsr/tmp folder

3.- Run vssadmin list shadows to display any old snapshot

4.- Use Diskshadow tool to delete old shadows

5.- Start NetWorker services

6.- Start Replication Manager Exchange Interface, and leave Replication Manager AgentPs stopped, as that service is Manual and will be started when required.

Then run a new backup and let us know the results.

What are you backing up by the way?

Thank you.

Carlos

View solution in original post

jbmcgowan2
2 Iron

Re: backup with snapshot error

Jump to solution

I had a similar error and thought I would add this in case.

nsrsnap_vss_save:NMM .. Error during import of snapshot: PS ..


and similar to


Error calling importCopy, status=%d:'%s' 3 0 35. PS: (CPSImportService::ImportCopy) 1 2 15 24 107 Error obtaining volume name (s)


My Win2k8 R2 Server running Exchange 2010 SP1 RU6 had NMM 3.0 on it but also had another application Inmage which had its own VSS Provider.


If you ran from the command line vssadmin list providers the output would show the Inmage Software Provider and Microsoft VSS Software Provider.


What we found was the Networker Group/Client was setup correctly, requesting the snapshots from the client ( inmage would respond/interfere ) and then when Networker looked for them in Microsoft VSS error 15 came up during import.


Disabled all inmage services, rebooted, ran vssadmin list providers again and inmage still showed up but that was ok, ran diskshadow delete shadows all, then restart the replication manager services as described above, I didn't need to rename tmp. Now backups running normally. Hope this helps someone avoid a 3 day support call. Cheers.

0 Kudos
CarlosRojas
4 Germanium

Re: backup with snapshot error

Jump to solution

Hi Joshua,

In that case you can try using

NSR_VSS_FORCE_SYSTEM _PROVIDER=yes

This will instruct NMM to use Software Provider (Microsoft VSS) instead of any other HW provider.

Thank you,

Carlos

0 Kudos
tkrajeesh
2 Bronze

Re: backup with snapshot error

Jump to solution

Hi, I am facing a problem, my SQL cluster backup failing.  Log saying "cannot run nsrsqlsv:  No such file or directory"

and when i am modifying cluster backup client, i am not able to browse Databases, i can see only folder selection option it is like file back.

How do i solve this issue?

Please help

Regards

Rajeesh

 

0 Kudos
crazyrov
4 Beryllium

Re: backup with snapshot error

Jump to solution

@tkrajeesh, from the error it looks like you don't have a NMM agent installed on that SQL server yet.

HTH,
For NetWorker related content - https://www.youtube.com/channel/UC4JLsVyXMyjbQ4i1NaJj5IQ

0 Kudos
tkrajeesh
2 Bronze

Re: backup with snapshot error

Jump to solution

Hi,

NMM and Networker installed and it was working fine.  there was one incident that happened data center UPS replacement, during the time we shut down all servers. after that, the problem started.   now i am reinstalling NW and NMM. I will update you with the result.

Please help if it was not resolved.

Thanks 

Rajeesh

0 Kudos