evobe_taxi
1 Copper

Changing subnet errors

OK, I've been tasked with decreasing the size of my subnet on our management VLAN. Whenever I try to go from .240 to .248 I get..

Error! Subnet conflict between specified IP Address and current configuration. All routing interfaces, service ports and network ports must be configured on different subnets. 

Not sure why this is happening, I'm the junior here so I admit I'm a little lost. 

Here's my running config:

sntp unicast client enable
sntp server 10.101.2.246
clock summer-time recurring USA
clock timezone -5 minutes 0 zone "EST"
stack
member 1 2
member 2 2
exit
ip address 10.101.19.10 255.255.255.0
ip address vlan 7
ip domain-name blserviceinc.com
ip name-server 10.101.2.245
ip name-server 10.101.2.246
ip routing
ip route 0.0.0.0 0.0.0.0 10.101.1.1
ip route 10.105.0.0 255.255.0.0 10.101.1.13
ip route 172.24.0.0 255.255.240.0 10.101.1.5
ip route 10.102.0.0 255.255.0.0 10.101.1.13
ip helper-address 10.101.2.246 domain
interface vlan 1
routing
ip address 10.101.2.1 255.255.240.0
exit
interface vlan 2
name "VMotion"
exit
interface vlan 3
name "ATTInternet"
exit
interface vlan 4
name "Comcast Internet"
exit
interface vlan 6
name "Phone-Net"
exit
interface vlan 7
name "Management"

the only change is that Vmotion no longer exists and management vlan is now 10.101.19.1 with a /24 mask. 

Any help would be appreciated. 

Thanks

Tags (3)
0 Kudos
6 Replies
Moderator
Moderator

RE: Changing subnet errors

Hi,

A .240(/28) has 16 hosts per subnet a .248(/29) subnet only has 6 hosts. A /24 is a subnet of 255.255.255.0 with 254 hosts

ip address 10.101.19.10 255.255.255.0
ip address vlan 7

 

change to this

ip address 10.101.19.1 255.255.255.248
ip address vlan 7

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
evobe_taxi
1 Copper

RE: Changing subnet errors

Would that then fix the error I'm getting when I attempt to change vlan 1 to 255.255.248.0?

So, to be clear, vlan 7 is our management vlan, and that's currently vlan 7 with an ip of 10.101.19.1 with a mask of 255.255.255.0.

The vlan I'm interested in changing in vlan 1 which is 10.101.2.1 with a mask of 255.255.240.0. I'd like to change that to 255.255.248.0

Thanks for the reply. 

0 Kudos
Moderator
Moderator

RE: Changing subnet errors

Oh ok, no, that would change VLAN 7. For VLAN 1 how are you changing it? Are you removing the existing IP with no ip address and then putting the new one on?

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
evobe_taxi
1 Copper

RE: Changing subnet errors

VLAN 1 already has an IP address:

interface vlan 1

routing

ip address 10.101.2.1 255.255.240.0

exit

I just want to change the subnet mask to 248 but whenever I attempt to do it I get;

Error! Subnet conflict between specified IP Address and current configuration. All routing interfaces, service ports and network ports must be configured on different subnets.

Which I don't get because I don't have another subnet with that mask, nor do I have any IP addresses in that range.

Much appreiciated.

0 Kudos
Moderator
Moderator

RE: Changing subnet errors

.240 includes .248 so it sees the conflict there, you have to remove the existing IP first.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
evobe_taxi
1 Copper

RE: Changing subnet errors

Ok so to be clear, I'd have to remove the subnet 255.255.240.0 subnet mask completely, save it, then add 255.255.248.0?

Edit: I'm doing these changes in dell openmanage btw, so I'm not sure it'll let me clear out my subnet mask completely. 

0 Kudos