Highlighted
kakalonso
Bronze

DHCP on S3124F

Jump to solution

Hi all,

I have a S3124F switch. I create 3 vlans and 3 DHCP pools. Those are:
- Interface Vlan 10 - IP Address 10.0.10.1, DHCP pools: 10.0.10.0/24

- Interface Vlan 12 - IP Address 10.0.12.1, DHCP pools: 10.0.12.0/23

- Interface Vlan 14 - IP Address 10.0.14.1, DHCP pools: 10.0.14.0/23

 

I assign port gi1/23 to vlan 12 via command 
interface vlan 12

untagged giga 1/23

I plugged a computer in port 1/23, if i set the static IP 10.0.12.2/23 it can ping 10.0.12.1.

But if i set it obtain IP from DHCP, it cannot get the IP Address. 
I show dhcp statistic on the switch and see no DHCP packets.

Please help me to fix it. Thank you all.

0 Kudos
11 Replies
murmanov
Silver

Re: DHCP on S3124F

Jump to solution

Post DHCP config from your switch

Moderator
Moderator

Re: DHCP on S3124F

Jump to solution

The config guide goes through the commands to implement DHCP on the switch. May be worth looking and comparing to your config.

Page 242: http://dell.to/2jOfAOQ

Feel free to post the running config up, we can help look through it.

Checking the logs may be another area to check. # show logging

 

 

 

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
kakalonso
Bronze

Re: DHCP on S3124F

Jump to solution

Sorry for the late reply. Here is my configuration. I just changed the subnet. The problem is still there. Please help me take a look on it. Thank you.
P/s: Port 23 is an access port, untagged vlan 11.  And pc plugged in this port cannot get ip address from dhcp pool.

 

DellSW-Core#show running-config
Current Configuration ...
! Version 9.10(0.0P1)
! Last configuration change at Wed Feb  7 20:51:55 2018 by default
! Startup-config last updated at Wed Feb  7 20:42:50 2018 by default
!
boot system stack-unit 1 primary system://A
boot system stack-unit 1 secondary system://B
!
hostname DellSW-Core
!
protocol lldp
!
redundancy auto-synchronize full
!
stack-unit 1 provision S3124F
!
interface GigabitEthernet 1/1
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/2
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/3
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/4
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/5
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/6
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/7
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/8
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/9
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/10
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/11
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/12
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/13
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/14
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/15
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/16
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/17
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/18
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/19
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/20
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface GigabitEthernet 1/21
 no ip address
 switchport
 no shutdown
!
interface GigabitEthernet 1/22
 no ip address
 switchport
 no shutdown
!
interface GigabitEthernet 1/23
 no ip address
 switchport
 no shutdown
!
interface GigabitEthernet 1/24
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface TenGigabitEthernet 1/25
 no ip address
 shutdown
!
interface TenGigabitEthernet 1/26
 no ip address
 shutdown
!
interface TenGigabitEthernet 1/27
 no ip address
 shutdown
!
interface TenGigabitEthernet 1/28
 no ip address
 shutdown
!
interface ManagementEthernet 1/1
 no ip address
 no shutdown
!
interface ManagementEthernet 2/1
 no shutdown
!
interface ManagementEthernet 3/1
 no shutdown
!
interface ManagementEthernet 4/1
 no shutdown
!
interface ManagementEthernet 5/1
 no shutdown
!
interface ManagementEthernet 6/1
 no shutdown
!
interface ManagementEthernet 7/1
 no shutdown
!
interface ManagementEthernet 8/1
 shutdown
!
interface ManagementEthernet 9/1
 shutdown
!
interface ManagementEthernet 10/1
 shutdown
!
interface ManagementEthernet 11/1
 shutdown
!
interface ManagementEthernet 12/1
 shutdown
!
interface Vlan 1
!untagged GigabitEthernet 1/1-1/20,1/24
 no shutdown
!
interface Vlan 2
 description Management
 name Management
 ip address 10.0.2.1/24
 tagged GigabitEthernet 1/1-1/22,1/24
 no shutdown
!
interface Vlan 10
 description WifiManagement
 name WifiManagement
 ip address 10.0.10.1/24
 tagged GigabitEthernet 1/1-1/22,1/24
 no shutdown
!
interface Vlan 11
 description Wifi-Staff
 name Wifi-Staff
 ip address 10.0.11.1/24
 tagged GigabitEthernet 1/1-1/22,1/24
untagged GigabitEthernet 1/23 no shutdown ! interface Vlan 12 description Wifi-Guest name Wifi-Guest ip address 10.0.12.1/23 tagged GigabitEthernet 1/1-1/22,1/24 no shutdown ! interface Vlan 20 description Staff name Staff ip address 10.0.20.1/22 tagged GigabitEthernet 1/1-1/22 no shutdown ! interface Vlan 30 description Server name Server ip address 10.0.30.1/24 tagged GigabitEthernet 1/1-1/22 no shutdown ! line console 0 line vty 0 line vty 1 line vty 2 line vty 3 line vty 4 line vty 5 line vty 6 line vty 7 line vty 8 line vty 9 ! ip dhcp server ! pool WifiGuest network 10.0.12.0/23 default-router 10.0.12.1 dns-server 8.8.8.8 8.8.4.4 lease 3 0 0 ! pool WifiStaff network 10.0.11.0/24 default-router 10.0.11.1 dns-server 8.8.8.8 8.8.4.4 lease 3 0 0 ! reload-type boot-type normal-reload config-scr-download enable ! end DellSW-Core#

 

0 Kudos
Moderator
Moderator

Re: DHCP on S3124F

Jump to solution

Everything in the configuration looks okay to me. Were there any DHCP messages recorded in the logs? Do the other pools function for the other VLANs?

 

There is a DHCP debug command that you can use to try and gather further information.

debug ip dhcp server

 

Another step you can take, would be to do a packet capture on interface 23. This would give you better insight into what DHCP packets are being sent/received by the client.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
kakalonso
Bronze

Re: DHCP on S3124F

Jump to solution

Showing dhcp statistic, i don't see any dhcp packet. So i'm wondering if there is any access list or some thing like that prevent dhcp packet.

0 Kudos
Moderator
Moderator

Re: DHCP on S3124F

Jump to solution

There is no inherent ACL on the switch. Do you have ACLs configured on the switch?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
kakalonso
Bronze

Re: DHCP on S3124F

Jump to solution

No, i don't. Does the switch block broadcast packet by default? Tomorrow when i'll send you the service tag. Thank for your help.

0 Kudos
Moderator
Moderator

Re: DHCP on S3124F

Jump to solution

Thanks so much for the reply to my private message. Really glad to hear that you were able to tweak the DNS server config and get this working.

Cheers!

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
kakalonso
Bronze

Re: DHCP on S3124F

Jump to solution

Do you reply wrong thread? I hasn't replied your message yet.
My switch still not working. Here is the show ip dhcp server statistic result:

DellSW-Core#show ip dhcp server statistics
Address pools           2
Database agents         0
Automatic bindings      0
Manual bindings         0
Expired bindings        0
Malformed messages      0

Message                 Received
BOOTREQUEST             0
DHCPDISCOVER            0
DHCPREQUEST             0
DHCPDECLINE             0
DHCPRELEASE             0
DHCPINFORM              0

Message                 Sent
BOOTREPLY               0
DHCPOFFER               0
DHCPACK                 0
DHCPNAK                 0
DellSW-Core#
0 Kudos