edmat
1 Nickel

Dell Force 10 and Cisco Nexus

Hi

Please assist me to find the problem, I have connected a Dell Force 10 switch to a Cisco Nexus 5000, the Nexus is running MSTP and the Dell switch is running basic spanning tree, the problem is when they are interconnected, the ports are blocked, not sure if it is a problem of Spanning tree.

I was reading this article 

https://hasanmansur.com/2012/10/15/cisco-and-force10-stp-spanning-tree-interoperability/

Between the devices we have a port channel.

Thank you so much

0 Kudos
10 Replies
Moderator
Moderator

RE: Dell Force 10 and Cisco Nexus

Is this the only connection the force 10 switch has to the network? Spanning tree should only block a port if spanning tree detects a loop. Do you have a topology you can share with us? We can help look for that loop

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
edmat
1 Nickel

RE: Dell Force 10 and Cisco Nexus

Thank you so much Daniel for your reply, attached you will find a picture related to the diagram.

0 Kudos
edmat
1 Nickel

RE: Dell Force 10 and Cisco Nexus

Thank you so much Daniel for your reply.

Attached you will find a picture of the topology.

0 Kudos
Moderator
Moderator

RE: Dell Force 10 and Cisco Nexus

Are the interfaces circled in red currently in a LAG? when the interfaces transitioned into a blocking states, was it the individual interfaces or the port channel? Can you post up the config for the interfaces circled in green? Does the Cisco have any other connections to the network? Or is it's only connection to the F10 switches?

Thanks

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
edmat
1 Nickel

RE: Dell Force 10 and Cisco Nexus

Hi Daniel,

Thank you so much again for the follow up, Currently I have not the configuration but it is port channel:

Port in hybrid mode

switchport

vlt-peer-lag port-channel

and big MTU 9xxx

The Cisco is just connected to Force 10.

0 Kudos
Moderator
Moderator

RE: Dell Force 10 and Cisco Nexus

If this is the only connection, then it must be treating this connection as not a port channel. I would double check both the cisco and Nexus to ensure that the port channel is configured correctly. Check the logs to see if spanning tree is reporting the transition on the individual interface, or the port channel. Check to be sure that the VLT/VPC peer to peer connection has spanning tree disabled on it.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
edmat
1 Nickel

RE: Dell Force 10 and Cisco Nexus

Thank you so much Daniel

0 Kudos
edmat
1 Nickel

RE: Dell Force 10 and Cisco Nexus

Hi Daniel, just a question, how the STP can be disabled on the interfaces?

0 Kudos
Moderator
Moderator

RE: Dell Force 10 and Cisco Nexus

Disabling spanning tree is not recommended. I am not seeing a method of disabling per interface, just globally.

http://dell.to/2r0TLlF

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos