Aditia Saputra
1 Copper

Dell N2048p can't separate IP voice & Data on same port

Hi all

Im new on dell switch and i need some advice about configuring voice vlan. I have 7 N2048p Switches and connecting IP Phone and PC on same port, for configuration of vlan is

Data VLAN is 101 with IP range 10.206.101.1-254 /24

Voice VLAN is 100 with IP range 10.206.100.1-254 /24

after update firmware dell switch to 6.5.3.3 most of IP Phone device using IP Data VLAN and not use IP voice VLAN. here is the capture

1.PNG

 

 

 

 

 

 

 

 

 

 

 

 

For Configuration of switch:

 

ACSW_B01#show running-config

!Current Configuration:
!Software Capability "Stack Limit = 12, VLAN Limit = 4093"
!Image File "N2000Stdv6.5.3.3"
!System Description "Dell EMC Networking N2048P, 6.5.3.3, Linux 3.6.5-e3cd5a07, Not Available"
!System Software Version 6.5.3.3
!
configure
vlan 5,10,98-102
exit
vlan 5
name "MGMT"
exit
vlan 10
name "Wifi_AS5NET"
exit
vlan 98
name "LAN_WING_A"
exit
vlan 99
name "LAN_WING_B"
exit
vlan 100
name "IPPhone"
exit
vlan 101
name "User_GnG"
exit
vlan 102
name "WIFI_As_5"
exit
hostname "ACSW_B01"
slot 1/0 4 ! Dell EMC Networking N2048P
sntp unicast client enable
sntp server 10.12.7.37
clock timezone 8 minutes 0 zone "WITA"
stack
member 1 4 ! N2048P
exit
ip http timeout-policy idle 3600 life 86400
interface vlan 1
exit
interface vlan 5
ip address 10.206.103.7 255.255.255.128
exit
ip default-gateway 10.206.103.1
username "myadmin" password 7ab7290b5df31798a1be77bab26788e9c privilege 15 encrypted
username "admin" password 695afd22e8220f34edb7ca20ce6c5802 privilege 15 encrypted
switchport voice vlan
line telnet
exec-timeout 5
exit
line ssh
exec-timeout 5
exit
ip ssh server
spanning-tree mode pvst
!
interface Gi1/0/1
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/2
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/3
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/4
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/5
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/6
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/7
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/8
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/9
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/10
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/11
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/12
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/13
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/14
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/15
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/16
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/17
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/18
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/19
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/20
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/21
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/22
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/23
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/24
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/25
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/26
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/27
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/28
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/29
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/30
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/31
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/32
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/33
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/34
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/35
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/36
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/37
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/38
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/39
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/40
description "User_GnG."
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/41
description "PC_NOC_Daskboard_Security"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/42
description "User_WingB"
spanning-tree portfast
switchport access vlan 99
switchport voice vlan 100
exit
!
interface Gi1/0/43
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/44
description "User_WingB"
spanning-tree portfast
switchport access vlan 99
switchport voice vlan 100
exit
!
interface Gi1/0/45
description "User_GnG"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100
exit
!
interface Gi1/0/46
shutdown
description "Spare"
switchport mode trunk
switchport trunk allowed vlan 5,98-102
exit
!
interface Gi1/0/47
shutdown
description "Spare"
switchport mode trunk
switchport trunk allowed vlan 5,98-102
exit
!
interface Gi1/0/48
shutdown
description "Spare"
switchport mode trunk
switchport trunk allowed vlan 5,98-102
exit
!
interface Te1/0/1
description "to_CSW01"
switchport mode trunk
exit
!
interface Te1/0/2
description "to_CSW02"
switchport mode trunk
exit
!
interface port-channel 1
description "to_B02"
switchport mode trunk
switchport trunk allowed vlan 5,98-102
exit
!
interface port-channel 2
description "to_B03"
switchport mode trunk
switchport trunk allowed vlan 5,98-102
exit
!
interface port-channel 3
description "to_B04"
switchport mode trunk
switchport trunk allowed vlan 5,98-102
exit
snmp-server engineid local 800002a203e4f004334dd2
snmp-server community "AS_5_RO" ro
snmp-server enable traps captive-portal
snmp-server enable traps captive-portal client-auth-failure
snmp-server enable traps captive-portal client-connect
snmp-server enable traps captive-portal client-db-full
snmp-server enable traps captive-portal client-disconnect
sntp source-interface vlan 5
eula-consent support-assist reject
eula-consent hiveagent reject
exit

 

there are missconfiguration on switch with config above?

 

Thank You

 

 

 

 

 

 

 

Labels (1)
Tags (1)
0 Kudos
4 Replies
Moderator
Moderator

Re: Dell N2048p can't separate IP voice & Data on same p

Hi,

Try setting the port mode to general, the PVID to the untagged vlan 101 and the tagged vlan to 100. Page 756 https://downloads.dell.com/manuals/all-products/esuprt_ser_stor_net/esuprt_networking/esuprt_net_fxd...

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
Aditia Saputra
1 Copper

Re: Dell N2048p can't separate IP voice & Data on same p

Hi Josh

Thanks for the reply

after change to general mode, testing in 1 port in Switch, IP Phone and PC can't get IP from DHCP Server. the changed command :

description "User_Wing_A"
spanning-tree portfast
switchport mode general
switchport general pvid 101
switchport general allowed vlan add 100 tagged

 

if i revert back configuration, PC and IP Phone get IP from DHCP but using same Subnet and VLAN

description "User_Wing_A"
spanning-tree portfast
switchport access vlan 101
switchport voice vlan 100

 

and if configuration only voice VLAN IP phone didn't get any IP, but voice vlan is enabled

description "User_Wing_A"
spanning-tree portfast
switchport voice vlan 100

1.PNG

 

Thank You

Aditia Dwi Saputra

 

 

0 Kudos
teampouce1
1 Copper

Re: Dell N2048p can't separate IP voice & Data on same p

HI All,

Did you solve your issue ?

I'm trying to implement 2 Dell N2048p on the same as your but I'm facing the issue with DHCP lease.

If you can shar your config or help in any other way it will be appreciate.

Thanks

Best Regards

0 Kudos
Aditia Saputra
1 Copper

Re: Dell N2048p can't separate IP voice & Data on same p

Hi sorry for late response

until now i cant determine cause of problem, but if i turn off voice vlan on problem port, the issue in solve, but IP Phone and PC using same VLAN (in my case all using VLAN98). I tried to call dell tech support and he give me a few changes:

 

disable tlv-select port VLAN --> no lldp tlv-select port-vlan
Disable green mode             --> no green-mode eee
reset PoE Power                  --> power inline reset

some IP Phone has successfully using these command but some IP Phone can't, I tried update firmware to 6.5.4.4 but didn't resolve the case

if im looking log on Cisco IP Phone, log say "DHCP timeout", i wonder why problem just on few IP Phone but another IP Phone works normally

Also another device using voice VLAN (Polycom trio+8000) cannot get network, but if im using data VLAN, these device works normally.

0 Kudos