ScootMcGoot
1 Copper

Dell S4128F-ON Inter VLAN routing

I am hoping somebody here can help me out.  I have been trying to get this working for about 16 hours now and I have no idea whats wrong.  I have setup inter VLAN routing before on Cisco switches and I have never had trouble getting it to work.  If I connect to the switch with the serial cable I can ping all of my VLAN interfaces from the switch as well as all of the hosts that are deployed within each of the VLANs.  When I set one of the ports on the switch to an access port, plug myself into it, and assign myself an IP from that subnet I am able to ping the gateway for that VLAN as well as all of the hosts in the same VLAN.  The problem is I am not able to ping the gateway for any of the other VLAN interfaces and I am also not able to ping any of the hosts that are deployed within those other VLANs.  I have ready just about every post I can find about setting up VLAN routing and have tried many different configs but nothing works.  Please help!

Switch Config

OS10# show running-configuration
! Version 10.4.0E(R3)
! Last configuration change at May 13 06:44:42 2019
!
snmp-server contact http://www.dell.com/support
interface breakout 1/1/25 map 100g-1x
interface breakout 1/1/26 map 100g-1x
username admin password **** role sysadmin
aaa authentication local
ip route 0.0.0.0/0 192.168.2.1
iscsi target port 860
iscsi target port 3260
!
interface vlan1
no shutdown
ip address 192.168.2.3/24
!
interface vlan10
no shutdown
ip address 192.168.10.1/23
!

interface vlan12
no shutdown
ip address 192.168.12.1/23
!
interface vlan14
no shutdown
ip address 192.168.14.1/23
!
interface vlan16
no shutdown
ip address 192.168.16.1/23
!
interface ethernet1/1/1
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 12,16
!
interface ethernet1/1/2
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 12,16
!
interface ethernet1/1/3
description "Link to X1052P-03"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 12,16
!
interface ethernet1/1/4
no shutdown
switchport access vlan 16
!
interface ethernet1/1/5
no shutdown
switchport access vlan 16
!
interface ethernet1/1/6
no shutdown
switchport access vlan 16
!
interface ethernet1/1/7
no shutdown
switchport access vlan 1
!

interface ethernet1/1/8
no shutdown
switchport access vlan 1
!
interface ethernet1/1/9
no shutdown
switchport access vlan 1
!
interface ethernet1/1/10
no shutdown
switchport access vlan 1
!
interface ethernet1/1/11
no shutdown
switchport access vlan 1
!
interface ethernet1/1/12
no shutdown
switchport access vlan 1
!
interface ethernet1/1/13
no shutdown
switchport access vlan 1
!
interface ethernet1/1/14
no shutdown
switchport access vlan 1
!
interface ethernet1/1/15
no shutdown
switchport access vlan 1
!
interface ethernet1/1/16
no shutdown
switchport access vlan 1
!
interface ethernet1/1/17
no shutdown
switchport access vlan 1
!
interface ethernet1/1/18
no shutdown
switchport access vlan 1
!
interface ethernet1/1/19
no shutdown
switchport access vlan 1
!

interface ethernet1/1/20
no shutdown
switchport access vlan 1
!
interface ethernet1/1/21
no shutdown
switchport access vlan 1
!
interface ethernet1/1/22
no shutdown
switchport access vlan 1
!
interface ethernet1/1/23
no shutdown
switchport access vlan 12
!
interface ethernet1/1/24
description "Uplink to ASA"
no shutdown
switchport access vlan 1
!
interface ethernet1/1/25
no shutdown
switchport access vlan 1
!
interface ethernet1/1/26
no shutdown
switchport access vlan 1
!
interface ethernet1/1/27
description "Link to X1052-01"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10,12,14,16
!
interface ethernet1/1/28
description "Link to X1052P-01"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10,12,14,16
!
interface ethernet1/1/29
description "Link to X1052P-02"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10,12,14,16
!
interface ethernet1/1/30
description "Link to X1052P-03"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10,12,14,16
!
interface mgmt1/1/1
no shutdown
ipv6 address autoconfig
!

support-assist
!
policy-map type application policy-iscsi
!
class-map type application class-iscsi
!
class-map type qos class-trust

 

Routes

OS10# show ip route all
Codes: C - connected
S - static
B - BGP, IN - internal BGP, EX - external BGP
O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
E2 - OSPF external type 2, * - candidate default,
+ - summary route, > - non-active route
Gateway of last resort is not set
Destination Gateway Dist/Metric Last Change
----------------------------------------------------------------------------------------------------
*S 0.0.0.0/0 via 192.168.2.1 vlan1 1/0 00:24:37
C 192.168.2.0/24 via 192.168.2.3 vlan1 0/0 10:11:51
C 192.168.10.0/23 via 192.168.10.1 vlan10 0/0 09:05:09
C 192.168.12.0/23 via 192.168.12.1 vlan12 0/0 2 days 01:12:03
C 192.168.14.0/23 via 192.168.14.1 vlan14 0/0 09:05:09
C 192.168.16.0/23 via 192.168.16.1 vlan16 0/0 2 days 01:12:03

 

Labels (1)
0 Kudos
2 Replies
Moderator
Moderator

Re: Dell S4128F-ON Inter VLAN routing

Hi,

On the ports that are trunks you don’t need switchport access vlan 1.

Did you do a no shutdown on the VLAN interfaces? Which version of the OS are you using?

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
ScootMcGoot
1 Copper

Re: Dell S4128F-ON Inter VLAN routing

Hi Josh,

Thanks for your reply.  I ended up getting this issue sorted out.  The reason for it not working had nothing to do with the configuration on the switch.  In fact the configuration I posted worked perfectly fine.  The issue was while working on this switch I was also connected to a wifi access point on a different network.  The 2 default gateways is what was screwing me up.  I could not get to other VLANs because my laptop was using the default gateway of my wireless connection instead of the wired connection into the switch.

Thanks,

Scott

0 Kudos