Start a Conversation

Unsolved

This post is more than 5 years old

186757

June 29th, 2015 05:00

N2000 Mac Authentication Bypass and 802.1x

We are trying to configure our N2000's to do 802.1x certificate based authentication, but want the ability to provide MAC based authentication as well.  Our current config is as follows:

!Current Configuration:
!System Description "Dell Networking N2048P, 6.2.1.6, Linux 3.6.5-a5c6fee7"
!System Software Version 6.2.1.6
!
configure
vlan 1000,1100,1200-1202,1724
exit
ip telnet server disable
hostname "QD_CORE_8021x"
slot 1/0 9    ! Dell Networking N2048P
sntp unicast client enable
sntp server 129.6.15.28
sntp server 129.6.15.29
clock timezone -5 minutes 0
stack
member 1 9    ! N2048P
exit
logging 10.10.10.46
level notifications
exit
ip http secure-session hard-timeout 24
ip http secure-session soft-timeout 5
interface vlan 1201 2
ip address 10.20.201.4 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 10.20.201.1
username " " password privilege 15 encrypted
aaa authentication login "defaultList" local
aaa authentication login "radiuslogin" radius local
aaa authentication enable "radiusenable" radius enable
ip http authentication radius local
ip https authentication radius local
aaa authorization exec "dfltExecAuthList" radius
authentication enable
dot1x system-auth-control
aaa authentication dot1x default radius
aaa authorization network default radius
dot1x dynamic-vlan enable
voice vlan
radius-server key " "
radius-server host auth 10.10.10.56
primary
name "JRNPS01"
exit
!
interface Gi1/0/1
description "Normal 802.1x - No MAC"
dot1x reauthentication
dot1x timeout guest-vlan-period 10
dot1x max-req 10
dot1x guest-vlan 1724
dot1x unauth-vlan 1724
authentication order dot1x
authentication priority dot1x
exit
!
interface Gi1/0/2
description "Normal non-802.1x Access"
switchport access vlan 1100
dot1x port-control force-authorized
exit
!
interface Gi1/0/3
description "MAB Test"
dot1x port-control mac-based
dot1x reauthentication
dot1x timeout guest-vlan-period 5
dot1x unauth-vlan 1100
dot1x mac-auth-bypass
authentication order dot1x mab
authentication priority dot1x mab
exit

 

When plugging in a computer to Gi1/0/3 it authenticates with Microsoft NPS and I can see the Access-Accept sending the correct attributes, yet the authentication never gets back to the computer authenticating.  The computer sees it as authentication failed, and never gets an IP address at all (not even seeing the unauth VLAN).  The same computer plugged into Gi1/0/1 authenticates just fine and receives what I would expect it to receive. 


Does anyone have any guides or thoughts as to why this could be happening? 

 

Second question, related is how do I get MAB working properly?  Are there any guides from Dell on this? 

5 Practitioner

 • 

274.2K Posts

June 29th, 2015 11:00

The only think I can initially see is that port 3 has no switchport mode. The user guide says it suggest to use switchport mode general. The other settings on the port look alright to me.

While setting up and troubleshooting this kind of config, you can set the switch to monitor mode. If authentication does not work the switch will log some additional information as to why, but wont deny traffic flow. Page 270 of the user guide.

http://dell.to/1H4xyD5

Here are some further show commands that might lend some additional information.

console#show dot1x clients all

console#show dot1x

console#show dot1x interface Gi1/0/3

Hope this helps find the solution.

11 Posts

June 29th, 2015 12:00

Are there any guides for the NPS side?  After changing to switchport mode general, my existing 802.1x working computers are working now, and my MAC test devices are now giving IAS_INVALID_AUTH_TYPE

Is there any documentation on the way the N2000 acts when it is being an 802.1x supplicant instead?

5 Practitioner

 • 

274.2K Posts

June 29th, 2015 13:00

Here are the up to date guides for the N-series switches.

http://dell.to/13T8tL4

I don't see one for this specific scenario. On your authentication server do you have the MAC addresses added and associated with credentials? Here is an example using server 2008.

http://bit.ly/1QZV6js

11 Posts

June 29th, 2015 14:00

Yes, we have the MAC added, and I've gone ahead and set the password per the latest CLI documentation.  It still is returning an IAS_INVALID_AUTH_TYPE when attempting to connect.  It would be nice if there were some configuration guides for common RADIUS solutions such as Microsoft NPS.   I'll have to repeat this for a 55XX switch as well later on.  

11 Posts

June 30th, 2015 05:00

So at this point I have to tombstone this part of the project because Dell can't keep with standards throughout the industry.  The N series sends the MAC as uppercase (and the password), while the 55XX line sends the MAC and password as lowercase (which is standard with most other vendors).  Since we were forced into running both product lines and I don't have the financial resources to update all my switches, this means we can't use the MAC for authentication on these other devices.  

11 Posts

June 30th, 2015 11:00

For those who come here looking for closure, the Dell switches use MD5-Challege for their authentication protocol with NPS.  Unfortunately this isn't enabled on newer versions of NPS.  You need to add it via the following Microsoft article:

https://support.microsoft.com/en-us/kb/922574/en-us

Once that is done, you can now use NPS for MAC authentication on your ports.  

The N-Series sends MAC addresses as username and password in all CAPS

The 55xx Powerconnect series sends MAC addresses as username and password in all lowercase

For a 55xx, the following is the code I have:

dot1x system-auth-control

aaa authentication dot1x default radius

 

interface vlan 1724

dot1x guest-vlan

interface gigabitethernet1/0/1

dot1x host-mode multi-sessions

dot1x guest-vlan enable

dot1x max-req 3

dot1x reauthentication

dot1x mac-authentication mac-and-802.1x

dot1x radius-attributes vlan

dot1x port-control auto

switchport access vlan none

For a N-series, we used the following:

dot1x port-control force-authorized

dot1x system-auth-control

aaa authentication dot1x default radius

dot1x dynamic-vlan enable

authentication enable

interface Gi1/0/3

description "MAB Test"

switchport mode general

dot1x port-control mac-based

dot1x reauthentication

dot1x timeout guest-vlan-period 5

dot1x max-req 3

dot1x unauth-vlan 1724

dot1x mac-auth-bypass

authentication order dot1x mab

authentication priority dot1x mab

exit

11 Posts

June 30th, 2015 13:00

Is there any way to change the username/password sent by either an N2000 or Powerconnect 55xx when authenticating to a RADIUS server for MAC Authentication Bypass?  Currently the N2000 sends the username and password as the uppercase version of the MAC Address, which is the opposite of pretty much every other standard, including the implementation on the Powerconnect 55xx. Since we have a mixed environment with both switches, it greatly impacts the ability to allow devices to "roam freely"

5 Practitioner

 • 

274.2K Posts

July 1st, 2015 06:00

Wanted to let you know I am actively researching this. I will post back up once I have any additional information/action plan.

Thanks

5 Practitioner

 • 

274.2K Posts

July 1st, 2015 11:00

I have confirmed there is not a way to change how the credentials are handled by the switch. Something you could try doing, is see if you can add 2 credential entries for each roaming user's MAC address. one in lowercase and one in upper case.

11 Posts

July 1st, 2015 11:00

Would it be possible to get this submitted as a bug request, as this is not how the rest of the industry does this.  

5 Practitioner

 • 

274.2K Posts

July 1st, 2015 12:00

I apologize but this is not a bug in the networking OS, it is operating as intended. I am not sure why it was implemented in this manner, but it is not something we can change. If you call in on the phones you might be able to put in a feature request. I believe the feature request actually goes through the sales department, but the phone group will be able to explain the procedure in more detail. 1 (800) 999-3355

11 Posts

July 8th, 2015 12:00

That would be great if it is in there.  

Are they fixing the other RADIUS auth bugs as well?

5 Practitioner

 • 

274.2K Posts

July 8th, 2015 12:00

Ordovice, I wanted to chime back in. I did some further research on this. From what I can gather there should hopefully be an implementation in firmware 6.2.6 that may resolve this. I do not know when this firmware will be released. But just wanted to let you know the fix should be in the works.

5 Practitioner

 • 

274.2K Posts

July 8th, 2015 13:00

That is all the information I have access to at this time.

11 Posts

July 27th, 2015 11:00

Daniel,

Just wanted to check and see if anyone had maybe put a bug in your ear about when the firmware was going to come out.  Additionally, is there any way to become a beta tester for this?

No Events found!

Top