Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

237341

January 6th, 2012 13:00

Powerconnect 6248 adding new vlan with dhcp relay

Hi all, I have a Dell 6248 switch in layer 2 mode and I try to add a new vlan and have it relay dhcp to my server. That switch is connected with a trunk port to my master switch that does the layer 3 routing. I already have other vlan that work ok via the trunk port so i can set port on any switch to a vlan and they talk ok. the problem is when I add a new vlan they don't talk so I might have missed something obvious as this vlan thing is still pretty new to me.

I created the vlan on the master switch and it can talk to other vlan device located on the master switch but it cannot talk to anything on the dell switch so I'm guessing there is a problem on my vlan creation on the dell swtch so if anyone would provide me a step by step guide to creating a new vlan (ID 145), adding that vlan to the trunk port (1g/45) and enabling DHCP relay with address 10.1.10.10 that might help me figure out the problem I have.

Thanks !

Here is my running config if it may help.

Dell6248#
show running-config

!Current Configuration:
!System Description "PowerConnect 6248, 3.3.1.10, VxWorks 6.5"
!System Software Version 3.3.1.10
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20,30,40,50,70,145,180
vlan routing 30 1
vlan routing 50 2
vlan routing 180 3
vlan routing 10 4
vlan routing 70 5
vlan routing 40 6
vlan routing 20 7
vlan routing 145 8
exit
hostname "Dell6248"
sntp server 10.1.10.10 priority 2
clock summer-time recurring USA zone "EDT"
clock timezone -5 minutes 0 zone "EST"


stack
member 1 2
exit
ip address 10.1.2.2 255.255.255.0
ip default-gateway 10.1.2.3
ip domain-name oculab.local
ip name-server 10.1.10.10
no ipv6 enable
ip routing
ip route 0.0.0.0 0.0.0.0 10.1.20.3
ip helper-address 10.1.10.10
interface vlan 10
name "vlan10"
routing
bandwidth 10000
ip helper-address 10.1.10.10
ip local-proxy-arp
ip mtu 1500
exit
interface vlan 20
name "vlan20"


routing
ip address 10.1.20.2 255.255.255.0
bandwidth 10000
ip helper-address 10.1.10.10
ip mtu 1500
no ip unreachables
exit
interface vlan 30
name "Office Users"
routing
bandwidth 10000
ip helper-address 10.1.10.10
ip helper-address 10.1.10.10 dhcp
ip mtu 1500
exit
interface vlan 40
name "office computer"
routing
ip helper-address 10.1.10.10
ip helper-address 10.1.10.10 dhcp
exit

interface vlan 50
name "Production"
routing
bandwidth 10000
ip helper-address 10.1.10.10
ip mtu 1500
exit
interface vlan 70
name "Printer"
routing
ip helper-address 10.1.10.10
exit
interface vlan 145
name "Innova"
routing
exit
interface vlan 180
name "Office Wireless"
routing
ip helper-address 10.1.10.10
exit


username "admin" password 1510c0828bb8c2f024d788a7d17bc8a0 level 15 encrypted
dhcp l2relay
dhcp l2relay vlan 1,10-100,145,180
dhcp l2relay circuit-id vlan 10,20,30,40,50,70,145,180
!
interface ethernet 1/g1
switchport access vlan 10
exit
!
interface ethernet 1/g2
switchport access vlan 10
exit
!
interface ethernet 1/g3
switchport access vlan 10
exit
!
interface ethernet 1/g4
switchport access vlan 10
exit
!
interface ethernet 1/g5
switchport access vlan 10
exit
!
interface ethernet 1/g6
switchport access vlan 10
exit
!
interface ethernet 1/g7
switchport access vlan 10
exit
!
interface ethernet 1/g8
switchport access vlan 10
exit
!
interface ethernet 1/g9
switchport access vlan 10
exit
!
interface ethernet 1/g10
switchport access vlan 10
exit
!
interface ethernet 1/g11
switchport access vlan 10
exit
!
interface ethernet 1/g12
switchport access vlan 10
exit
!
interface ethernet 1/g13
dhcp l2relay
switchport access vlan 10
exit
!
interface ethernet 1/g14
switchport access vlan 10
exit
!
interface ethernet 1/g15
switchport access vlan 10
exit
!
interface ethernet 1/g16
switchport access vlan 10
exit
!
interface ethernet 1/g17
switchport access vlan 10
exit
!
interface ethernet 1/g18
switchport access vlan 10
exit
!
interface ethernet 1/g19
switchport access vlan 50
exit
!
interface ethernet 1/g20
switchport access vlan 10
exit
!
interface ethernet 1/g21
switchport access vlan 20
exit
!
interface ethernet 1/g22
switchport access vlan 30
exit
!
interface ethernet 1/g23
switchport access vlan 40
exit
!
interface ethernet 1/g24
switchport access vlan 50
exit
!
interface ethernet 1/g25
switchport access vlan 70
exit
!
interface ethernet 1/g26
switchport access vlan 180
exit
!
interface ethernet 1/g27
switchport access vlan 50
exit
!
interface ethernet 1/g28
switchport access vlan 50
exit
!
interface ethernet 1/g29
switchport access vlan 145
exit
!
interface ethernet 1/g30
switchport access vlan 50
exit
!
interface ethernet 1/g31
switchport access vlan 50
exit
!
interface ethernet 1/g32
switchport access vlan 50
exit
!
interface ethernet 1/g33
switchport access vlan 50
exit
!
interface ethernet 1/g34
switchport access vlan 50
exit
!
interface ethernet 1/g35
switchport access vlan 50
exit
!
interface ethernet 1/g36
interface ethernet 1/g36


switchport access vlan 50
exit
!
interface ethernet 1/g37
switchport access vlan 50
exit
!
interface ethernet 1/g38
switchport access vlan 50
exit
!
interface ethernet 1/g41
switchport access vlan 40
exit
!
interface ethernet 1/g43
switchport mode trunk
switchport trunk allowed vlan add 10,20,30,40,50,70,180
exit
!
interface ethernet 1/g44


switchport access vlan 180
exit
!
interface ethernet 1/g45
switchport mode trunk
switchport trunk allowed vlan add 10,20,30,40,50,70,145,180
exit
!
interface ethernet 1/g46
switchport access vlan 20
exit
!
interface ethernet 1/g47
switchport access vlan 30
exit
!
interface ethernet 1/g48
switchport access vlan 30
exit
!

interface port-channel 1
switchport access vlan 10
exit
!
interface port-channel 2
switchport access vlan 10
exit
!
interface port-channel 3
switchport access vlan 10
exit
!
interface port-channel 4
switchport access vlan 10
exit
!
interface port-channel 5
switchport access vlan 10
exit
!
interface port-channel 6
switchport access vlan 10

9 Posts

January 30th, 2012 13:00

To remove global IP routing, type this command from the enable prompt.

no ip routing

To remove routing per VLAN, type these commands.

interface vlan # (in the place of the # sign, type the VLAN ID)

no routing

If the DHCP Server and Client Computers are connected to the same VLAN, the trunk port will allow forwarding of DHCP requests to the DHCP Server.  If the DHCP Server and Client Computers are connected to two separate VLANs, then yes the trunk port from the Layer2 switch will communicate with the Layer3 device but only if you have routing configured on your Layer3 device.  The Layer3 device will act as the bridge between each VLAN.

The cleanest set up is to have one Layer3 device in the MDF act as your VLAN router for LAN traffic.  The other switches located in IDFs should communicate via a trunk.  Make sure the PC62XX does not perform any routing or you will be forced to create static routes or use a dymanic routing protocol for the two Layer3 devices to communicate.

The PC62XX acting only as a Layer2 device only needs to trunk VLANs that it wants to pass to the PC62XX that is acting as the Layer3 device.  The Layer3 device will do all inter-VLAN routing.

9 Posts

January 30th, 2012 14:00

No problem!  I always look at trying to keep the network as simple as possible because sometimes implementing routing just complicates the network and can also increase latencies between endpoints because of the processing the Layer3 devices need to do to move a packet from one point to another.

MDF = Main Distribution Frame - This is the main network closet/server room where each IDF will uplink to

IDF = Intermediate Distribution Frame - This is where each endpoint device will connect to

9 Posts

January 30th, 2012 12:00

On the Master Switch (Layer3), make sure you've also created a VLAN ID 145 and have added this VLAN to the uplink port that you've trunked to the Layer2 switch.  Both sides of the uplink (Layer3 and Layer2 switches) require VLAN ID 145 to be trunked so VLAN 145 traffic can pass through the uplink.  Make sure you're able to ping 10.1.10.10 from the Layer2 switch after the trunk is created.

If the Layer2 switch is not routing, be sure to remove static routes (anything starting with "ip route"), the global "ip routing" command, and also the command "routing" from VLAN interfaces.  I think an issue you're having is that the PowerConnect 6248 by default will try to route when a VLAN is created with the "routing" command specified.  Essentially, you want the PowerConnect 6248 to act as if it were a PowerConnect 5448 which is only Layer2.

Remove ip helper-address commands from your VLANs and global configuration from your Layer2 switch.  This command only needs to reside on the Layer3 device which I assume is acting as your core switch or MDF within your network.  I would only add the "ip helper-address 10.1.10.10 dhcp" command to the VLAN that requires DHCP client requests to be forwarded to a DHCP server.

I always say to keep things simple especially if there is no requirement for intra-site routing.  Have your core switch (MDF) do all your VLAN routing and each IDF simply will have an uplink that is trunked with the VLANs you want to pass traffic.

16 Posts

January 30th, 2012 13:00

What command should I issue from the cli to remove the routing ? Also I do have dhcp client connected on the "layer 2" dell switch if I remove the ip-helper line how will they find the dhcp server? Are they gonna find it by going to the trunk and grab it from the layer 3 core ?

16 Posts

January 30th, 2012 13:00

Thanks for the information, very helpfull. I wanted to have the setup that way from the beginning ( 1 layer 3 device and 1 layer 2) but it seem my config were badly done from start. One more newbie question, what does MDF ans IDF stand for ?

Thanks !

20 Posts

October 16th, 2012 00:00

I can't figure out how to get vlan routing enabled via CLI. Your config has an the following:

vlan routing 30 1

...

Can you provide a CLI example to get this vlan routing statement to appear in my config?

802 Posts

October 16th, 2012 10:00

In order to enable routing for a specific VLAN you would enter the VLAN interface in this case VLAN 10.

console# config

console(config)# interface vlan 10

console(config-if-vlan10)# routing    (enable routing for VLAN 10)

console(config-if-vlan10)# ip address 172.16.1.1     (set IP address for VLAN to route) (this would be the gateway address of any device connected to the VLAN)

Hope this helps,

Keep us updated if you can.

No Events found!

Top