Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

19505

March 8th, 2014 07:00

Powerconnect Switch and Cisco Routers

I have 4 Cisco routers connected to our Dell Powerconnect 7024. This is  a lab environment where I am trying to have each router (2 per site) act as a WAN access point for these 2 sites.

              Site 1                                                                                                                           Site 2

                                                        Router 2                                         Router 3

Client PC ------Dumb_switch                         PowerConnect                            Dumb_switch------Client PC

                                                        Router 1                                         Router 4 

There are a few other Vlans on the switch with connected devices. With the current configuration, these two sites can communicate with any other 'site' connected to the switch over either route, except for each other. 

The interfaces directly connected to the router are in trunk mode, as this is the only way I could get the dell to communicate with the Cisco. Ive read in other threads that general mode is usually suggested on the powerconnect, but did not have any luck with that setup.

Router 1 -----> Gi1/0/15 (vlan 10)

Router 2 ----->Gi1/0/14 (vlan 11)

Router 3 ----->Gi1/0/22 (vlan 16)

Router 4 ----->Gi1/0/23 (vlan 14)

Example: a ping from Site 1 can reach int 22 of the switch with no problem, but I cannot ping next hop to R3. Since every other device on this switch can talk to these sites I am not clear on if the issue is my config of the dell switch or on the routers. Any input would be greatly appreciated. Thanks!

!Current Configuration:
!System Description "PowerConnect 7024, 5.1.2.3, VxWorks 6.6"
!System Software Version 5.1.2.3
!System Operational Mode "Normal"
!
configure
gvrp enable
vlan 2-7,9-14,16
exit
vlan 2
name "BOSTON"
exit
vlan 3
name "MIAMI"
exit
vlan 4
name "LA"
exit
vlan 5
name "SEATTLE"
exit
vlan 6
name "DALLAS"
exit
vlan 7
name "London"
exit
vlan 9
name "Frankfurt"
exit
vlan 10
name "Rome"
exit
vlan 11
name "Sczecin"
exit
vlan 12
name "Budapest"
exit
vlan 13
name "Moscow"
exit
vlan 14
name "Quebec"
exit
--More-- or (q)uit
vlan 16
name "Winnipeg"
exit
hostname "Devlin"
slot 1/0 2 ! PowerConnect 7024
clock timezone -5 minutes 0
stack
member 1 2 ! PCT7024
exit
interface out-of-band
shutdown
exit
no ip domain-lookup
ip domain-name "local"
ip routing
ip route 0.0.0.0 0.0.0.0 172.16.37.3
ip route 172.16.37.160 255.255.255.240 172.16.37.162
ip route 172.16.37.112 255.255.255.240 172.16.37.162
ip route 172.16.37.112 255.255.255.240 172.16.37.147
ip route 172.16.37.144 255.255.255.240 172.16.37.147
ip route 172.16.37.240 255.255.255.240 172.16.37.244
ip route 172.16.37.224 255.255.255.240 172.16.37.244
ip route 172.16.37.224 255.255.255.240 172.16.37.217
--More-- or (q)uit
ip route 172.16.37.208 255.255.255.240 172.16.37.217
arp 172.16.37.162 0022.9057.7F51
interface vlan 1
ip address 172.16.37.4 255.255.255.240
bandwidth 10000
ip ospf cost 10
exit
interface vlan 2
ip address 172.16.37.17 255.255.255.240
exit
interface vlan 3
ip address 172.16.37.33 255.255.255.240
exit
interface vlan 4
ip address 172.16.37.49 255.255.255.240
exit
interface vlan 5
ip address 172.16.37.65 255.255.255.240
exit
interface vlan 6
ip address 172.16.37.81 255.255.255.240
exit
interface vlan 7
--More-- or (q)uit
ip address 172.16.37.97 255.255.255.240
exit
interface vlan 9
ip address 172.16.37.129 255.255.255.240
bandwidth 10000
exit
interface vlan 10
ip address 172.16.37.145 255.255.255.240
bandwidth 1000
ip irdp
exit
interface vlan 11
ip address 172.16.37.161 255.255.255.240
bandwidth 1000
ip irdp
exit
interface vlan 12
ip address 172.16.37.177 255.255.255.240
bandwidth 100000
exit
interface vlan 13
ip address 172.16.37.193 255.255.255.240
bandwidth 1000
exit
interface vlan 14
ip address 172.16.37.209 255.255.255.240
bandwidth 1000
exit
interface vlan 16
ip address 172.16.37.241 255.255.255.240
bandwidth 1000
ip ospf cost 100
exit
no flowcontrol
!
interface Gi1/0/3
spanning-tree portfast
exit
!
interface Gi1/0/4
spanning-tree portfast
exit
!
interface Gi1/0/5
spanning-tree portfast
switchport access vlan 2
exit
!
interface Gi1/0/6
spanning-tree portfast
switchport access vlan 3
exit
!
interface Gi1/0/7
spanning-tree portfast
switchport access vlan 4
exit
!
interface Gi1/0/8
spanning-tree portfast
switchport access vlan 5
exit
!
interface Gi1/0/9
switchport access vlan 6
exit
!
interface Gi1/0/10
switchport access vlan 7
exit
!
interface Gi1/0/11
spanning-tree portfast
switchport mode trunk
exit
!
interface Gi1/0/12
spanning-tree portfast
switchport mode trunk
exit
!
interface Gi1/0/13
switchport access vlan 9
exit
!
interface Gi1/0/14
speed 100
duplex full
switchport mode trunk
switchport general allowed vlan add 10 tagged
switchport access vlan 10
exit
!
interface Gi1/0/15
speed 100
duplex full
switchport mode trunk
switchport general allowed vlan add 11 tagged
switchport access vlan 11
exit
!
interface Gi1/0/16
switchport access vlan 12
exit
!
interface Gi1/0/17
switchport access vlan 12
exit
!
interface Gi1/0/18
switchport access vlan 13
exit
!
interface Gi1/0/19
switchport access vlan 13
exit
!
interface Gi1/0/22
speed 100
duplex full
switchport mode trunk
switchport general allowed vlan add 16 tagged
switchport access vlan 16
exit
!
interface Gi1/0/23
speed 100
duplex full
switchport mode trunk
switchport general allowed vlan add 14
switchport access vlan 14
exit
!
interface Gi1/0/24

Moderator

 • 

8.7K Posts

March 13th, 2014 16:00

You could probably create a static route from router 1 to router 4 with a priority that is better than the other options so it goes there unless the link is down.

Moderator

 • 

8.7K Posts

March 10th, 2014 09:00

Hi,

Trunk mode is fine if all of the VLANs are tagged. Does the dumb switch handle VLANs? Does each switch have both routers connected to it?

 

It looks like the flow of the ping:

Client 1 sends ping out across an access port.

The 7024 receives the ping, sees that it does not belong to anything on that it knows the location of.

The 7024 sends the ping to its default route across the trunk port to router 1.

Router 1 or 2 receives it, can’t process it itself and then goes to the next hop, router 3.

Router 3 receives the ping and sends it out the trunk port to the unmanaged switch.

The unmanaged switch sends it out and should be seen by client 2.

 

Since the ping is reaching router 3 or 4, they are not sure where to send the packet, or the unmanaged switch is unsure of where to send the packet.

If you ping the other direction from a client on the router 3 or 4 side to a client on router 1 or 2 side does reach the router? Can it reach the 7024?

March 13th, 2014 16:00

Hi Josh,

Thanks for the reply. I managed to figure out the issue of the sites not communicating. I had configured on each of the routers a sub-interface for each subnet located behind the routers. Because of this, the routers did not know where to send the traffic.

The only step left is getting a reliable route between routers 1 and 4. The issue I face now is any traffic I send out of router 1 towards site 2 is directed by the switch to router 3. 

Is it possible for instance to create a rule or static route that says 'any traffic coming from router 1 - next hop router 4' (from the 7024 config it would be any traffic entering the switch on int 15 (.161) next hop int 23 (.209), and vice versa?

If im not being clear enough just let me know.

Regards

No Events found!

Top