anh2lua35
1 Copper

VLAN Routing Configuration with Trunk Ports

We have a few ESX Hosts that we want to use for hosting several VMs in different subnets.

We also have two Dell PowerConnect 6248P where the ESX hosts are connected to. We are planning to let the ESX Virtual Switch doing the tagging (one virtual switch with several port groups, each with a different VLAN ID).

On the PowerConnect, let's assume we want ports 1/g1-g10 and 2/g1-g2 be the ports connected to the ESX hosts, and that we want them to be part of VLANs 50-85. Port 1/g11 is the uplink port of the switches (they are stacked).

We also have other hosts on these same switches that are on default VLAN.

My configuration is as follows:

vlan database
vlan 50-85

ip routing
ip route 0.0.0.0 0.0.0.0 10.1.0.250 (10.1.0.250 is the default gateway for all hosts on the default VLAN)

interface vlan 1
interface vlan 50
routing
ip address  10.3.50.253  255.255.255.240

interface vlan 51
routing
ip address 10.3.51.253 255.255.255.240

interface vlan 52
routing
ip address 10.3.52.253 255.255.255.240

interface vlan 53
routing
ip address 10.3.53.253 255.255.255.240

and so on.....

interface ethernet 1/g1
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only (does this allow traffic from VLAN 1 to pass through?)
switchport general allowed vlan add 50-85 tagged
exit

interface ethernet 1/g2
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g3
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g4
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g5
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g6
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g7
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g8
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g9
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 1/g10
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit

interface ethernet 1/g11 (this is the uplink port to the router)
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit


interface ethernet 2/g1
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g2
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g3
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g4
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g5
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g6
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g7
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g8
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g9
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit
interface ethernet 2/g10
mdix on
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 50-85 tagged
exit

 

On the router, I have the following configuration

interface g0/1.50
ip address 10.3.50.254 255.255.255.240
encapsulation dot1Q 50

interface g0/1.51
ip address 10.3.51.254 255.255.255.240
encapsulation dot1Q 51

and so on...

If I used the default gateway of the VLAN interface on the switch, the VMs cannot ping anything outside of their own subnet. If I used the default gateway of the subinterfaces on the router as configured above, the VMs can ping anything on the network.

What am I missing on the switch configuration to allow routing between VMs on those VLANs, from 50-85 without having to traverse the router?

Thanks in advance!

0 Kudos
4 Replies
Anaraendil
2 Iron

Re: VLAN Routing Configuration with Trunk Ports

Hi,

You haven't enabling routing in VLAN interfaces. To do that enter vlan routing X in VLAN configuration mode: http://support.dell.com/support/edocs/network/PC62XX/en/CLI/HTML/VLAN.htm#1182142

Also your suggestions about no switchport general acceptable-frame-type tagged-only are absolutely correct, but dy default all frames are accepted so it's a litlle bit excessive configuration

0 Kudos
anh2lua35
1 Copper

Re: VLAN Routing Configuration with Trunk Ports

interface vlan 50

routing is the only option available in vlan configuration mode.

Looks like the no switchport general acceptable-frame-type tagged-only is entered by default when I enabled the general mode.

Thanks

0 Kudos
Anaraendil
2 Iron

Re: VLAN Routing Configuration with Trunk Ports

Hi,

My mistake, I haven't noticed that you already activated routing on all VLANs.

Can you post here output of show ip brief, show ip interface vlan X for one or two VLANs and a part of show ip route?

0 Kudos
anh2lua35
1 Copper

Re: VLAN Routing Configuration with Trunk Ports

 Thanks for replying.

I already contacted support this morning and for what I want to accomplish, these won't work.

0 Kudos