parkcitygolfer
1 Copper

Vlan not Working on 6224

Sorry I am new to dell switches. I am more familiar with Procurve. I have 3 vlans on my 2 stacked 6224 switches, but only the default vlan 1 works. The other two cannot ping out at all. 

!Current Configuration:
!System Description "PowerConnect 6224, 3.3.3.3, VxWorks 6.5"
!System Software Version 3.3.3.3
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 2,4
exit
hostname "VM-LAN-STACKED"
stack
member 1 1
member 2 1
exit
ip address 172.17.10.50 255.255.0.0
interface vlan 2
name "phones"
exit
interface vlan 4
name "DMZ"
exit


username "admin" password 58bcac9276704e7f10e73d5fbcc75a53 level 15 encrypted
line ssh
exec-timeout 20
exit
ip ssh server
spanning-tree priority 61440
!
interface ethernet 1/g4
switchport access vlan 4
exit
!
interface ethernet 1/g5
switchport access vlan 4
exit
!
interface ethernet 1/g6
switchport access vlan 4
exit
!
interface ethernet 1/g7
switchport access vlan 2


exit
!
interface ethernet 1/g8
switchport access vlan 2
exit
!
interface ethernet 1/g9
switchport access vlan 2
exit
!
interface ethernet 1/g20
channel-group 1 mode auto
description 'UPLINKTOCORE'
spanning-tree portfast
exit
!
interface ethernet 2/g4
switchport access vlan 4
exit
!
interface ethernet 2/g5


switchport access vlan 4
exit
!
interface ethernet 2/g6
switchport access vlan 4
exit
!
interface ethernet 2/g7
switchport access vlan 2
exit
!
interface ethernet 2/g8
switchport access vlan 2
exit
!
interface ethernet 2/g9
switchport access vlan 2
exit
!
interface ethernet 2/g20
channel-group 1 mode auto


description 'UPLINKTOCORE'
spanning-tree portfast
exit
!
interface port-channel 1
spanning-tree portfast
switchport mode general
exit
enable password 58bcac9276704e7f10e73d5fbcc75a53 encrypted
exit

0 Kudos
6 Replies
Moderator
Moderator

RE: Vlan not Working on 6224

Hi,

Are the other VLANs connected to other switches or to client PCS? Is there routing between the VLANs on this switch or another layer 3 switch in the network? Can two devices on VLAN 4 ping each other? Are the phones getting DHCP from somewhere on VLAN 2? If this is a new implementation I would recommend installing the latest firmware on the stack. http://www.dell.com/support/drivers/us/en/555/DriverDetails/Product/powerconnect-6224?driverId=77XG3...

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
parkcitygolfer
1 Copper

RE: Vlan not Working on 6224

The other vlans are routed from our adtran 4430 that is connected to two hp procurve 2910's. the phones are getting dhcp from the adtran on vlan 2. this is a relatively new implementation but its connected to our production vmware farm. i am planning downtime to get the firmware updated soon. I was just looking at the dell openmanage switch web page for the switch and wondered if i need to tag or untag vlan 2 on the LAG? If so how do i do that. Thanks for your help. 

0 Kudos
Moderator
Moderator

RE: Vlan not Working on 6224

Yes you may need to specify what VLANs the LAG is accessing with the command switchport general allowed vlan 2 tagged page 598 ftp://ftp.dell.com/Manuals/all-products/esuprt_ser_stor_net/esuprt_powerconnect/powerconnect-6248_Re...

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
parkcitygolfer
1 Copper

RE: Vlan not Working on 6224

so i would go to configure then interface port-channel 1 then switchport general allowed vlan 2 ? 

will this change any other settings on that lag? im worried about making this change during work hours if it will change the membership of the default vlan?  

sorry clueless on dell switches. thanks again

0 Kudos
Moderator
Moderator

RE: Vlan not Working on 6224

Those are the correct steps, it will have that LAG pass just that VLAN unless others are specified as well and should not change any of the other settings, but it still might be better to wait until after work hours in case it not passing VLAN 1 becomes an issue.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
parkcitygolfer
1 Copper

RE: Vlan not Working on 6224

Solved. Thanks for your help. 

0 Kudos