Start a Conversation

Unsolved

This post is more than 5 years old

58741

January 19th, 2012 06:00

change vlan over snmp - powerconnect 6248

I'm trying to change vlan membership and pvid using snmp.

After reading http://en.community.dell.com/support-forums/network-switches/f/866/t/19431493.aspx I tried doing it myself using iReasoning MIB Browser on my powerconnect 6248 and failed.

I followed the instructions by changing all ports to general mode (is it really necessary?) and created PortList arrays for all 6 varialbles:

dot1qVlanStaticEgressPorts on new vlan

dot1qVlanForbiddenEgressPorts on new vlan

dot1qVlanStaticUntaggedPorts on new vlan

dot1qVlanStaticEgressPorts on old vlan

dot1qVlanForbiddenEgressPorts on old vlan

dot1qVlanStaticUntaggedPorts on old vlan

The set action (all variables must in one action) return success (noError), but the actual values on the switch are not changed.

BTW - the pvid set action succeeded, but has no real impact on the vlan membership.

Moderator

 • 

7.1K Posts

January 19th, 2012 13:00

Hello,

It would really help to have a little more information like which ports are being assigned to which vlans, etc.  if you could run show run command should show us all that information needed to see where the hang up is coming from.  

Here is a basic setup of a Vlan which you can check to make sure that you set them up correctly and not missing any thing:

Set up the Vlans you want.

console> enable

console# config

console(config)# vlan database

console(config-vlan)# vlan 2

console(config-vlan)# exit

console(config)# interface vlan 2

console(config-if)# name Marketing

console(config-if)# end

 

Once the Vlan is created you can then add ports to the Vlan

console> enable

console# config

console(config)# interface ethernet 1/e1

console(config-if)# switchport access vlan 1

 

Here are the differences in VLAN Link types, usually Acess mode would be used.

 

Access Links connect VLAN unaware devices to the port of a VLAN-aware switch. All frames on access links are untagged.

 

The VLAN switch adds tags to received frames, and removes tags when transmitting frames.

 

End users and VLAN-unaware workstations commonly reside on access links. By Default all ports are in ACCESS mode assigned to the default VLAN (VLAN 1). Ports set to Access mode belong to one VLAN only.

General Links consist of a combination of VLAN Trunk and Access Links.

General Links can have both tagged and untagged frames, However, all frames sent to a specific VLAN must be tagged.  All untagged  frames are sent to the native VLAN.

The native VLAN still applies to the General LINK.  While it is possible to have multiple untagged vlans on a General link, you can only have ONE (1) PVID.  The PVID represents the native VLAN.  

While untagged traffic may be sent via several untagged VLANs, returning untagged traffic will only be received by the PVID and therefore will NOT be forwarded to a specific VLAN.

General links are mostly used today for legacy equipment.  However, on the PowerConnect 62xx series switches, you must use General mode if you want to allow management traffic onto the switch over the PVID.  If you use Trunk mode, you will not have the default VLAN on those ports.  The ports will only allow tagged traffic.

This is the command you would use to set the mode

console(config-if)# switchport mode access

Or change it to general instead of access,or if you want general.

Once the VLAN are setup I would check to make sure the clients that connect to each vlan, can communicate.

Once they can communicate then move on to setting up SNMP

setup snmp

Next is to setup the snmp.

Here is an example of the configuration.

console# configure

console(config)# snmp-server community public rw ip address 172.16.x.xx

console(config)# snmp-server enable traps all

console(config)# snmp-server trap authentication

console(config)# snmp-server host 172.16.x.xx public traps v2

console(config)# snmp-server host 172.16.x.xx public informs

console(config)# snmp contact "John Smith"

console(config)# snmp location "RR7 First Floor"

Once this is setup the host IP should be receiving any SNMP traffic the switch sends out.

You can manage the switch with an SNMP-compatible console application such as Dell OpenManage Network Manager  . The switch is compatible with SNMP version 1.0.

5 Posts

January 20th, 2012 02:00

Sorry to hijack this thread, but I'm having a similar problem of setting values over snmp, no error returned, but values not applied.

My setup:

Q-BRIDGE-MIB::dot1qVlanStaticName.1 = STRING: Default
Q-BRIDGE-MIB::dot1qVlanStaticName.101 = STRING:
Q-BRIDGE-MIB::dot1qVlanStaticEgressPorts.1 = Hex-STRING: 00 00 00 00 00 03 C0 00 00 00 00 00 00 00 00 00
Q-BRIDGE-MIB::dot1qVlanStaticEgressPorts.101 = Hex-STRING: 80 00 00 00 00 03 00 00 00 00 00 00 00 00 00 00
Q-BRIDGE-MIB::dot1qVlanForbiddenEgressPorts.1 = Hex-STRING: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Q-BRIDGE-MIB::dot1qVlanForbiddenEgressPorts.101 = Hex-STRING: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Q-BRIDGE-MIB::dot1qVlanStaticUntaggedPorts.1 = Hex-STRING: 00 00 00 00 00 03 C0 00 00 00 00 00 00 00 00 00
Q-BRIDGE-MIB::dot1qVlanStaticUntaggedPorts.101 = Hex-STRING: 80 00 00 00 00 03 00 00 00 00 00 00 00 00 00 00
Q-BRIDGE-MIB::dot1qVlanStaticRowStatus.1 = INTEGER: active(1)
Q-BRIDGE-MIB::dot1qVlanStaticRowStatus.101 = INTEGER: active(1)

The problem:

$ snmpset -v2c 10.21.0.139 Q-BRIDGE-MIB::dot1qVlanStaticUntaggedPorts.101 x "80000000000000" Q-BRIDGE-MIB::dot1qVlanStaticEgressPorts.101 x "80000000000300"

$ snmpwalk -mQ-BRIDGE-MIB 10.21.0.139 Q-BRIDGE-MIB::dot1qVlanStaticUntaggedPorts.101
Q-BRIDGE-MIB::dot1qVlanStaticUntaggedPorts.101 = Hex-STRING: 80 00 00 00 00 03 00 00 00 00 00 00 00 00 00 00

Why does dot1qVlanStaticUntaggedPorts.101 still includes port 47 and 48? I need port 47, 48 *tagged* in VLANs >1

5 Posts

January 20th, 2012 02:00

19 Posts

January 25th, 2012 01:00

I would check what your SNMP tool actually does, i.e. what oid+value it sends in the set operations, and what values the switch return for each operation. I would use Wireshark for this, and I would also try to duplicate the setup with the tools like snmpset/snmpget from Net-SNMP, before moving on to a more complex tool.

I successfully modified the vlan configuration on a Dell M6220 using the steps described in the other thread. As for the note about ports having to be in general mode: If i remember correctly, they will end up in general mode if you start configuring a switch from a clean config. I don't know what will happen if you modify a port that is already in access or trunk mode. Give it a shot and let me know what you find.

5 Posts

January 26th, 2012 05:00

Hi. Thanks for your reply. I did already check the requests using wireshark, and the snmp* commands are from Net-SNMP. Setting the VLANs this way works fine on 2 models of dlink switches. All the interfaces in question are in 'general' mode.

Looking at "show running-config", it has (as a result of the snmpset):

interface ethernet 1/g48
switchport mode general
switchport general allowed vlan add 101

I configured it manually over the console to tag 101 on port 48 and it generated:

interface ethernet 1/g48
switchport mode general
switchport general allowed vlan add 101 tagged

Could this be a bug? I can't find any Dell documentation on the correct way of creating and manipulating VLANs over SNMP, so I'm not sure if I'm doing it correctly.

5 Posts

February 7th, 2012 13:00

I finally got it working! I'm using VLAN 100 as an example. Vlan 100 is untagged on port 1/g3 and tagged on ports 1/xg3 and 1/xg4.

I used "snmpset" (e.g. snmpset -cCOMMUNITY -v2c ... ) to set these oids IN SEPARATE REQUESTS! (This is important - do not set the oids in one snmp command):

snmpset 1.3.6.1.2.1.17.7.1.4.3.1.5.100 i 4 - create the vLAN
snmpset 1.3.6.1.2.1.17.7.1.4.3.1.2.100 x 20000000000030 - set the egress (ports 1/g3, 1/xg3, 1/xg4)
snmpset 1.3.6.1.2.1.17.7.1.4.3.1.4.100  x 20000000000000 - set the untagged list (port 1/g3)
snmpset 1.3.6.1.2.1.17.7.1.4.5.1.1.3 u 100 - set the PVID of port 3 to 100
snmpset 1.3.6.1.2.1.17.7.1.4.3.1.1.100 s "vlan100" - set vlan name (optional)

(If you have the Q-BRIDGE-MIB installed and configured correctly, you can use Q-BRIDGE-MIB::dot1qVlanStaticName etc instead of the raw OID - see http://www.oidview.com/mibs/0/Q-BRIDGE-MIB.html)

This seems to be sufficient to put the ports in general mode, which is what I want. It also seems possible to overwrite the egress/untagged lists without deleting the VLAN, which is awesome.

4 Posts

February 8th, 2012 05:00

The VLAN switch adds tags to received frames, and removes tags when transmitting frames. 

No Events found!

Top