Highlighted
dzsino
1 Nickel

WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi, on brand new 3521 laptop with Win7 Pro the WLAN connects to selected wireless router but fails to establish internet connection.

WLan Driver 1703 was duly installed after the Chipset driver were installed , as recommended.

Other mobile devices happily connect to same router. Ubuntu on this laptop was also happy to connect to internet on WLAN, only Win7 fails.

Turned off Win7 firewall , but no change. Shows unidentified connection in Network and Sharing Center.   Router SSID etc were correctly entered. Deleted WLAN profile and reentered , no change.

Tried to connect to another wireless router with same result. I can only run this laptop on wired connection to the router. 

I am at a loss as to what other steps I could take to fix this WLan / internet connection.

Any suggestions would be welcome. Cheers.

0 Kudos
1 Solution

Accepted Solutions
dzsino
1 Nickel

Re: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi Amogh,

Thanks for your advice. I deleted the profiles ( two identical found !) , also deleted all entries of all WiFi routers in the Win 7 Registry. This step did not resolve the issue.

However I found the reason for the connection trouble and the solution is as follows:

In the Wireless Router being connected to  (TP-LINK) , the Wireless Settings --> Channel was set to "AUTO" (which is automatically selecting 20MHz or 40MHz) .

In the Dell WLAN 1703 Device driver (Properties --> Advanced --> 802.11 n Bandwidth , the value was set to (ie the Atheros default is !!)  "20MHz".

Once I set the value to option "20MHz / 40MHz Auto" , the connection sprang to life.

What a relief !!!

The matter is now completely resolved. Thank you for all of you who contributed.

Best regards Dzsino.

9 Replies

Re: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi dzsino,

You may make the changes in wireless card settings as mentioned below:

  • Open Device Manager
  • Expand ‘Network Adapters’, right click the wireless card and choose ‘Properties’
  • Click ‘Advanced’
  • Disable 802.11b Preamble to Long
  • Change Receive Buffers to 300
  • Change Transmit Buffers to 500
  • Click ‘Power Management’
  • Uncheck ‘Allow the computer to turn off this device to save power’

Keep me posted with the results. I will be glad to assist further.

Thanks & Regards
Amogh G
#iworkfordell
To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

0 Kudos
dzsino
1 Nickel

Re: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi Amogh,

Thank you for your prompt reply.

I have carried out your suggestions but unfortunately has not resolved the issue. The Laptop is happy to connect to the internet when wired to the router (TP-Link WR841N) but not when trying to access via WiFi. I am trying to resolve this using remotely as the laptop is in another country.

I assume that LAN and WiFi cannot connect to the internet at the same time , but even when the LAN cable is removed , the WiFi still says "unidentified network". As mentioned earlier , when Ubuntu 12.04 was installed , the Wifi connection to this router was working fine which shows that the WLAN / BT interface HW must be OK .The owner would like to use Win 7 Pro though ,  not Ubuntu. I can ping / run admin on a browser to the router no problem when wired. I took the systeminfo and ipconfig. The router dishes out 192.168.0.102 for the LAN and 169.254.17.218 for the Wifi. The router shows the mac address of the laptop in its Wifi list.

BR , dzsino

0 Kudos
8 Krypton

Re: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

dzsino,

 

Please continue with Amogh

 

The 169.254 ip address tells me there is a communication problem with the wireless router. Try...

 

Power off your ISP modem/router and your wireless router(if any) for 30 seconds. Then power on the ISP modem/router. Wait 15 seconds, then power on the wireless router(if any)

Restart the computer and try to connect.

What happens?

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
dzsino
1 Nickel

Re: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi Amogh,

I quite agree with Rick below that there is a basic connection issue with the router. I checked the IPconfig for the wired LAN and its address is correct as is  its DHCP server address (same as the address of the router).Surprisingly the BT addresses are also correct.However for the WiFi not only the preferred IP address is completely bogus and well outside the range for the router as per its documentation, there is no entry for DHCP server for the Wifi in IPconfig's listing.I am surprised as the WLAN and BT driver are in one install module and I expected both to fail at the same time. Double checked the HW, it is listed in systeminfo as 1703 for sure. The driver that was installed following the chipset drivers is 9.2.0.504, A02 which is what comes up in Dell's product support for Win 7 with the service tag of the 3521.So far the only sign of life are : 1. Win7 lists all the surrounding WiFi routers with correct signal strength and correct routher credentials. 2. There is a "Connected Status" for the selected router at 150MBs 3.  the router lists the WiFi MAC of the 3521 correctly though with only 2bytes in both received / transmitted in its wireless connection list. (checked via wired connection to router). Any further tests or suggestions would be welcome. Thanks.BR Dzsino

0 Kudos

Re: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi dzsino,

I would suggest you to delete all the wireless profiles listed on the system and create a new wireless profile. You may disable the WLAN security temporarily and then try to reconnect to the newly created wireless profile. Please refer to the link: http://bit.ly/13vBdpv.

Keep me posted with the results. I will be glad to assist further.

Thanks & Regards
Amogh G
#iworkfordell
To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

0 Kudos
dzsino
1 Nickel

Re: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi Amogh,

Thanks for your advice. I deleted the profiles ( two identical found !) , also deleted all entries of all WiFi routers in the Win 7 Registry. This step did not resolve the issue.

However I found the reason for the connection trouble and the solution is as follows:

In the Wireless Router being connected to  (TP-LINK) , the Wireless Settings --> Channel was set to "AUTO" (which is automatically selecting 20MHz or 40MHz) .

In the Dell WLAN 1703 Device driver (Properties --> Advanced --> 802.11 n Bandwidth , the value was set to (ie the Atheros default is !!)  "20MHz".

Once I set the value to option "20MHz / 40MHz Auto" , the connection sprang to life.

What a relief !!!

The matter is now completely resolved. Thank you for all of you who contributed.

Best regards Dzsino.

Giopat
1 Copper

RE: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi,

Same identical issue on XPS One 27! Several hours struggling for a stable solution. Dzsino proposed solution worked also for me.

Great Dzsino!

Best Regards,

Giopat

0 Kudos
pradeep9ch
1 Copper

RE: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

Hi,

I bought a new DELL Inspiron 3521. when iam trying to connect to wireless(Windows 8), but unable to do so. I verified the device manager- network controller under Other Devices. Here are my details.

PCI\VEN_168C&DEV_0036&SUBSYS_020C1028&REV_01
PCI\VEN_168C&DEV_0036&SUBSYS_020C1028
PCI\VEN_168C&DEV_0036&CC_028000
PCI\VEN_168C&DEV_0036&CC_0280

Can Please help me out... Thanks

Thanks,

PradeepCh

0 Kudos
MarcosFreddo
1 Copper

RE: WLAN connects to router but no internet connection on 15R 3521

Jump to solution

In your network properties, enable compliance with fips

0 Kudos